summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-24 04:24:06 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-24 04:24:06 +0000
commit25250db3002017530c6eb0d6661704dbcc19e0e7 (patch)
tree4933d3d360c6af63aaf372c7cb4881a072ae62dc
parentVersion bump. (diff)
downloadgentoo-2-25250db3002017530c6eb0d6661704dbcc19e0e7.tar.gz
gentoo-2-25250db3002017530c6eb0d6661704dbcc19e0e7.tar.bz2
gentoo-2-25250db3002017530c6eb0d6661704dbcc19e0e7.zip
Version bumps #460646 by Andrej Filipcic.
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
-rw-r--r--net-fs/openafs/ChangeLog10
-rw-r--r--net-fs/openafs/openafs-1.4.14.1-r1.ebuild147
-rw-r--r--net-fs/openafs/openafs-1.6.1-r3.ebuild150
-rw-r--r--net-fs/openafs/openafs-1.6.2.ebuild150
4 files changed, 456 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 34210cb3e1ed..610314ee3143 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-fs/openafs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.188 2013/03/17 15:55:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.189 2013/03/24 04:24:06 vapier Exp $
+
+*openafs-1.6.1-r3 (24 Mar 2013)
+*openafs-1.4.14.1-r1 (24 Mar 2013)
+*openafs-1.6.2 (24 Mar 2013)
+
+ 24 Mar 2013; Mike Frysinger <vapier@gentoo.org> +openafs-1.4.14.1-r1.ebuild,
+ +openafs-1.6.1-r3.ebuild, +openafs-1.6.2.ebuild:
+ Version bumps #460646 by Andrej Filipcic.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/net-fs/openafs/openafs-1.4.14.1-r1.ebuild b/net-fs/openafs/openafs-1.4.14.1-r1.ebuild
new file mode 100644
index 000000000000..5a241241d7ce
--- /dev/null
+++ b/net-fs/openafs/openafs-1.4.14.1-r1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.14.1-r1.ebuild,v 1.1 2013/03/24 04:24:06 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils autotools toolchain-funcs versionator pam
+
+MY_PV=$(get_version_component_range 1-4)
+PVER="2"
+DESCRIPTION="The OpenAFS distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+SRC_URI="http://openafs.org/dl/${MY_PV}/${P}-src.tar.bz2
+ http://openafs.org/dl/${MY_PV}/${P}-doc.tar.bz2
+ mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="doc kerberos pam"
+
+RDEPEND="~net-fs/openafs-kernel-${PV}
+ pam? ( sys-libs/pam )
+ kerberos? ( virtual/krb5 )"
+
+src_prepare() {
+ EPATCH_EXCLUDE="012_all_kbuild.patch" \
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/gentoo/patches
+
+ # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
+ sed -i '/^a/s:^:e:' regen.sh
+ skipman=1
+ . regen.sh
+}
+
+src_configure() {
+ # cannot use "use_with" macro, as --without-krb5-config crashes the econf
+ local myconf=""
+ if use kerberos; then
+ myconf="--with-krb5-conf=$(type -p krb5-config)"
+ fi
+
+ AFS_SYSKVERS=26 \
+ XCFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable pam) \
+ --enable-largefile-fileserver \
+ --enable-supergroups \
+ --disable-kernel-module \
+ --disable-strip-binaries \
+ ${myconf}
+}
+
+src_compile() {
+ emake -j1 all_nolibafs || die
+}
+
+src_install() {
+ local CONFDIR=${WORKDIR}/gentoo/configs
+ local SCRIPTDIR=${WORKDIR}/gentoo/scripts
+
+ emake -j1 DESTDIR="${D}" install_nolibafs || die
+
+ insinto /etc/openafs
+ doins src/afsd/CellServDB || die
+ echo "/afs:/var/cache/openafs:200000" > "${D}"/etc/openafs/cacheinfo
+ echo "openafs.org" > "${D}"/etc/openafs/ThisCell
+
+ # pam_afs and pam_afs.krb have been installed in irregular locations, fix
+ if use pam ; then
+ dopammod "${D}"/usr/$(get_libdir)/pam_afs* || die
+ fi
+ rm -f "${D}"/usr/$(get_libdir)/pam_afs* || die
+
+ # remove kdump stuff provided by kexec-tools #222455
+ rm -rf "${D}"/usr/sbin/kdump*
+
+ # avoid collision with mit_krb5's version of kpasswd
+ mv "${D}"/usr/bin/kpasswd{,_afs} || die
+ mv "${D}"/usr/share/man/man1/kpasswd{,_afs}.1 || die
+
+ # move lwp stuff around #200674 #330061
+ mv "${D}"/usr/include/{lwp,lock,timer}.h "${D}"/usr/include/afs/ || die
+ mv "${D}"/usr/$(get_libdir)/liblwp* "${D}"/usr/$(get_libdir)/afs/ || die
+ # update paths to the relocated lwp headers
+ sed -ri \
+ -e '/^#include <(lwp|lock|timer).h>/s:<([^>]*)>:<afs/\1>:' \
+ "${D}"/usr/include/*.h \
+ "${D}"/usr/include/*/*.h \
+ || die
+
+ # minimal documentation
+ use pam && doman src/pam/pam_afs.5
+ dodoc "${CONFDIR}"/README src/afsd/CellServDB
+
+ # documentation package
+ if use doc ; then
+ dodoc doc/{arch,examples,pdf,protocol,txt}/*
+ dohtml -A xml -r doc/{html,xml}/*
+ fi
+
+ # Gentoo related scripts
+ newinitd "${SCRIPTDIR}"/openafs-client openafs-client || die
+ newconfd "${CONFDIR}"/openafs-client openafs-client || die
+ newinitd "${SCRIPTDIR}"/openafs-server openafs-server || die
+ newconfd "${CONFDIR}"/openafs-server openafs-server || die
+
+ # used directories: client
+ keepdir /etc/openafs
+ keepdir /var/cache/openafs
+
+ # used directories: server
+ keepdir /etc/openafs/server
+ diropts -m0700
+ keepdir /var/lib/openafs
+ keepdir /var/lib/openafs/db
+ diropts -m0755
+ keepdir /var/lib/openafs/logs
+
+ # link logfiles to /var/log
+ dosym ../lib/openafs/logs /var/log/openafs
+}
+
+pkg_preinst() {
+ ## Somewhat intelligently install default configuration files
+ ## (when they are not present)
+ local x
+ for x in cacheinfo CellServDB ThisCell ; do
+ if [ -e "${ROOT}"/etc/openafs/${x} ] ; then
+ cp "${ROOT}"/etc/openafs/${x} "${D}"/etc/openafs/
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "This installation should work out of the box (at least the"
+ elog "client part doing global afs-cell browsing, unless you had"
+ elog "a previous and different configuration). If you want to"
+ elog "set up your own cell or modify the standard config,"
+ elog "please have a look at the Gentoo OpenAFS documentation"
+ elog "(warning: it is not yet up to date wrt the new file locations)"
+ elog
+ elog "The documentation can be found at:"
+ elog " http://www.gentoo.org/doc/en/openafs.xml"
+}
diff --git a/net-fs/openafs/openafs-1.6.1-r3.ebuild b/net-fs/openafs/openafs-1.6.1-r3.ebuild
new file mode 100644
index 000000000000..40dd21df7b22
--- /dev/null
+++ b/net-fs/openafs/openafs-1.6.1-r3.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.6.1-r3.ebuild,v 1.1 2013/03/24 04:24:06 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic eutils autotools multilib toolchain-funcs versionator pam
+
+MY_PV=$(delete_version_separator '_')
+MY_P="${PN}-${MY_PV}"
+PVER="4"
+DESCRIPTION="The OpenAFS distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+SRC_URI="http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-src.tar.bz2
+ http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-doc.tar.bz2
+ mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc kerberos pam"
+
+RDEPEND="~net-fs/openafs-kernel-${PV}
+ sys-libs/ncurses
+ pam? ( sys-libs/pam )
+ kerberos? ( virtual/krb5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/gentoo/patches
+
+ # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
+ sed -i 's/^\(\s*\)a/\1ea/' regen.sh
+ : # this line makes repoman ok with not calling eautoconf etc. directly
+ skipman=1
+ . regen.sh
+}
+
+src_configure() {
+ # cannot use "use_with" macro, as --without-krb5-config crashes the econf
+ local myconf=""
+ if use kerberos; then
+ myconf="--with-krb5-conf=$(type -p krb5-config)"
+ fi
+
+ AFS_SYSKVERS=26 \
+ XCFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable pam) \
+ --enable-supergroups \
+ --disable-kernel-module \
+ --disable-strip-binaries \
+ ${myconf}
+}
+
+src_compile() {
+ emake all_nolibafs
+}
+
+src_install() {
+ local CONFDIR=${WORKDIR}/gentoo/configs
+ local SCRIPTDIR=${WORKDIR}/gentoo/scripts
+
+ emake DESTDIR="${ED}" install_nolibafs
+
+ insinto /etc/openafs
+ doins src/afsd/CellServDB
+ echo "/afs:/var/cache/openafs:200000" > "${ED}"/etc/openafs/cacheinfo
+ echo "openafs.org" > "${ED}"/etc/openafs/ThisCell
+
+ # pam_afs and pam_afs.krb have been installed in irregular locations, fix
+ if use pam ; then
+ dopammod "${ED}"/usr/$(get_libdir)/pam_afs*
+ fi
+ rm -f "${ED}"/usr/$(get_libdir)/pam_afs* || die
+
+ # remove kdump stuff provided by kexec-tools #222455
+ rm -rf "${ED}"/usr/sbin/kdump*
+
+ # avoid collision with mit_krb5's version of kpasswd
+ mv "${ED}"/usr/bin/kpasswd{,_afs} || die
+ mv "${ED}"/usr/share/man/man1/kpasswd{,_afs}.1 || die
+
+ # move lwp stuff around #200674 #330061
+ mv "${ED}"/usr/include/{lwp,lock,timer}.h "${ED}"/usr/include/afs/ || die
+ mv "${ED}"/usr/$(get_libdir)/liblwp* "${ED}"/usr/$(get_libdir)/afs/ || die
+ # update paths to the relocated lwp headers
+ sed -ri \
+ -e '/^#include <(lwp|lock|timer).h>/s:<([^>]*)>:<afs/\1>:' \
+ "${ED}"/usr/include/*.h \
+ "${ED}"/usr/include/*/*.h \
+ || die
+
+ # minimal documentation
+ use pam && doman src/pam/pam_afs.5
+ dodoc "${CONFDIR}"/README src/afsd/CellServDB
+
+ # documentation package
+ if use doc ; then
+ find doc/{arch,examples,pdf,protocol,txt}/ -type f -exec dodoc {} +
+ dohtml -A xml -r doc/{html,xml}/*
+ fi
+
+ # Gentoo related scripts
+ newinitd "${SCRIPTDIR}"/openafs-client openafs-client || die
+ newconfd "${CONFDIR}"/openafs-client openafs-client || die
+ newinitd "${SCRIPTDIR}"/openafs-server openafs-server || die
+ newconfd "${CONFDIR}"/openafs-server openafs-server || die
+
+ # used directories: client
+ keepdir /etc/openafs
+ keepdir /var/cache/openafs
+
+ # used directories: server
+ keepdir /etc/openafs/server
+ diropts -m0700
+ keepdir /var/lib/openafs
+ keepdir /var/lib/openafs/db
+ diropts -m0755
+ keepdir /var/lib/openafs/logs
+
+ # link logfiles to /var/log
+ dosym ../lib/openafs/logs /var/log/openafs
+}
+
+pkg_preinst() {
+ ## Somewhat intelligently install default configuration files
+ ## (when they are not present)
+ local x
+ for x in cacheinfo CellServDB ThisCell ; do
+ if [ -e "${EROOT}"/etc/openafs/${x} ] ; then
+ cp "${EROOT}"/etc/openafs/${x} "${ED}"/etc/openafs/
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "This installation should work out of the box (at least the"
+ elog "client part doing global afs-cell browsing, unless you had"
+ elog "a previous and different configuration). If you want to"
+ elog "set up your own cell or modify the standard config,"
+ elog "please have a look at the Gentoo OpenAFS documentation"
+ elog "(warning: it is not yet up to date wrt the new file locations)"
+ elog
+ elog "The documentation can be found at:"
+ elog " http://www.gentoo.org/doc/en/openafs.xml"
+}
diff --git a/net-fs/openafs/openafs-1.6.2.ebuild b/net-fs/openafs/openafs-1.6.2.ebuild
new file mode 100644
index 000000000000..d7b0a00fdcc4
--- /dev/null
+++ b/net-fs/openafs/openafs-1.6.2.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.6.2.ebuild,v 1.1 2013/03/24 04:24:06 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic eutils autotools multilib toolchain-funcs versionator pam
+
+MY_PV=$(delete_version_separator '_')
+MY_P="${PN}-${MY_PV}"
+PVER="1"
+DESCRIPTION="The OpenAFS distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+SRC_URI="http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-src.tar.bz2
+ http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-doc.tar.bz2
+ mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc kerberos pam"
+
+RDEPEND="~net-fs/openafs-kernel-${PV}
+ sys-libs/ncurses
+ pam? ( sys-libs/pam )
+ kerberos? ( virtual/krb5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/gentoo/patches
+
+ # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
+ sed -i 's/^\(\s*\)a/\1ea/' regen.sh
+ : # this line makes repoman ok with not calling eautoconf etc. directly
+ skipman=1
+ . regen.sh
+}
+
+src_configure() {
+ # cannot use "use_with" macro, as --without-krb5-config crashes the econf
+ local myconf=""
+ if use kerberos; then
+ myconf="--with-krb5-conf=$(type -p krb5-config)"
+ fi
+
+ AFS_SYSKVERS=26 \
+ XCFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable pam) \
+ --enable-supergroups \
+ --disable-kernel-module \
+ --disable-strip-binaries \
+ ${myconf}
+}
+
+src_compile() {
+ emake all_nolibafs
+}
+
+src_install() {
+ local CONFDIR=${WORKDIR}/gentoo/configs
+ local SCRIPTDIR=${WORKDIR}/gentoo/scripts
+
+ emake DESTDIR="${ED}" install_nolibafs
+
+ insinto /etc/openafs
+ doins src/afsd/CellServDB
+ echo "/afs:/var/cache/openafs:200000" > "${ED}"/etc/openafs/cacheinfo
+ echo "openafs.org" > "${ED}"/etc/openafs/ThisCell
+
+ # pam_afs and pam_afs.krb have been installed in irregular locations, fix
+ if use pam ; then
+ dopammod "${ED}"/usr/$(get_libdir)/pam_afs*
+ fi
+ rm -f "${ED}"/usr/$(get_libdir)/pam_afs* || die
+
+ # remove kdump stuff provided by kexec-tools #222455
+ rm -rf "${ED}"/usr/sbin/kdump*
+
+ # avoid collision with mit_krb5's version of kpasswd
+ mv "${ED}"/usr/bin/kpasswd{,_afs} || die
+ mv "${ED}"/usr/share/man/man1/kpasswd{,_afs}.1 || die
+
+ # move lwp stuff around #200674 #330061
+ mv "${ED}"/usr/include/{lwp,lock,timer}.h "${ED}"/usr/include/afs/ || die
+ mv "${ED}"/usr/$(get_libdir)/liblwp* "${ED}"/usr/$(get_libdir)/afs/ || die
+ # update paths to the relocated lwp headers
+ sed -ri \
+ -e '/^#include <(lwp|lock|timer).h>/s:<([^>]*)>:<afs/\1>:' \
+ "${ED}"/usr/include/*.h \
+ "${ED}"/usr/include/*/*.h \
+ || die
+
+ # minimal documentation
+ use pam && doman src/pam/pam_afs.5
+ dodoc "${CONFDIR}"/README src/afsd/CellServDB
+
+ # documentation package
+ if use doc ; then
+ find doc/{arch,examples,pdf,protocol,txt}/ -type f -exec dodoc {} +
+ dohtml -A xml -r doc/{html,xml}/*
+ fi
+
+ # Gentoo related scripts
+ newinitd "${SCRIPTDIR}"/openafs-client openafs-client || die
+ newconfd "${CONFDIR}"/openafs-client openafs-client || die
+ newinitd "${SCRIPTDIR}"/openafs-server openafs-server || die
+ newconfd "${CONFDIR}"/openafs-server openafs-server || die
+
+ # used directories: client
+ keepdir /etc/openafs
+ keepdir /var/cache/openafs
+
+ # used directories: server
+ keepdir /etc/openafs/server
+ diropts -m0700
+ keepdir /var/lib/openafs
+ keepdir /var/lib/openafs/db
+ diropts -m0755
+ keepdir /var/lib/openafs/logs
+
+ # link logfiles to /var/log
+ dosym ../lib/openafs/logs /var/log/openafs
+}
+
+pkg_preinst() {
+ ## Somewhat intelligently install default configuration files
+ ## (when they are not present)
+ local x
+ for x in cacheinfo CellServDB ThisCell ; do
+ if [ -e "${EROOT}"/etc/openafs/${x} ] ; then
+ cp "${EROOT}"/etc/openafs/${x} "${ED}"/etc/openafs/
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "This installation should work out of the box (at least the"
+ elog "client part doing global afs-cell browsing, unless you had"
+ elog "a previous and different configuration). If you want to"
+ elog "set up your own cell or modify the standard config,"
+ elog "please have a look at the Gentoo OpenAFS documentation"
+ elog "(warning: it is not yet up to date wrt the new file locations)"
+ elog
+ elog "The documentation can be found at:"
+ elog " http://www.gentoo.org/doc/en/openafs.xml"
+}