summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-30 07:37:29 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-30 07:37:29 +0000
commit24477a03e5f204beca510bd74c1dcf6c4255481a (patch)
tree69fab5617436955133645ef0cf31cf3007d666bc
parent* bump. (diff)
downloadgentoo-2-24477a03e5f204beca510bd74c1dcf6c4255481a.tar.gz
gentoo-2-24477a03e5f204beca510bd74c1dcf6c4255481a.tar.bz2
gentoo-2-24477a03e5f204beca510bd74c1dcf6c4255481a.zip
No more exec stacks; always install static lib; let portage strip binaries
(Portage version: 2.1.2_rc1-r1)
-rw-r--r--media-libs/allegro/ChangeLog9
-rw-r--r--media-libs/allegro/allegro-4.2.0-r2.ebuild104
-rw-r--r--media-libs/allegro/files/allegro-4.2.0-exec-stack.patch234
-rw-r--r--media-libs/allegro/files/allegro-4.2.0-flags.patch43
-rw-r--r--media-libs/allegro/files/digest-allegro-4.2.0-r23
5 files changed, 392 insertions, 1 deletions
diff --git a/media-libs/allegro/ChangeLog b/media-libs/allegro/ChangeLog
index 4cca49c61cf1..15b9b3bc507a 100644
--- a/media-libs/allegro/ChangeLog
+++ b/media-libs/allegro/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/allegro
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.58 2006/08/28 02:09:59 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.59 2006/10/30 07:37:28 nyhm Exp $
+
+*allegro-4.2.0-r2 (30 Oct 2006)
+
+ 30 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/allegro-4.2.0-exec-stack.patch, +files/allegro-4.2.0-flags.patch,
+ +allegro-4.2.0-r2.ebuild:
+ No more exec stacks; always install static lib; let portage strip binaries
28 Aug 2006; Luis Medinas <metalgod@gentoo.org> allegro-4.2.0-r1.ebuild:
Stable on amd64. Bug #145148.
diff --git a/media-libs/allegro/allegro-4.2.0-r2.ebuild b/media-libs/allegro/allegro-4.2.0-r2.ebuild
new file mode 100644
index 000000000000..53d405e76899
--- /dev/null
+++ b/media-libs/allegro/allegro-4.2.0-r2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.2.0-r2.ebuild,v 1.1 2006/10/30 07:37:28 nyhm Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="cross-platform multimedia library"
+HOMEPAGE="http://alleg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
+
+LICENSE="Allegro"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 -sparc ~x86"
+IUSE="X alsa arts doc esd fbcon mmx oss sse svga tetex"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ X? ( x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ svga? ( media-libs/svgalib )"
+DEPEND="${RDEPEND}
+ tetex? ( virtual/tetex )
+ X? ( x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-exec-stack.patch \
+ "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ filter-flags -fPIC -fprefetch-loop-arrays
+ econf \
+ --enable-linux \
+ --enable-static \
+ --enable-vga \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable oss ossdigi) \
+ $(use_enable oss ossmidi) \
+ $(use_enable alsa alsadigi) \
+ $(use_enable alsa alsamidi) \
+ $(use_enable esd esddigi) \
+ $(use_enable arts artsdigi) \
+ $(use_with X x) \
+ $(use_enable X xwin-shm) \
+ $(use_enable X xwin-vidmode) \
+ $(use_enable X xwin-dga) \
+ $(use_enable X xwin-dga2) \
+ $(use_enable fbcon) \
+ $(use_enable svga svgalib) \
+ || die
+
+ emake -j1 CFLAGS="${CFLAGS}" || die "emake failed"
+
+ if use tetex ; then
+ addwrite /var/lib/texmf
+ addwrite /usr/share/texmf
+ addwrite /var/cache/fonts
+ emake docs-dvi docs-ps || die
+ fi
+}
+
+src_install() {
+ addpredict /usr/share/info
+ emake DESTDIR="${D}" \
+ install \
+ install-gzipped-man \
+ install-gzipped-info \
+ || die "emake install failed"
+
+ # Different format versions of the Allegro documentation
+ dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
+ use tetex && dodoc docs/allegro.{dvi,ps}
+ use doc && dodoc examples/*
+ dohtml docs/html/*
+ docinto txt
+ dodoc docs/txt/*.txt
+ docinto rtf
+ dodoc docs/rtf/*.rtf
+ docinto build
+ dodoc docs/build/*.txt
+}
+
+pkg_postinst() {
+ ewarn "\"revdep-rebuild\" must be run now for applications already"
+ ewarn "using allegro to continue to work."
+ ewarn "revdep-rebuild is part of the gentoolkit package."
+ ewarn "(Run \"emerge gentoolkit\" if revdep-rebuild isn't already"
+ ewarn " available on your system.)"
+ ewarn
+}
diff --git a/media-libs/allegro/files/allegro-4.2.0-exec-stack.patch b/media-libs/allegro/files/allegro-4.2.0-exec-stack.patch
new file mode 100644
index 000000000000..22a85919d45b
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.2.0-exec-stack.patch
@@ -0,0 +1,234 @@
+--- src/amd64/acpus.s
++++ src/amd64/acpus.s
+@@ -128,3 +128,6 @@
+ popq %rbp
+ ret
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/iblit16.s
++++ src/i386/iblit16.s
+@@ -743,3 +743,6 @@
+
+
+ #endif /* ifdef ALLEGRO_COLOR16 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/iblit24.s
++++ src/i386/iblit24.s
+@@ -372,3 +372,6 @@
+
+
+ #endif /* ifdef ALLEGRO_COLOR24 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/iblit32.s
++++ src/i386/iblit32.s
+@@ -357,3 +357,6 @@
+
+
+ #endif /* ifdef ALLEGRO_COLOR32 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/iblit8.s
++++ src/i386/iblit8.s
+@@ -787,3 +787,6 @@
+
+
+ #endif /* ifdef ALLEGRO_COLOR8 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/icpus.s
++++ src/i386/icpus.s
+@@ -213,3 +213,6 @@
+ popl %ebp
+ ret
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/igfx15.s
++++ src/i386/igfx15.s
+@@ -436,3 +436,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR16 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/igfx16.s
++++ src/i386/igfx16.s
+@@ -487,3 +487,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR16 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/igfx24.s
++++ src/i386/igfx24.s
+@@ -581,3 +581,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR24 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/igfx32.s
++++ src/i386/igfx32.s
+@@ -467,3 +467,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR32 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/igfx8.s
++++ src/i386/igfx8.s
+@@ -530,3 +530,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR8 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/imisc.s
++++ src/i386/imisc.s
+@@ -600,3 +600,6 @@
+ popl %ebp
+ ret /* end of fixhypot() */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/iscanmmx.s
++++ src/i386/iscanmmx.s
+@@ -1672,3 +1672,6 @@
+
+
+ #endif /* MMX */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/iscan.s
++++ src/i386/iscan.s
+@@ -2777,3 +2777,6 @@
+ ret /* end of _poly_scanline_ptex_mask_trans24() */
+
+ #endif /* COLOR24 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/ispr15.s
++++ src/i386/ispr15.s
+@@ -494,3 +494,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR16 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/ispr16.s
++++ src/i386/ispr16.s
+@@ -889,3 +889,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR16 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/ispr24.s
++++ src/i386/ispr24.s
+@@ -913,3 +913,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR24 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/ispr32.s
++++ src/i386/ispr32.s
+@@ -700,3 +700,6 @@
+
+ #endif /* ifdef ALLEGRO_COLOR32 */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/ispr8.s
++++ src/i386/ispr8.s
+@@ -1046,3 +1046,6 @@
+
+
+ #endif /* ifdef ALLEGRO_COLOR8 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/i386/izbuf.s
++++ src/i386/izbuf.s
+@@ -2328,3 +2328,6 @@
+ ret /* end of _poly_zbuf_ptex_mask_trans24() */
+
+ #endif /* COLOR24 */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/linux/svgalibs.s
++++ src/linux/svgalibs.s
+@@ -65,3 +65,6 @@
+
+ #endif
+ #endif
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/misc/icolconv.s
++++ src/misc/icolconv.s
+@@ -3288,3 +3288,6 @@
+
+ #endif /* ALLEGRO_NO_COLORCOPY */
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/misc/modexgfx.s
++++ src/misc/modexgfx.s
+@@ -1688,3 +1688,6 @@
+
+
+ #endif /* (!defined ALLEGRO_LINUX) || ((defined ALLEGRO_LINUX_VGA) && ... */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/misc/vbeafs.s
++++ src/misc/vbeafs.s
+@@ -188,3 +188,6 @@
+
+
+ #endif /* ifdef VBE/AF is cool on this platform */
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/x/xdga2s.s
++++ src/x/xdga2s.s
+@@ -51,3 +51,6 @@
+ #endif
+ #endif
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/x/xwins.s
++++ src/x/xwins.s
+@@ -51,3 +51,6 @@
+
+ #endif
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/media-libs/allegro/files/allegro-4.2.0-flags.patch b/media-libs/allegro/files/allegro-4.2.0-flags.patch
new file mode 100644
index 000000000000..26aee313d06d
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.2.0-flags.patch
@@ -0,0 +1,43 @@
+--- configure
++++ configure
+@@ -2880,7 +2880,6 @@
+ echo "$as_me:$LINENO: checking whether linker works with -s option" >&5
+ echo $ECHO_N "checking whether linker works with -s option... $ECHO_C" >&6
+ allegro_save_LDFLAGS=$LDFLAGS
+-LDFLAGS="-s $LDFLAGS"
+ if test "${allegro_cv_prog_ld_s+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+@@ -4959,7 +4958,7 @@
+ COMPILE_CXX_PROGRAM=COMPILE_CXX_NORMAL
+ COMPILE_S_PROGRAM=COMPILE_S_NORMAL
+ if test "X$allegro_cv_prog_ld_s" = "Xyes"; then
+- PROG_LDFLAGS="-s \$(LDFLAGS)"
++ PROG_LDFLAGS="\$(LDFLAGS)"
+ else
+ PROG_LDFLAGS="\$(LDFLAGS)"
+ fi
+@@ -11367,11 +11366,7 @@
+ ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DDMALLOC"
+ fi
+ ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
+- if test "X$allegro_cv_support_fomit_frame_pointer" = "Xyes"; then
+- CFLAGS="$CFLAGS $TARGET_ARCH -O2 -funroll-loops -ffast-math -fomit-frame-pointer $WFLAGS"
+- else
+- CFLAGS="$CFLAGS $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
+- fi
++ CFLAGS="$CFLAGS -funroll-loops -ffast-math $WFLAGS"
+ ALLEGRO_SFLAGS="-x assembler-with-cpp"
+ ALLEGRO_SHAREDLIB_CFLAGS="-fPIC -DALLEGRO_SHARED"
+ else
+--- misc/deplib.sh
++++ misc/deplib.sh
+@@ -70,7 +70,7 @@
+ done
+ echo "$prev"
+ echo ""
+-write_code alleg LIBALLEG -s
++write_code alleg LIBALLEG
+ echo ""
+ echo ""
+
diff --git a/media-libs/allegro/files/digest-allegro-4.2.0-r2 b/media-libs/allegro/files/digest-allegro-4.2.0-r2
new file mode 100644
index 000000000000..9cccac0876ee
--- /dev/null
+++ b/media-libs/allegro/files/digest-allegro-4.2.0-r2
@@ -0,0 +1,3 @@
+MD5 a8b2c85c58b16345fe735f72763f3a6e allegro-4.2.0.tar.gz 3056173
+RMD160 e1602ea2f8bc1761be0ee34001e9d77d3a6ea3ff allegro-4.2.0.tar.gz 3056173
+SHA256 d8df27558bc083298d6933c843d4fdaf9afc0aa1607276acc96ed8fa9a39060c allegro-4.2.0.tar.gz 3056173