summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-06-12 19:57:10 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-06-12 19:57:10 +0000
commit23585d30cb25c7a6450c83558139c2b8ca7f3167 (patch)
treed6d6752e3d9ac831df5c3468ae7b113665f90ea0
parentAdded some more stuff to bootmisc init script (diff)
downloadgentoo-2-23585d30cb25c7a6450c83558139c2b8ca7f3167.tar.gz
gentoo-2-23585d30cb25c7a6450c83558139c2b8ca7f3167.tar.bz2
gentoo-2-23585d30cb25c7a6450c83558139c2b8ca7f3167.zip
Added some sed action to pkg_postinst, it should customize your conffile
for you.
-rw-r--r--ChangeLog4
-rw-r--r--net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild51
2 files changed, 55 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 5b24d68f2038..9d51b8282394 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
date 11 June 2001
+upd net-mail/ssmtp--2.38.14-r1
+will properly setup the ssmtp.conf file
+ben
+
upd dev-libs/pilot-link-0.9.5_pre6
the bleeding edge version of pilot-link
aj
diff --git a/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild b/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild
new file mode 100644
index 000000000000..54459097883e
--- /dev/null
+++ b/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <lewis@sistina.com>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/system/mail/mta/${A}"
+
+DEPEND="virtual/glibc
+ >=net-mail/mailbase-0.00"
+
+RDEPEND="!virtual/mta"
+
+PROVIDE="virtual/mta"
+
+src_compile() {
+ try make clean
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosbin ssmtp
+ chmod 755 ${D}/usr/sbin/ssmtp
+ dosym /usr/sbin/ssmtp /usr/bin/mailq
+ dosym /usr/sbin/ssmtp /usr/bin/newaliases
+ dosym /usr/sbin/ssmtp /usr/bin/mail
+ dosym /usr/sbin/ssmtp /usr/sbin/sendmail
+ dosym /usr/sbin/ssmtp /usr/lib/sendmail
+ doman ssmtp.8
+ dosym /usr/share/man/man8/ssmtp.8 /usr/share/man/man8/sendmail.8
+ dodoc CHANGELOG INSTALL MANIFEST README
+ newdoc ssmtp.lsm DESC
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+}
+
+pkg_postinst() {
+conffile="/etc/ssmtp/ssmtp.conf"
+hostname=`hostname -f`
+domainame=`hostname -d`
+mv ${conffile} ${conffile}.orig
+cat ${conffile}.orig \
+| sed -e "s:rewriteDomain\=:rewriteDomain\=${domainame}:g" \
+| sed -e "s:_HOSTNAME_:${hostname}:" \
+| sed -e "s:\=mail:\=mail.${domainame}:g" > ${conffile}
+
+}
+
+