summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-25 19:25:34 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-25 19:25:34 +0000
commit22fba488aa542e4f93a4189d8f03e0ba448a858b (patch)
tree97bb05b64f20566ee63db14a76ee9996b237d3cf
parentstable ppc, bug #448544, thanks peratu (diff)
downloadgentoo-2-22fba488aa542e4f93a4189d8f03e0ba448a858b.tar.gz
gentoo-2-22fba488aa542e4f93a4189d8f03e0ba448a858b.tar.bz2
gentoo-2-22fba488aa542e4f93a4189d8f03e0ba448a858b.zip
Fix lookup of dirs to autotool #448488 by Ivan.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
-rw-r--r--media-tv/xbmc/ChangeLog6
-rw-r--r--media-tv/xbmc/xbmc-12.0_rc2.ebuild9
-rw-r--r--media-tv/xbmc/xbmc-9999.ebuild6
3 files changed, 12 insertions, 9 deletions
diff --git a/media-tv/xbmc/ChangeLog b/media-tv/xbmc/ChangeLog
index 673da915a94e..bf6f89f7f4d5 100644
--- a/media-tv/xbmc/ChangeLog
+++ b/media-tv/xbmc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/xbmc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.159 2012/12/25 04:08:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.160 2012/12/25 19:25:34 vapier Exp $
+
+ 25 Dec 2012; Mike Frysinger <vapier@gentoo.org> xbmc-12.0_rc2.ebuild,
+ xbmc-9999.ebuild:
+ Fix lookup of dirs to autotool #448488 by Ivan.
*xbmc-12.0_rc2 (25 Dec 2012)
diff --git a/media-tv/xbmc/xbmc-12.0_rc2.ebuild b/media-tv/xbmc/xbmc-12.0_rc2.ebuild
index 1e4beb19fb35..3ec684be7644 100644
--- a/media-tv/xbmc/xbmc-12.0_rc2.ebuild
+++ b/media-tv/xbmc/xbmc-12.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-12.0_rc2.ebuild,v 1.1 2012/12/25 04:08:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-12.0_rc2.ebuild,v 1.2 2012/12/25 19:25:34 vapier Exp $
EAPI="4"
@@ -127,8 +127,7 @@ pkg_setup() {
}
src_unpack() {
- [[ ${PV} == "9999" ]] && git-2_src_unpack
- default
+ [[ ${PV} == "9999" ]] && git-2_src_unpack || default
}
src_prepare() {
@@ -140,9 +139,9 @@ src_prepare() {
# some dirs ship generated autotools, some dont
multijob_init
local d
- for d in $(printf 'f:\n\techo $(BOOTSTRAP_TARGETS)\ninclude bootstrap.mk\n' | emake -f - f) ; do
+ for d in $(printf 'f:\n\t@echo $(BOOTSTRAP_TARGETS)\ninclude bootstrap.mk\n' | emake -f - f) ; do
[[ -e ${d} ]] && continue
- pushd ${d/%\/configure/.} >/dev/null
+ pushd ${d/%configure/.} >/dev/null || die
AT_NOELIBTOOLIZE="yes" AT_TOPLEVEL_EAUTORECONF="yes" \
multijob_child_init eautoreconf
popd >/dev/null
diff --git a/media-tv/xbmc/xbmc-9999.ebuild b/media-tv/xbmc/xbmc-9999.ebuild
index c1b4de45c3db..97480975324f 100644
--- a/media-tv/xbmc/xbmc-9999.ebuild
+++ b/media-tv/xbmc/xbmc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.125 2012/12/25 04:08:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.126 2012/12/25 19:25:34 vapier Exp $
EAPI="4"
@@ -139,9 +139,9 @@ src_prepare() {
# some dirs ship generated autotools, some dont
multijob_init
local d
- for d in $(printf 'f:\n\techo $(BOOTSTRAP_TARGETS)\ninclude bootstrap.mk\n' | emake -f - f) ; do
+ for d in $(printf 'f:\n\t@echo $(BOOTSTRAP_TARGETS)\ninclude bootstrap.mk\n' | emake -f - f) ; do
[[ -e ${d} ]] && continue
- pushd ${d/%\/configure/.} >/dev/null
+ pushd ${d/%configure/.} >/dev/null || die
AT_NOELIBTOOLIZE="yes" AT_TOPLEVEL_EAUTORECONF="yes" \
multijob_child_init eautoreconf
popd >/dev/null