summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-31 06:01:38 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-31 06:01:38 +0000
commit22f8e2ca8621dbd9ff54f55cce0ce956e37aa308 (patch)
treef0911215b53c9b26d37681e8419fb1c0f900c882
parentadded upstream support for clock following an existing local bluetooth connec... (diff)
downloadgentoo-2-22f8e2ca8621dbd9ff54f55cce0ce956e37aa308.tar.gz
gentoo-2-22f8e2ca8621dbd9ff54f55cce0ce956e37aa308.tar.bz2
gentoo-2-22f8e2ca8621dbd9ff54f55cce0ce956e37aa308.zip
Cleanup.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--app-office/rabbit/ChangeLog6
-rw-r--r--app-office/rabbit/rabbit-1.0.6.ebuild76
-rw-r--r--app-office/rabbit/rabbit-1.0.8.ebuild77
3 files changed, 5 insertions, 154 deletions
diff --git a/app-office/rabbit/ChangeLog b/app-office/rabbit/ChangeLog
index 2c38be1299e2..58e2028db50c 100644
--- a/app-office/rabbit/ChangeLog
+++ b/app-office/rabbit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/rabbit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/rabbit/ChangeLog,v 1.21 2012/07/27 17:33:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/rabbit/ChangeLog,v 1.22 2012/08/31 06:01:38 graaff Exp $
+
+ 31 Aug 2012; Hans de Graaff <graaff@gentoo.org> -rabbit-1.0.6.ebuild,
+ -rabbit-1.0.8.ebuild:
+ Cleanup.
*rabbit-1.0.9 (27 Jul 2012)
diff --git a/app-office/rabbit/rabbit-1.0.6.ebuild b/app-office/rabbit/rabbit-1.0.6.ebuild
deleted file mode 100644
index 47b6f1e54597..000000000000
--- a/app-office/rabbit/rabbit-1.0.6.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/rabbit/rabbit-1.0.6.ebuild,v 1.3 2012/06/16 16:35:04 ssuominen Exp $
-
-EAPI=4
-USE_RUBY="ruby18"
-
-inherit ruby-ng elisp-common eutils
-
-DESCRIPTION="An application to do presentation with RD document"
-HOMEPAGE="http://rabbit-shockers.org/"
-SRC_URI="http://rabbit-shockers.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nls migemo tgif enscript emacs markdown postscript"
-
-CDEPEND="emacs? ( virtual/emacs )"
-DEPEND="${DEPEND} ${CDEPEND}"
-RDEPEND="${RDEPEND} ${CDEPEND}
- nls? ( dev-ruby/ruby-gettext )
- postscript? ( app-text/ghostscript-gpl )
- migemo? ( app-text/migemo )
- enscript? ( app-text/enscript )
- tgif? ( media-gfx/tgif )"
-
-ruby_add_rdepend "
- >=dev-ruby/coderay-1.0.0
- >=dev-ruby/ruby-gdkpixbuf2-0.15.0
- dev-ruby/ruby-gtk2
- dev-ruby/ruby-poppler
- >=dev-ruby/ruby-rsvg-1.0.3
- dev-ruby/rdtool
- dev-ruby/haml
- markdown? ( dev-ruby/kramdown )
- dev-ruby/sinatra
- enscript? ( dev-ruby/nokogiri )
- emacs? ( dev-ruby/nokogiri ) "
-
-each_ruby_configure() {
- ${RUBY} setup.rb config --prefix=/usr || die
- ${RUBY} setup.rb setup || die
-}
-
-all_ruby_compile() {
- if use emacs; then
- cd "${S}/misc/emacs"
- elisp-compile rabbit-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} setup.rb install --prefix="${D}"
-}
-
-all_ruby_install() {
- dodoc -r doc
-
- insinto /usr/share/doc/${PF}
- doins -r sample
-
- if use emacs; then
- cd "${S}/misc/emacs"
- elisp-install rabbit-mode rabbit-mode.el{,c}
- elisp-site-file-install "${FILESDIR}/50rabbit-mode-gentoo.el"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/app-office/rabbit/rabbit-1.0.8.ebuild b/app-office/rabbit/rabbit-1.0.8.ebuild
deleted file mode 100644
index f772b7d5678c..000000000000
--- a/app-office/rabbit/rabbit-1.0.8.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/rabbit/rabbit-1.0.8.ebuild,v 1.2 2012/07/21 07:31:22 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18"
-
-inherit ruby-ng elisp-common eutils
-
-DESCRIPTION="An application to do presentation with RD document"
-HOMEPAGE="http://rabbit-shockers.org/"
-SRC_URI="http://rabbit-shockers.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nls migemo tgif enscript emacs markdown postscript"
-
-CDEPEND="emacs? ( virtual/emacs )"
-DEPEND="${DEPEND} ${CDEPEND}"
-RDEPEND="${RDEPEND} ${CDEPEND}
- nls? ( dev-ruby/ruby-gettext )
- postscript? ( app-text/ghostscript-gpl )
- migemo? ( app-text/migemo )
- enscript? ( app-text/enscript )
- tgif? ( media-gfx/tgif )"
-
-ruby_add_bdepend "emacs? ( dev-ruby/rdtool[emacs] )"
-ruby_add_rdepend "
- >=dev-ruby/coderay-1.0.0
- >=dev-ruby/ruby-gdkpixbuf2-0.15.0
- dev-ruby/ruby-gtk2
- dev-ruby/ruby-poppler
- >=dev-ruby/ruby-rsvg-1.0.3
- dev-ruby/rdtool[emacs?]
- dev-ruby/haml
- markdown? ( dev-ruby/kramdown )
- dev-ruby/sinatra
- enscript? ( dev-ruby/nokogiri )
- emacs? ( dev-ruby/nokogiri ) "
-
-each_ruby_configure() {
- ${RUBY} setup.rb config --prefix=/usr || die
- ${RUBY} setup.rb setup || die
-}
-
-all_ruby_compile() {
- if use emacs; then
- cd "${S}/misc/emacs"
- elisp-compile rabbit-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} setup.rb install --prefix="${D}"
-}
-
-all_ruby_install() {
- dodoc -r doc
-
- insinto /usr/share/doc/${PF}
- doins -r sample
-
- if use emacs; then
- cd "${S}/misc/emacs"
- elisp-install rabbit-mode rabbit-mode.el{,c}
- elisp-site-file-install "${FILESDIR}/50rabbit-mode-gentoo.el"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}