summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-12-28 18:54:34 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-12-28 18:54:34 +0000
commit22bcf747321ca29a89206e1b2c3eafe19f81e353 (patch)
tree398fd71626f428322357232d75a3a437241a173b
parent4.17-r1 is stable long enough to remove all 4.* using deprecated distutils. (diff)
downloadgentoo-2-22bcf747321ca29a89206e1b2c3eafe19f81e353.tar.gz
gentoo-2-22bcf747321ca29a89206e1b2c3eafe19f81e353.tar.bz2
gentoo-2-22bcf747321ca29a89206e1b2c3eafe19f81e353.zip
Removed testing 4.20.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
-rw-r--r--dev-python/pyro/ChangeLog5
-rw-r--r--dev-python/pyro/pyro-4.20.ebuild80
2 files changed, 4 insertions, 81 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 5504f4f24a2b..e9920a8b9ff6 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.96 2013/12/28 18:52:02 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.97 2013/12/28 18:54:34 aidecoe Exp $
+
+ 28 Dec 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-4.20.ebuild:
+ Removed testing 4.20.
28 Dec 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-4.8.ebuild,
-pyro-4.11.ebuild, -pyro-4.17.ebuild:
diff --git a/dev-python/pyro/pyro-4.20.ebuild b/dev-python/pyro/pyro-4.20.ebuild
deleted file mode 100644
index a88ffa159c28..000000000000
--- a/dev-python/pyro/pyro-4.20.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.20.ebuild,v 1.4 2013/10/06 19:17:10 aidecoe Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-MY_PN="Pyro4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="!dev-python/pyro:0
- dev-python/serpent[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- virtual/python-unittest2[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- epatch "${FILESDIR}/${PV}-0001-Use-unittest2-for-older-Python-version.patch"
-
- sed \
- -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' \
- -i tests/run_suite.py || die
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -e "s/testBCLookup/_&/" \
- -i tests/PyroTests/test_naming.py || die
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py || die
-
- sed \
- -e "s/testServerConnections/_&/" \
- -e "s/testServerParallelism/_&/" \
- -i tests/PyroTests/test_server.py || die
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -e "s/testGetIpVersion/_&/" \
- -i tests/PyroTests/test_socket.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${S}"/tests || die
- ${PYTHON} run_suite.py || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}