summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-02-20 14:11:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-02-20 14:11:26 +0000
commit22b1c864deb0fc438d381abce9d57c0597be5f40 (patch)
tree2470dfc54bdc3740121d4cdae299c263b4890844
parentVersion bump. (diff)
downloadgentoo-2-22b1c864deb0fc438d381abce9d57c0597be5f40.tar.gz
gentoo-2-22b1c864deb0fc438d381abce9d57c0597be5f40.tar.bz2
gentoo-2-22b1c864deb0fc438d381abce9d57c0597be5f40.zip
Version bump
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
-rw-r--r--x11-apps/xdpyinfo/ChangeLog9
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.2.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/x11-apps/xdpyinfo/ChangeLog b/x11-apps/xdpyinfo/ChangeLog
index bf6c150e259c..c3679e6830cb 100644
--- a/x11-apps/xdpyinfo/ChangeLog
+++ b/x11-apps/xdpyinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdpyinfo
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.60 2010/01/23 18:51:29 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.61 2011/02/20 14:11:26 scarabeus Exp $
+
+*xdpyinfo-1.2.0 (20 Feb 2011)
+
+ 20 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> +xdpyinfo-1.2.0.ebuild:
+ Version bump
23 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-xdpyinfo-1.0.2.ebuild, -xdpyinfo-1.0.3.ebuild:
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.2.0.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.2.0.ebuild
new file mode 100644
index 000000000000..a3f33e6c6cf6
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.2.0.ebuild,v 1.1 2011/02/20 14:11:26 scarabeus Exp $
+
+EAPI=3
+
+inherit xorg-2
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-proto/compositeproto
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/renderproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ dga? ( x11-proto/xf86dgaproto )
+ dmx? ( x11-proto/dmxproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="--without-xf86misc
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ "
+}