summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-06-09 02:19:25 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-06-09 02:19:25 +0000
commit21a01188ee2b1bfd93e40afe828e2524a7af7195 (patch)
tree52b74d02886be044b299ee8b2217fcc257e9e20d
parent3.43.9 version bump for bug 317713. Thanks to tman <cornicx at hotmail dot (diff)
downloadgentoo-2-21a01188ee2b1bfd93e40afe828e2524a7af7195.tar.gz
gentoo-2-21a01188ee2b1bfd93e40afe828e2524a7af7195.tar.bz2
gentoo-2-21a01188ee2b1bfd93e40afe828e2524a7af7195.zip
Version bump. Update to EAPI 3. Update to handle new python/distutils (#316939). Other minor tweaks.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--sys-cluster/pbs-python/ChangeLog9
-rw-r--r--sys-cluster/pbs-python/pbs-python-4.1.0.ebuild28
2 files changed, 36 insertions, 1 deletions
diff --git a/sys-cluster/pbs-python/ChangeLog b/sys-cluster/pbs-python/ChangeLog
index f6ec7a67956b..dbae48d38ee4 100644
--- a/sys-cluster/pbs-python/ChangeLog
+++ b/sys-cluster/pbs-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pbs-python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/ChangeLog,v 1.3 2010/03/02 02:35:22 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/ChangeLog,v 1.4 2010/06/09 02:19:25 jsbronder Exp $
+
+*pbs-python-4.1.0 (09 Jun 2010)
+
+ 09 Jun 2010; Justin Bronder <jsbronder@gentoo.org>
+ +pbs-python-4.1.0.ebuild:
+ Version bump. Update to EAPI 3. Update to handle new python/distutils
+ (#316939). Other minor tweaks.
02 Mar 2010; Justin Bronder <jsbronder@gentoo.org>
-pbs-python-2.9.4.ebuild:
diff --git a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
new file mode 100644
index 000000000000..76557bbaf9fb
--- /dev/null
+++ b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild,v 1.1 2010/06/09 02:19:25 jsbronder Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_MODNAME="pbs"
+inherit distutils
+
+MY_P=${P/-/_}
+DESCRIPTION="Python bindings to the Torque C API"
+HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
+LICENSE="openpbs"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+RDEPEND="sys-cluster/torque"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${P} || die
+ doins "${S}"/examples/* || die
+ fi
+}