summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-04 17:54:15 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-04 17:54:15 +0000
commit2183ed6ee01403b0b4bc69b36c7a08146efe4f02 (patch)
treefbcdbee763a1f9f7eabeb10432f336fa5a191ea9
parentAdded ~mips to KEYWORDS to satisfy repoman deps and added gnuconfig for mips.... (diff)
downloadgentoo-2-2183ed6ee01403b0b4bc69b36c7a08146efe4f02.tar.gz
gentoo-2-2183ed6ee01403b0b4bc69b36c7a08146efe4f02.tar.bz2
gentoo-2-2183ed6ee01403b0b4bc69b36c7a08146efe4f02.zip
Version bumped.
-rw-r--r--dev-php/phpgroupware/ChangeLog10
-rw-r--r--dev-php/phpgroupware/Manifest4
-rw-r--r--dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.0001
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.16.000.ebuild56
4 files changed, 68 insertions, 3 deletions
diff --git a/dev-php/phpgroupware/ChangeLog b/dev-php/phpgroupware/ChangeLog
index a193ac8fc14c..a0b3ac39f300 100644
--- a/dev-php/phpgroupware/ChangeLog
+++ b/dev-php/phpgroupware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phpgroupware
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.19 2004/01/08 08:41:30 robbat2 Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.20 2004/03/04 17:54:15 mholzer Exp $
+
+*phpgroupware-0.9.16.000 (04 Mar 2004)
+
+ 04 Mar 2004; Martin Holzer <mholzer@gentoo.org>
+ phpgroupware-0.9.16.000.ebuild:
+ Version bumped.
08 Jan 2004; Robin H. Johnson <robbat2@gentoo.org>
phpgroupware-0.9.14.007.ebuild:
diff --git a/dev-php/phpgroupware/Manifest b/dev-php/phpgroupware/Manifest
index aa42e9a1c945..3ebd55fa31f5 100644
--- a/dev-php/phpgroupware/Manifest
+++ b/dev-php/phpgroupware/Manifest
@@ -1,4 +1,6 @@
-MD5 fbbb5aaa9a96a007bda35ba9dd6edaa7 phpgroupware-0.9.14.007.ebuild 1573
MD5 bf869d870dd2c837bdeae97a569f46fd ChangeLog 2526
MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
+MD5 fbbb5aaa9a96a007bda35ba9dd6edaa7 phpgroupware-0.9.14.007.ebuild 1573
+MD5 aca7051d8303d7ac128a09e2ddd78451 phpgroupware-0.9.16.000.ebuild 1608
MD5 02797b628fc7108b8d474fad0bc92cae files/digest-phpgroupware-0.9.14.007 77
+MD5 922ab954a67c17f0e1a566626098243a files/digest-phpgroupware-0.9.16.000 80
diff --git a/dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.000 b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.000
new file mode 100644
index 000000000000..71e692c3c770
--- /dev/null
+++ b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.000
@@ -0,0 +1 @@
+MD5 d40a2e046d8356511b4ec8fd1d834c7f phpgroupware-0.9.16.000-1.tar.bz2 17078710
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.16.000.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.16.000.ebuild
new file mode 100644
index 000000000000..6ed6c853fe5b
--- /dev/null
+++ b/dev-php/phpgroupware/phpgroupware-0.9.16.000.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.16.000.ebuild,v 1.1 2004/03/04 17:54:15 mholzer Exp $
+
+inherit webapp-apache
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="intranet/groupware tool and application framework"
+HOMEPAGE="http://www.phpgroupware.org/"
+SRC_URI="mirror://sourceforge/phpgroupware/${P}-1.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa"
+
+RDEPEND=">=dev-php/mod_php-4.1
+ dev-db/mysql"
+
+pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old ${PN} version first."
+ ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ webapp-detect || NO_WEBSERVER=1
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+
+ dodir ${destdir}
+ #cd ${WORKDIR}
+ cp -r . ${D}${destdir}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+ # Fix permissions
+ find ${D}${destdir} -type d | xargs chmod 755
+ find ${D}${destdir} -type f | xargs chmod 644
+ dohtml ${PN}/doc/en_US/html/admin/*.html
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at"
+ einfo "/usr/share/doc/${PF}/html/x62.html#AEN134"
+ einfo "to complete the install."
+ einfo "You need to add MySQL users and configure ${PN}"
+}