summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-05-19 18:44:38 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-05-19 18:44:38 +0000
commit204bf0725d4b5019d344ef29c3af00e1d841f609 (patch)
treedc6de505e4b58deb5297b76f48a95a8d96d6dafe
parentStable on amd64 wrt bug 177753 (diff)
downloadgentoo-2-204bf0725d4b5019d344ef29c3af00e1d841f609.tar.gz
gentoo-2-204bf0725d4b5019d344ef29c3af00e1d841f609.tar.bz2
gentoo-2-204bf0725d4b5019d344ef29c3af00e1d841f609.zip
Handle vim syntax correctly, bug#179123, thanks to Pietro Franchi
(Portage version: 2.1.2.7)
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.95-r16
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.95-r1.ebuild76
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.95-r1 b/sys-power/hibernate-script/files/digest-hibernate-script-1.95-r1
new file mode 100644
index 000000000000..d538ac93172e
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.95-r1
@@ -0,0 +1,6 @@
+MD5 55898e9265e077467eaad99599a47e5a hibernate-script-1.95-patches-1.tar.bz2 1374
+RMD160 23d3035090df8331175165eae69e7fae1e742ae9 hibernate-script-1.95-patches-1.tar.bz2 1374
+SHA256 5f5996c2b8bab58e1b26eb4c56e1d392fbf2509c6e2b9b523e644d68664188fb hibernate-script-1.95-patches-1.tar.bz2 1374
+MD5 026a7a8992da4fe56fb19530df998806 hibernate-script-1.95.tar.gz 74954
+RMD160 032cb97c355248640107e779f99ad5a86fb74846 hibernate-script-1.95.tar.gz 74954
+SHA256 e0c73cd1c3af2c0f409dba07e6fbd86c23150cfe77c4f9286ce239aedbe0a123 hibernate-script-1.95.tar.gz 74954
diff --git a/sys-power/hibernate-script/hibernate-script-1.95-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.95-r1.ebuild
new file mode 100644
index 000000000000..9f6f2afd390f
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.95-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.95-r1.ebuild,v 1.1 2007/05/19 18:44:38 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim-syntax"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate"
+ elog "suspend images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+ elog
+ elog "Starting with hibernate-script-1.90 the configuration files have"
+ elog "been reordered and split into method specific files. Make sure you"
+ elog "update your /etc/hibernate/ configuration files accordingly."
+ elog
+}