summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-29 16:53:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-29 16:53:16 +0000
commit20246c3939e73c2bd16abf800235a7a7e93f7fc9 (patch)
tree5492be9a1de4e495aa1c2fd008d942304573df29
parentalpha/ia64/sparc stable wrt #207634 (diff)
downloadgentoo-2-20246c3939e73c2bd16abf800235a7a7e93f7fc9.tar.gz
gentoo-2-20246c3939e73c2bd16abf800235a7a7e93f7fc9.tar.bz2
gentoo-2-20246c3939e73c2bd16abf800235a7a7e93f7fc9.zip
add a patch to build with latest libcaca, bug #208057
(Portage version: 2.1.4)
-rw-r--r--media-video/xine-ui/ChangeLog8
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.99.5-r13
-rw-r--r--media-video/xine-ui/files/xine-ui-0.99.5-new_libcaca_api.patch35
-rw-r--r--media-video/xine-ui/xine-ui-0.99.5-r1.ebuild93
4 files changed, 138 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index d4981db2fb49..726b7aa58a46 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.156 2008/01/13 00:49:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.157 2008/01/29 16:53:15 aballier Exp $
+
+*xine-ui-0.99.5-r1 (29 Jan 2008)
+
+ 29 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/xine-ui-0.99.5-new_libcaca_api.patch, +xine-ui-0.99.5-r1.ebuild:
+ add a patch to build with latest libcaca, bug #208057
13 Jan 2008; Alexis Ballier <aballier@gentoo.org> xine-ui-0.99.5.ebuild:
add missing inputproto dep, bug #205548
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.99.5-r1 b/media-video/xine-ui/files/digest-xine-ui-0.99.5-r1
new file mode 100644
index 000000000000..00ac1a3ea00d
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.99.5-r1
@@ -0,0 +1,3 @@
+MD5 e643cd1fcad4d98a5ae4eb877ce5087b xine-ui-0.99.5.tar.gz 2606481
+RMD160 64cb69549d88d904d986ea7dd7b36a51d5b91756 xine-ui-0.99.5.tar.gz 2606481
+SHA256 1368aa9cfd70433d14efde5bf0e70911f80f9463a026192c1f133a339be25e1e xine-ui-0.99.5.tar.gz 2606481
diff --git a/media-video/xine-ui/files/xine-ui-0.99.5-new_libcaca_api.patch b/media-video/xine-ui/files/xine-ui-0.99.5-new_libcaca_api.patch
new file mode 100644
index 000000000000..ae573d76d92f
--- /dev/null
+++ b/media-video/xine-ui/files/xine-ui-0.99.5-new_libcaca_api.patch
@@ -0,0 +1,35 @@
+Index: xine-ui-0.99.5/configure.ac
+===================================================================
+--- xine-ui-0.99.5.orig/configure.ac
++++ xine-ui-0.99.5/configure.ac
+@@ -364,6 +364,13 @@ if test "x$with_caca" != "xno"; then
+ if test "x$with_caca" = "xyes" && test "x$have_caca" = "xno"; then
+ AC_MSG_ERROR([CACA support requested, but libcaca 0.99 not found])
+ fi
++ AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[#include <caca.h>
++ caca_event_t ev;]],
++ [[ev.type = 0;]]
++ )],
++ [],
++ [AC_DEFINE(CACA_EVENT_OPAQUE, [1], ["Define if struct caca_event is opaque and must not be accessed directly"])]
++ )
+ fi
+
+ AM_CONDITIONAL([HAVE_CACA], [test "x$have_caca" = "xyes"])
+Index: xine-ui-0.99.5/src/aaui/main.c
+===================================================================
+--- xine-ui-0.99.5.orig/src/aaui/main.c
++++ xine-ui-0.99.5/src/aaui/main.c
+@@ -593,8 +593,12 @@ static int aaxine_get_key_event(void) {
+ while ( !caca_get_event(aaxine.display, CACA_EVENT_KEY_PRESS, &ev, 50000) && aaxine.running ) ;
+
+ if (!aaxine.running) return 0;
++#ifdef CACA_EVENT_OPAQUE
++ return caca_get_event_key_ch( &ev );
++#else
+ return ev.data.key.ch;
+ #endif
++#endif
+ }
+
+ /*
diff --git a/media-video/xine-ui/xine-ui-0.99.5-r1.ebuild b/media-video/xine-ui/xine-ui-0.99.5-r1.ebuild
new file mode 100644
index 000000000000..bff8e3432d91
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.99.5-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.99.5-r1.ebuild,v 1.1 2008/01/29 16:53:15 aballier Exp $
+
+# WANT_AUTOCONF=latest
+# WANT_AUTOMAKE=latest
+
+inherit eutils toolchain-funcs flag-o-matic autotools
+
+#PATCHLEVEL="11"
+DESCRIPTION="Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+# mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="X nls lirc aalib libcaca readline curl vdr xinerama debug"
+
+RDEPEND=">=media-libs/libpng-1.2.8
+ >=media-libs/xine-lib-1.1.0
+ lirc? ( app-misc/lirc )
+ aalib? ( media-libs/aalib )
+ libcaca? ( media-libs/libcaca )
+ curl? ( >=net-misc/curl-7.10.2 )
+ X? ( x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXv
+ x11-libs/libXtst
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama ) )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ X? ( x11-libs/libXt
+ x11-proto/xf86vidmodeproto
+ x11-proto/inputproto
+ xinerama? ( x11-proto/xineramaproto ) )
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use aalib && ! built_with_use media-libs/xine-lib aalib; then
+ eerror "To enable the AA frontend in xine-ui you need"
+ eerror "to enable the aalib video output in media-libs/xine-lib."
+ die "Missing aalib USE flag on media-libs/xine-lib."
+ fi
+
+ if use libcaca && ! built_with_use media-libs/xine-lib libcaca; then
+ eerror "To enable the CACA frontend in xine-ui you need"
+ eerror "to enable the libcaca video output in media-libs/xine-lib."
+ die "Missing libcaca USE flag on media-libs/xine-lib."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-new_libcaca_api.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ rm misc/xine-bugreport
+
+ econf \
+ $(use_enable lirc) \
+ $(use_enable nls) \
+ $(use_enable vdr vdr-keys) \
+ $(use_enable xinerama) \
+ $(use_enable debug) \
+ $(use_with X x) \
+ $(use_with aalib) \
+ $(use_with libcaca caca) \
+ $(use_with curl) \
+ $(use_with readline) \
+ --without-ncurses \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" docsdir="/usr/share/doc/${PF}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Remove on next snapshot (after 20070303)
+ dodir /usr/share/applications
+ mv "${D}/usr/share/xine/desktop/xine.desktop" "${D}/usr/share/applications"
+}