summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-06 09:02:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-06 09:02:23 +0000
commit1f8f1b892943f8326febc3a79bf4c12303a76d62 (patch)
treee48b8b6764dcf99d89a73fc8989f17540cc82d96
parentFix compilation with gcc-4.3 and -O2. Bug #26968 (diff)
downloadgentoo-2-1f8f1b892943f8326febc3a79bf4c12303a76d62.tar.gz
gentoo-2-1f8f1b892943f8326febc3a79bf4c12303a76d62.tar.bz2
gentoo-2-1f8f1b892943f8326febc3a79bf4c12303a76d62.zip
Split cdda in cdda/cddax useflags; merge vcd useflag in cdda as that is what currently controls it. Part of bug #257788
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--media-video/vlc/ChangeLog7
-rw-r--r--media-video/vlc/metadata.xml3
-rw-r--r--media-video/vlc/vlc-0.9.8a.ebuild17
3 files changed, 17 insertions, 10 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index d06dd828ec8c..071dfe500889 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vlc
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.419 2009/01/11 17:19:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.420 2009/02/06 09:02:22 aballier Exp $
+
+ 06 Feb 2009; Alexis Ballier <aballier@gentoo.org> metadata.xml,
+ vlc-0.9.8a.ebuild:
+ Split cdda in cdda/cddax useflags; merge vcd useflag in cdda as that is
+ what currently controls it. Part of bug #257788
11 Jan 2009; Alexis Ballier <aballier@gentoo.org> metadata.xml,
vlc-0.9.8a.ebuild:
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
index 366837d4f054..2b46503961d1 100644
--- a/media-video/vlc/metadata.xml
+++ b/media-video/vlc/metadata.xml
@@ -8,7 +8,8 @@
</maintainer>
<use>
<flag name="atmo">Enables support for AtmoLight (homebrew Ambient Lighting Technology)</flag>
- <flag name="cdda">Enables libcdda cd audio playback support.</flag>
+ <flag name="cdda">Enables audio CD and VCD playback support.</flag>
+ <flag name="cddax">Enables audio CD plugin with CD Text and CD paranoia via libcdio</flag>
<flag name="cdio">Enables CD input and control library support.</flag>
<flag name="dc1394">Enables IIDC cameras support.</flag>
<flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
diff --git a/media-video/vlc/vlc-0.9.8a.ebuild b/media-video/vlc/vlc-0.9.8a.ebuild
index 3c8d23350d54..408d7611a838 100644
--- a/media-video/vlc/vlc-0.9.8a.ebuild
+++ b/media-video/vlc/vlc-0.9.8a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.9.8a.ebuild,v 1.7 2009/01/11 17:19:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.9.8a.ebuild,v 1.8 2009/02/06 09:02:23 aballier Exp $
EAPI="1"
@@ -38,12 +38,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="a52 aac aalib alsa altivec arts atmo avahi bidi cdda cddb cdio dbus dc1394
+IUSE="a52 aac aalib alsa altivec arts atmo avahi bidi cdda cddax cddb cdio dbus dc1394
debug dirac directfb dts dvb dvd esd fbcon fluidsynth +ffmpeg flac fontconfig ggi gnome gnutls hal httpd
id3tag jack kate libass libcaca +libgcrypt libnotify libsysfs libv4l2 lirc live lua matroska mmx modplug mp3 mpeg
musepack ncurses nsplugin ogg opengl optimisememory oss pda png pulseaudio pvr +qt4
remoteosd rtsp run-as-root samba schroedinger sdl sdl-image seamonkey shout skins speex sse stream svg svga taglib
- theora truetype twolame upnp v4l v4l2 vcd vcdinfo vcdx vlm vorbis win32codecs
+ theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs
X x264 xinerama xml xosd xv zvbi"
RDEPEND="
@@ -56,8 +56,8 @@ RDEPEND="
arts? ( kde-base/arts )
avahi? ( >=net-dns/avahi-0.6 )
bidi? ( >=dev-libs/fribidi-0.10.4 )
- cdda? ( >=dev-libs/libcdio-0.72
- cddb? ( >=media-libs/libcddb-1.2.0 ) )
+ cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
+ cddax? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
cdio? ( >=dev-libs/libcdio-0.78.2 )
dbus? ( >=sys-apps/dbus-1.0.2 )
dc1394? ( sys-libs/libraw1394
@@ -190,7 +190,7 @@ vlc_ffmpeg_scaling_api() {
pkg_setup() {
vlc_use_needs skins truetype
vlc_use_force skins qt4
- vlc_use_needs cdda cdio
+ vlc_use_needs cddax cdio
vlc_use_needs vcdx cdio
vlc_use_needs vcdx vcdinfo
vlc_use_needs vcdinfo cdio
@@ -198,6 +198,7 @@ pkg_setup() {
vlc_use_force remoteosd libgcrypt
vlc_use_needs fontconfig truetype
vlc_use_needs libv4l2 v4l2
+ use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
if ( use qt4 || use skins ) ; then
QT4_BUILT_WITH_USE_CHECK="png" qt4_pkg_setup
else
@@ -247,7 +248,8 @@ src_compile () {
$(use_enable atmo) \
$(use_enable avahi bonjour) \
$(use_enable bidi fribidi) \
- $(use_enable cdda) $(use_enable cdda cddax)\
+ $(use_enable cdda vcd) \
+ $(use_enable cddax)\
$(use_enable cddb libcddb) \
$(use_enable cdio libcdio) \
--disable-csri \
@@ -323,7 +325,6 @@ src_compile () {
$(use_enable upnp) \
$(use_enable v4l) \
$(use_enable v4l2) \
- $(use_enable vcd) \
$(use_enable vcdinfo) \
$(use_enable vcdx) \
$(use_enable vorbis) \