summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-02 09:22:48 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-02 09:22:48 +0000
commit1f3194759cac73fd50e3ae1fdabd6961b1dd890f (patch)
tree680695f7e1bb36293609937586e7c5e6c92cb2f2
parentImported from prefix overlay (diff)
downloadgentoo-2-1f3194759cac73fd50e3ae1fdabd6961b1dd890f.tar.gz
gentoo-2-1f3194759cac73fd50e3ae1fdabd6961b1dd890f.tar.bz2
gentoo-2-1f3194759cac73fd50e3ae1fdabd6961b1dd890f.zip
Imported from prefix overlay, LDFALGS patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-tcltk/tclx/ChangeLog10
-rw-r--r--dev-tcltk/tclx/files/tclx-8.4-ldflags.patch13
-rw-r--r--dev-tcltk/tclx/tclx-8.4-r2.ebuild52
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-tcltk/tclx/ChangeLog b/dev-tcltk/tclx/ChangeLog
index 7f4def32144b..8d1b99e61fe9 100644
--- a/dev-tcltk/tclx/ChangeLog
+++ b/dev-tcltk/tclx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.40 2009/08/05 20:10:09 mescalinum Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.41 2010/04/02 09:22:48 jlec Exp $
+
+*tclx-8.4-r2 (02 Apr 2010)
+
+ 02 Apr 2010; Justin Lecher <jlec@gentoo.org> +tclx-8.4-r2.ebuild,
+ +files/tclx-8.4-ldflags.patch:
+ Imported from prefix overlay, ldflags respectation patch
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org> tclx-8.4-r1.ebuild:
disable tests wrt bug 279283
diff --git a/dev-tcltk/tclx/files/tclx-8.4-ldflags.patch b/dev-tcltk/tclx/files/tclx-8.4-ldflags.patch
new file mode 100644
index 000000000000..d6ef567a1522
--- /dev/null
+++ b/dev-tcltk/tclx/files/tclx-8.4-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index b812bbe..069337c 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -123,7 +123,7 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ TCL_DEFS = @TCL_DEFS@
diff --git a/dev-tcltk/tclx/tclx-8.4-r2.ebuild b/dev-tcltk/tclx/tclx-8.4-r2.ebuild
new file mode 100644
index 000000000000..274564fb8219
--- /dev/null
+++ b/dev-tcltk/tclx/tclx-8.4-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.4-r2.ebuild,v 1.1 2010/04/02 09:22:48 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://tclx.sourceforge.net"
+SRC_URI="mirror://sourceforge/tclx/${PN}${PV}.tar.bz2"
+
+LICENSE="BSD"
+IUSE="tk threads"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND=">=dev-lang/tcl-8.4.6
+ tk? ( >=dev-lang/tk-8.4.6 )"
+
+S="${WORKDIR}"/${PN}${PV}
+
+# tests broken, bug #279283
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-relid.patch
+ epatch "${FILESDIR}"/${P}-varinit.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable tk) \
+ $(use_enable threads) \
+ --enable-shared \
+ --with-tcl="${EPREFIX}/usr/lib/" \
+ || die "econf failed"
+
+ # adjust install_name on darwin
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i \
+ -e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
+ "${S}"/Makefile || die 'sed failed'
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+ doman doc/*.[n3]
+}