summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-09-30 19:54:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-09-30 19:54:43 +0000
commit1eea06ebd0daa4d35efd3facd76222ead663675f (patch)
treef7fcf083b646eee3e7b46650dc2d46fbe338c16f
parentIf no targets are found, remove the symlink and exit. (diff)
downloadgentoo-2-1eea06ebd0daa4d35efd3facd76222ead663675f.tar.gz
gentoo-2-1eea06ebd0daa4d35efd3facd76222ead663675f.tar.bz2
gentoo-2-1eea06ebd0daa4d35efd3facd76222ead663675f.zip
hardened-sources-2.6.32-r19 based on 2.6.32.23 + genpatches + grsec-2.2.0-2.6.32.23-201009272133
hardened-sources-2.6.35-r1 based on 2.6.35.6 + genpatches + grsec-2.2.0-2.6.35.6-201009281623 (Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--sys-kernel/hardened-sources/ChangeLog12
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r19.ebuild46
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.35-r1.ebuild46
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 06555ea56231..07d90023d28b 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.340 2010/09/28 02:17:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.341 2010/09/30 19:54:43 blueness Exp $
+
+*hardened-sources-2.6.35-r1 (30 Sep 2010)
+*hardened-sources-2.6.32-r19 (30 Sep 2010)
+
+ 30 Sep 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r19.ebuild, +hardened-sources-2.6.35-r1.ebuild:
+ hardened-sources-2.6.32-r19 based on 2.6.32.23 + genpatches +
+ grsec-2.2.0-2.6.32.23-201009272133
+ hardened-sources-2.6.35-r1 based on 2.6.35.6 + genpatches +
+ grsec-2.2.0-2.6.35.6-201009281623
*hardened-sources-2.6.35 (28 Sep 2010)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r19.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r19.ebuild
new file mode 100644
index 000000000000..04856e5e59d5
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r19.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r19.ebuild,v 1.1 2010/09/30 19:54:43 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="22"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-22"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.35-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.35-r1.ebuild
new file mode 100644
index 000000000000..c3c171492dbc
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.35-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.35-r1.ebuild,v 1.1 2010/09/30 19:54:43 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}