summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-10 18:48:23 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-10 18:48:23 +0000
commit1ebc534047ac669cec43e3f7af120907ef08f3b1 (patch)
tree0a4e12cecd11d026da955e68771e609d416f7399
parentMarked ~{amd64,x86}-linux, bug #385065 (diff)
downloadgentoo-2-1ebc534047ac669cec43e3f7af120907ef08f3b1.tar.gz
gentoo-2-1ebc534047ac669cec43e3f7af120907ef08f3b1.tar.bz2
gentoo-2-1ebc534047ac669cec43e3f7af120907ef08f3b1.zip
Call tests directly instead of via testrb to address bug 339126.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--dev-ruby/json/ChangeLog5
-rw-r--r--dev-ruby/json/json-1.5.4.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index be0357a29164..b302b7b7b5de 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.66 2011/09/11 06:05:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.67 2011/10/10 18:48:23 graaff Exp $
+
+ 10 Oct 2011; Hans de Graaff <graaff@gentoo.org> json-1.5.4.ebuild:
+ Call tests directly instead of via testrb to address bug 339126.
*json-1.5.4 (11 Sep 2011)
diff --git a/dev-ruby/json/json-1.5.4.ebuild b/dev-ruby/json/json-1.5.4.ebuild
index ae874b93bdbf..6ba22c8e928f 100644
--- a/dev-ruby/json/json-1.5.4.ebuild
+++ b/dev-ruby/json/json-1.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.4.ebuild,v 1.1 2011/09/11 06:05:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.4.ebuild,v 1.2 2011/10/10 18:48:23 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -45,11 +45,11 @@ each_ruby_compile() {
each_ruby_test() {
JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/*.rb || die "pure ruby tests failed"
+ ${RUBY} -Iext:lib -rtest/unit -e "Dir['test/*.rb'].each{|f| require f}" || die "pure ruby tests failed"
if [[ $(basename ${RUBY}) != "jruby" ]]; then
JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/*.rb || die "ext ruby tests failed"
+ ${RUBY} -Iext:lib -rtest/unit -e "Dir['test/*.rb'].each{|f| require f}" || die "ext ruby tests failed"
fi
}