summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 13:44:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 13:44:05 +0000
commit1e8f3ae63c4aa681554f2f2cc9c25fcf3d9b69fe (patch)
treeead5af8a78a034c1fb4b44b9341a87a1e10e73d2
parentx86 stable wrt security bug #437664 (diff)
downloadgentoo-2-1e8f3ae63c4aa681554f2f2cc9c25fcf3d9b69fe.tar.gz
gentoo-2-1e8f3ae63c4aa681554f2f2cc9c25fcf3d9b69fe.tar.bz2
gentoo-2-1e8f3ae63c4aa681554f2f2cc9c25fcf3d9b69fe.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
-rw-r--r--dev-python/webtest/ChangeLog8
-rw-r--r--dev-python/webtest/webtest-1.4.0.ebuild61
2 files changed, 67 insertions, 2 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index c340b7a29a7e..ee7629f4ab93 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.37 2012/08/05 06:14:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.38 2012/10/09 13:44:05 patrick Exp $
+
+*webtest-1.4.0 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +webtest-1.4.0.ebuild:
+ Bump
05 Aug 2012; Anthony G. Basile <blueness@gentoo.org> webtest-1.2.3.ebuild:
Stable arm, bug #427546
@@ -141,4 +146,3 @@
02 Jul 2008; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+webtest-1.0.ebuild:
Initial commit.
-
diff --git a/dev-python/webtest/webtest-1.4.0.ebuild b/dev-python/webtest/webtest-1.4.0.ebuild
new file mode 100644
index 000000000000..6447fa34ce17
--- /dev/null
+++ b/dev-python/webtest/webtest-1.4.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.4.0.ebuild,v 1.1 2012/10/09 13:44:05 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.1"
+PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-python/webob-0.9.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pyquery )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.4-index_fixt.patch"
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ sphinx-build docs html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
+ delete_lint3() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+ rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
+ }
+ python_execute_function -q delete_lint3
+
+ if use doc; then
+ dohtml -r html/*
+ fi
+}