summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-03-19 17:20:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-03-19 17:20:02 +0000
commit1e2927ece33c1581b7d08158ec43d39af94b42cb (patch)
tree3fe9ec5e71336f8d22247d2785daf901715d6170
parentVersion bump (diff)
downloadgentoo-2-1e2927ece33c1581b7d08158ec43d39af94b42cb.tar.gz
gentoo-2-1e2927ece33c1581b7d08158ec43d39af94b42cb.tar.bz2
gentoo-2-1e2927ece33c1581b7d08158ec43d39af94b42cb.zip
Add patch fixing build with libpng-1.5 (bug #355035).
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.8.11-libpng15.patch36
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild3
3 files changed, 43 insertions, 2 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index e8d6f3160dc7..c88a5032cfd6 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.259 2011/02/27 14:32:40 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.260 2011/03/19 17:20:02 dirtyepic Exp $
+
+ 19 Mar 2011; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxGTK-2.8.11-libpng15.patch, wxGTK-2.8.11.0.ebuild:
+ Add patch fixing build with libpng-1.5 (bug #355035).
27 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.8.10.1-r5.ebuild,
wxGTK-2.8.11.0.ebuild, wxGTK-2.9.1.1.ebuild:
diff --git a/x11-libs/wxGTK/files/wxGTK-2.8.11-libpng15.patch b/x11-libs/wxGTK/files/wxGTK-2.8.11-libpng15.patch
new file mode 100644
index 000000000000..56abde593155
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.8.11-libpng15.patch
@@ -0,0 +1,36 @@
+diff --git a/src/common/imagpng.cpp b/src/common/imagpng.cpp
+index 7891ff8..197bda5 100644
+--- a/src/common/imagpng.cpp
++++ b/src/common/imagpng.cpp
+@@ -529,7 +529,7 @@ wxPNGHandler::LoadFile(wxImage *image,
+ png_structp png_ptr = png_create_read_struct
+ (
+ PNG_LIBPNG_VER_STRING,
+- (voidp) NULL,
++ NULL,
+ wx_png_error,
+ wx_png_warning
+ );
+@@ -586,16 +586,18 @@ wxPNGHandler::LoadFile(wxImage *image,
+ #if wxUSE_PALETTE
+ if (color_type == PNG_COLOR_TYPE_PALETTE)
+ {
+- const size_t ncolors = info_ptr->num_palette;
++ int ncolors = 0;
++ png_colorp palette;
++ png_get_PLTE( png_ptr, info_ptr, &palette, &ncolors);
+ unsigned char* r = new unsigned char[ncolors];
+ unsigned char* g = new unsigned char[ncolors];
+ unsigned char* b = new unsigned char[ncolors];
+
+ for (size_t j = 0; j < ncolors; j++)
+ {
+- r[j] = info_ptr->palette[j].red;
+- g[j] = info_ptr->palette[j].green;
+- b[j] = info_ptr->palette[j].blue;
++ r[j] = palette[j].red;
++ g[j] = palette[j].green;
++ b[j] = palette[j].blue;
+ }
+
+ image->SetPalette(wxPalette(ncolors, r, g, b));
diff --git a/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild b/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild
index 74668888f109..86368e439bfe 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild,v 1.4 2011/02/27 14:32:40 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild,v 1.5 2011/03/19 17:20:02 dirtyepic Exp $
EAPI="2"
@@ -61,6 +61,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.8.11-collision.patch
epatch "${FILESDIR}"/${PN}-2.8.7-mmedia.patch # Bug #174874
epatch "${FILESDIR}"/${PN}-2.8.10.1-odbc-defines.patch # Bug #310923
+ epatch "${FILESDIR}"/${PN}-2.8.11-libpng15.patch # Bug #355035
}
src_configure() {