summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-01 10:40:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-01 10:40:27 +0000
commit1e192b6890e3b326c8cb425c3289fd589964cc58 (patch)
tree78d009d14d5e1db7659e1396455c881412dcf215
parentBump to 3.0.6 (diff)
downloadgentoo-2-1e192b6890e3b326c8cb425c3289fd589964cc58.tar.gz
gentoo-2-1e192b6890e3b326c8cb425c3289fd589964cc58.tar.bz2
gentoo-2-1e192b6890e3b326c8cb425c3289fd589964cc58.zip
Bump to 3.0.6, fixes #283001
(Portage version: 2.2_rc40/cvs/Linux x86_64)
-rw-r--r--net-firewall/fwbuilder/ChangeLog7
-rw-r--r--net-firewall/fwbuilder/fwbuilder-3.0.6.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/net-firewall/fwbuilder/ChangeLog b/net-firewall/fwbuilder/ChangeLog
index 27671b52990b..3349b3f09c7e 100644
--- a/net-firewall/fwbuilder/ChangeLog
+++ b/net-firewall/fwbuilder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/fwbuilder
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/ChangeLog,v 1.86 2009/07/26 13:49:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/ChangeLog,v 1.87 2009/09/01 10:40:27 patrick Exp $
+
+*fwbuilder-3.0.6 (01 Sep 2009)
+
+ 01 Sep 2009; Patrick Lauer <patrick@gentoo.org> +fwbuilder-3.0.6.ebuild:
+ Bump to 3.0.6, fixes #283001
26 Jul 2009; Brent Baude <ranger@gentoo.org> fwbuilder-3.0.3.ebuild:
Marking fwbuilder-3.0.3 ppc64 for bug 235809
diff --git a/net-firewall/fwbuilder/fwbuilder-3.0.6.ebuild b/net-firewall/fwbuilder/fwbuilder-3.0.6.ebuild
new file mode 100644
index 000000000000..9844de927a20
--- /dev/null
+++ b/net-firewall/fwbuilder/fwbuilder-3.0.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-3.0.6.ebuild,v 1.1 2009/09/01 10:40:27 patrick Exp $
+
+EAPI="2"
+
+inherit qt4 multilib
+
+DESCRIPTION="A firewall GUI"
+HOMEPAGE="http://www.fwbuilder.org/"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+pch"
+
+DEPEND="~net-libs/libfwbuilder-${PV}
+ >=dev-java/antlr-2.7.7:0[cxx]
+ x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt4_src_prepare
+
+ # Remove bundled antlr
+ rm -rf src/antlr
+
+ sed -i \
+ -e '/COPYING/d' \
+ doc/doc.pro || die "sed doc.pro failed"
+
+ # we'll use our eqmake instead of bundled script to process qmake files
+ sed -i \
+ -e 's:^. ./runqmake.sh$:echo:' \
+ configure || die "sed configure failed"
+
+ # prevent install script from automatically stripping binaries - let portage do that
+ sed -i \
+ -e 's/s) stripcmd="$stripprog"$/s)/' \
+ install.sh || die "sed install.sh failed"
+
+ if ! use pch; then
+ sed -i \
+ -e '/^PRECOMPILED_HEADER =/,/[^\\]$/d' \
+ -e '/^CONFIG += precompile_header/d' \
+ src/gui/gui.pro || die "sed for gui.pro failed"
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-docdir=/usr/share/doc/${PF}
+
+ for pro_file in $(find "${S}" -name "*.pro"); do
+ eqmake4 "${pro_file}" -o "$(dirname ${pro_file})/Makefile" "CONFIG+=nostrip" || die "eqmake4 for ${pro_file} failed"
+ done
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ cd doc
+ dodoc AUTHORS ChangeLog Credits README* \
+ FWBuilder-Routing-LICENSE.txt PatchAcceptancePolicy.txt
+ doman fwb*.1
+}
+
+pkg_postinst() {
+ validate_desktop_entries
+
+ elog "You need to emerge sys-apps/iproute2 on the machine"
+ elog "that will run the firewall script."
+}