summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-12-20 14:48:38 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-12-20 14:48:38 +0000
commit1c143c5ac69ef25c93ed0668a99fa9ab2d5b72fa (patch)
treed9e534a74e08c52f2421545124b4828446a5b6ee
parentStable on amd64. (Manifest recommit) (diff)
downloadgentoo-2-1c143c5ac69ef25c93ed0668a99fa9ab2d5b72fa.tar.gz
gentoo-2-1c143c5ac69ef25c93ed0668a99fa9ab2d5b72fa.tar.bz2
gentoo-2-1c143c5ac69ef25c93ed0668a99fa9ab2d5b72fa.zip
Parrot: squak! (bug 74405)
-rw-r--r--dev-lang/parrot/ChangeLog11
-rw-r--r--dev-lang/parrot/Manifest2
-rw-r--r--dev-lang/parrot/files/digest-parrot-0.1.11
-rw-r--r--dev-lang/parrot/metadata.xml10
-rw-r--r--dev-lang/parrot/parrot-0.1.1.ebuild43
5 files changed, 67 insertions, 0 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
new file mode 100644
index 000000000000..078db4094ffd
--- /dev/null
+++ b/dev-lang/parrot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lang/parrot
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.1 2004/12/20 14:48:38 mcummings Exp $
+
+*parrot-0.1.1 (20 Dec 2004)
+
+ 20 Dec 2004; Michael Cummings <mcummings@gentoo.org> +parrot-0.1.1.ebuild:
+ Long overdue, the ebuild for parrot. Original version submitted in bug 74405
+ by Adrian Lambeck <adrian.lambeck@basicsedv.de>, cleaned up for a better
+ install.
+
diff --git a/dev-lang/parrot/Manifest b/dev-lang/parrot/Manifest
new file mode 100644
index 000000000000..44f773d3f6ba
--- /dev/null
+++ b/dev-lang/parrot/Manifest
@@ -0,0 +1,2 @@
+MD5 a0ce69eeb54fc8bc98bb1fa19a146074 parrot-0.1.1.ebuild 1035
+MD5 75fbd20b4daec7e1b315a172ad60c64f files/digest-parrot-0.1.1 65
diff --git a/dev-lang/parrot/files/digest-parrot-0.1.1 b/dev-lang/parrot/files/digest-parrot-0.1.1
new file mode 100644
index 000000000000..1d3b974f49fb
--- /dev/null
+++ b/dev-lang/parrot/files/digest-parrot-0.1.1
@@ -0,0 +1 @@
+MD5 39991aee98df7b1249e44cced43403e3 parrot-0.1.1.tar.gz 8878237
diff --git a/dev-lang/parrot/metadata.xml b/dev-lang/parrot/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/dev-lang/parrot/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/dev-lang/parrot/parrot-0.1.1.ebuild b/dev-lang/parrot/parrot-0.1.1.ebuild
new file mode 100644
index 000000000000..6ad7e5452ccd
--- /dev/null
+++ b/dev-lang/parrot/parrot-0.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-0.1.1.ebuild,v 1.1 2004/12/20 14:48:38 mcummings Exp $
+
+DESCRIPTION="The virtual machine that perl6 relies on."
+HOMEPAGE="http://www.parrotcode.org/"
+SRC_URI="mirror://cpan/authors/id/L/LT/LTOETSCH/${S}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+#this ebuild has been tested with the given perl
+#if we trust the README then 5.6 should also be ok.
+DEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-libs/icu-2.6"
+
+src_compile() {
+ #This configure defines the DESTDIR for make.
+ perl Configure.pl --prefix=${D}|| die "Perl ./Configure.pl failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+
+ #The prefix was set by Configure.pl - see src_compile().
+ make install BUILDPREFIX=${D} PREFIX=/usr/${P} || die
+ dodir /usr/bin
+ dosym /usr/${P}/bin/parrot /usr/bin
+
+ #TODO: put the doc (pod) and examples in a special dir
+ #/docs/ /examples/
+ #Note: this is not yet supported by the Makefile
+
+ #TODO:
+ #dodoc ...
+}
+
+src_test() {
+ emake test || die "test failed"
+}
+