summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-18 20:57:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-18 20:57:11 +0000
commit1b53c4a91399274bd90d2dbb4c20b71bde4c4eab (patch)
treeca4c7694f8db0d405fe914c47e124f04f50a99c9
parentVersion bump with USE=cxx updates. #390637 by Stefan Zwanenburg. (diff)
downloadgentoo-2-1b53c4a91399274bd90d2dbb4c20b71bde4c4eab.tar.gz
gentoo-2-1b53c4a91399274bd90d2dbb4c20b71bde4c4eab.tar.bz2
gentoo-2-1b53c4a91399274bd90d2dbb4c20b71bde4c4eab.zip
Introduce libglyr support and enable it by default for complete plug-in.
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/ChangeLog6
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/metadata.xml3
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild8
3 files changed, 11 insertions, 6 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
index d73d76e84bb0..76e7c957366f 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-soundmenu-plugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.1 2011/10/26 18:07:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.2 2011/11/18 20:57:11 ssuominen Exp $
+
+ 18 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-soundmenu-plugin-0.2.4.1.ebuild:
+ Introduce libglyr support and enable it by default for complete plug-in.
*xfce4-soundmenu-plugin-0.2.4.1 (26 Oct 2011)
diff --git a/xfce-extra/xfce4-soundmenu-plugin/metadata.xml b/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
index 32ddcc04b889..19f5f9a432bc 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
+++ b/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>xfce</herd>
<use>
- <flag name="lastfm">Enable last.fm support using <pkg>media-libs/libclastfm</pkg></flag>
+ <flag name='glyr'>Enable music metadata searchengine support using <pkg>media-libs/glyr</pkg></flag>
+ <flag name='lastfm'>Enable last.fm support using <pkg>media-libs/libclastfm</pkg></flag>
</use>
</pkgmetadata>
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild
index 9e8522447a4f..77442b950e96 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild,v 1.1 2011/10/26 18:07:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.2.4.1.ebuild,v 1.2 2011/11/18 20:57:11 ssuominen Exp $
EAPI=4
inherit xfconf
@@ -12,7 +12,7 @@ SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug lastfm"
+IUSE="debug +glyr lastfm"
RDEPEND=">=dev-libs/dbus-glib-0.74
>=dev-libs/keybinder-0.2
@@ -20,6 +20,7 @@ RDEPEND=">=dev-libs/dbus-glib-0.74
>=xfce-base/libxfce4ui-4.8
>=xfce-base/libxfce4util-4.8
>=xfce-base/xfce4-panel-4.8
+ glyr? ( media-libs/glyr )
lastfm? ( media-libs/libclastfm )"
DEPEND="${RDEPEND}
dev-util/intltool
@@ -27,10 +28,9 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
pkg_setup() {
- # FIXME: Include libglyr in Portage
XFCONF=(
$(use_enable lastfm libclastfm)
- --disable-libglyr
+ $(use_enable glyr libglyr)
$(xfconf_use_debug)
)