summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-04 18:21:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-04 18:21:41 +0000
commit1b4e906b91e44f1fa970ed7920e01fe985461dec (patch)
tree00d28fd429fc25a9350dfda5a15f4d5e849a6b31
parentnew emul rc (diff)
downloadgentoo-2-1b4e906b91e44f1fa970ed7920e01fe985461dec.tar.gz
gentoo-2-1b4e906b91e44f1fa970ed7920e01fe985461dec.tar.bz2
gentoo-2-1b4e906b91e44f1fa970ed7920e01fe985461dec.zip
Version bump.
(Portage version: 14490-svn/cvs/Linux x86_64)
-rw-r--r--dev-python/python-docs/ChangeLog8
-rw-r--r--dev-python/python-docs/python-docs-2.6.3.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index 5da7e835cf2a..5b654319a6da 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.129 2009/09/27 14:28:56 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.130 2009/10/04 18:21:41 arfrever Exp $
+
+*python-docs-2.6.3 (04 Oct 2009)
+
+ 04 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +python-docs-2.6.3.ebuild:
+ Version bump.
27 Sep 2009; nixnut <nixnut@gentoo.org> python-docs-2.6.2-r1.ebuild:
ppc stable #277645
diff --git a/dev-python/python-docs/python-docs-2.6.3.ebuild b/dev-python/python-docs/python-docs-2.6.3.ebuild
new file mode 100644
index 000000000000..edeac7c74731
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.6.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.3.ebuild,v 1.1 2009/10/04 18:21:41 arfrever Exp $
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-python-20090606"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${D}/usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+eselect_python_update() {
+ local ignored_python_slots
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+
+ # Create python2 symlink.
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+
+ eselect python update ${ignored_python_slots}
+}
+
+pkg_postinst() {
+ eselect_python_update
+}
+
+pkg_postrm() {
+ eselect_python_update
+
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${ROOT}etc/env.d/65python-docs"
+ fi
+
+ rm -f "${ROOT}etc/env.d/50python-docs"
+}