summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-11 23:19:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-11 23:19:23 +0000
commit1ad7308199cf0226ef035b7152d5c47146b6dad7 (patch)
treeff950a7212d8da11ca5221eec0260067418ed864
parentversion bump (diff)
downloadgentoo-2-1ad7308199cf0226ef035b7152d5c47146b6dad7.tar.gz
gentoo-2-1ad7308199cf0226ef035b7152d5c47146b6dad7.tar.bz2
gentoo-2-1ad7308199cf0226ef035b7152d5c47146b6dad7.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--net-voip/gnugk/ChangeLog8
-rw-r--r--net-voip/gnugk/gnugk-3.3.4.ebuild125
2 files changed, 132 insertions, 1 deletions
diff --git a/net-voip/gnugk/ChangeLog b/net-voip/gnugk/ChangeLog
index bd7383b5bd1b..bb06c7e50e54 100644
--- a/net-voip/gnugk/ChangeLog
+++ b/net-voip/gnugk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/gnugk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/ChangeLog,v 1.10 2013/03/06 02:09:40 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/ChangeLog,v 1.11 2013/07/11 23:19:23 chithanh Exp $
+
+*gnugk-3.3.4 (11 Jul 2013)
+
+ 11 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +gnugk-3.3.4.ebuild:
+ Version bump.
*gnugk-3.2.2 (06 Mar 2013)
diff --git a/net-voip/gnugk/gnugk-3.3.4.ebuild b/net-voip/gnugk/gnugk-3.3.4.ebuild
new file mode 100644
index 000000000000..961cce05cd4f
--- /dev/null
+++ b/net-voip/gnugk/gnugk-3.3.4.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/gnugk-3.3.4.ebuild,v 1.1 2013/07/11 23:19:23 chithanh Exp $
+
+EAPI="5"
+
+inherit eutils versionator
+
+MY_P1=${PN}-$(replace_version_separator 2 -)
+MY_P2=${PN}-$(get_version_component_range 1-2)
+
+DESCRIPTION="GNU H.323 gatekeeper"
+HOMEPAGE="http://www.gnugk.org/"
+SRC_URI="mirror://sourceforge/openh323gk/${MY_P1}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# dev-db/firebird isn't keyworded for ppc but firebird IUSE is masked for ppc
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc firebird lua mysql odbc postgres radius snmp sqlite ssh linguas_en linguas_es linguas_fr"
+REQUIRED_USE="doc? (
+ || ( linguas_en linguas_es linguas_fr )
+ )
+"
+
+RDEPEND="net-libs/ptlib:=
+ net-libs/h323plus:=
+ dev-libs/openssl
+ firebird? ( dev-db/firebird )
+ lua? ( dev-lang/lua )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql-base )
+ snmp? ( net-analyzer/net-snmp )
+ ssh? ( net-libs/libssh )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+S=${WORKDIR}/${MY_P2}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.2.2-ptrace.patch
+ epatch "${FILESDIR}"/${PN}-3.2.2-h323plus-buildopts.patch
+ epatch "${FILESDIR}"/${PN}-3.2.2-lua.cxx-toolkit_h.patch
+}
+
+# TODO: investigate possible ebuild conversion to use cmake
+src_configure() {
+ # --with-large-fdset=4096 is added because of bug #128102
+ # and it is recommended in the online manual
+ econf \
+ $(use_enable firebird) \
+ $(use_enable lua) \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable odbc unixodbc) \
+ $(use_enable radius) \
+ $(use_enable snmp netsnmp) \
+ $(use_enable sqlite) \
+ $(use_enable ssh libssh) \
+ --with-large-fdset=4096
+}
+
+src_compile() {
+ # PASN_NOPRINT should be set for -debug but it's buggy
+ # better to prevent issues and keep default settings
+ # `make debugdepend debugshared` and `make debug` failed (so no debug)
+ # `make optdepend optnoshared` also failed (so no static)
+
+ # splitting emake calls fixes parallel build issue
+ emake optdepend
+ emake \
+ PT_LIBDIR="$(ptlib-config --libdir)" \
+ OH323_LIBDIR="${EPREFIX}"/usr/lib \
+ optshared
+ # build tool addpasswd
+ emake -C addpasswd PTLIBDIR="$(ptlib-config --ptlibdir)"
+
+ if use doc; then
+ cd docs/manual
+
+ if use linguas_en; then
+ emake html
+ fi
+
+ if use linguas_es; then
+ emake html-es
+ fi
+
+ if use linguas_fr; then
+ emake html-fr
+ fi
+ cd ../..
+ fi
+}
+
+src_install() {
+ dosbin obj_*_*_*/${PN}
+ dosbin addpasswd/obj_*_*_*/addpasswd
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins etc/*
+
+ dodoc changes.txt readme.txt
+ dodoc docs/*.txt docs/*.pdf
+
+ if use doc; then
+ if use linguas_en; then
+ dohtml docs/manual/manual*.html
+ fi
+ if use linguas_fr; then
+ dohtml docs/manual/fr/manual-fr*.html
+ fi
+ if use linguas_es; then
+ dohtml docs/manual/es/manual-es*.html
+ fi
+ fi
+
+ doman docs/${PN}.1 docs/addpasswd.1
+
+ newinitd "${FILESDIR}"/${PN}.rc6 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}