summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-05 15:03:51 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-05 15:03:51 +0000
commit1a73bc2dabb818747c8baebb87ce003ff19f7866 (patch)
tree20e8ec4c67a2e19fd0b4ad9bd16d6261ff3e21b1
parentFixed build issue with new libtool, bug #272681, thank Diego Stamigni and Die... (diff)
downloadgentoo-2-1a73bc2dabb818747c8baebb87ce003ff19f7866.tar.gz
gentoo-2-1a73bc2dabb818747c8baebb87ce003ff19f7866.tar.bz2
gentoo-2-1a73bc2dabb818747c8baebb87ce003ff19f7866.zip
Version bump, remove broken version.
(Portage version: 2.2_rc33/cvs/Linux i686)
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/ipset-3.0.ebuild (renamed from net-firewall/ipset/ipset-2.5.0.ebuild)30
2 files changed, 23 insertions, 15 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 3f2fe555dedb..519a7ecc2959 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.27 2009/05/14 23:05:53 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.28 2009/06/05 15:03:51 pva Exp $
+
+*ipset-3.0 (05 Jun 2009)
+
+ 05 Jun 2009; Peter Volkov <pva@gentoo.org> -ipset-2.5.0.ebuild,
+ +ipset-3.0.ebuild:
+ Version bump, remove broken version.
*ipset-2.5.0-r1 (14 May 2009)
diff --git a/net-firewall/ipset/ipset-2.5.0.ebuild b/net-firewall/ipset/ipset-3.0.ebuild
index b9f778f72b40..248028cf5ad4 100644
--- a/net-firewall/ipset/ipset-2.5.0.ebuild
+++ b/net-firewall/ipset/ipset-3.0.ebuild
@@ -1,16 +1,20 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.5.0.ebuild,v 1.1 2009/04/04 09:11:22 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-3.0.ebuild,v 1.1 2009/06/05 15:03:51 pva Exp $
+
+EAPI="2"
inherit eutils versionator toolchain-funcs linux-mod linux-info
DESCRIPTION="IPset tool for iptables, successor to ippool."
HOMEPAGE="http://ipset.netfilter.org/"
SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+
RDEPEND=">=net-firewall/iptables-1.4.1"
DEPEND="${RDEPEND}"
@@ -22,7 +26,7 @@ BUILD_PARAMS="IP_NF_SET_MAX=$IP_NF_SET_MAX IP_NF_SET_HASHSIZE=${IP_NF_SET_HASHSI
BUILD_TARGETS="all"
MODULE_NAMES_ARG="kernel/net/ipv4/netfilter:${S}/kernel"
MODULE_NAMES=""
-for i in ip_set{,_{{ip,port,macip}map,{ip,net,ipport}hash,iptree{,map}}} \
+for i in ip_set{,_{setlist,{ip,port,macip}map,{ip,net,ipport,ipportip,ipportnet}hash,iptree{,map}}} \
ipt_{SET,set}; do
MODULE_NAMES="${MODULE_NAMES} ${i}(${MODULE_NAMES_ARG})"
done
@@ -30,18 +34,6 @@ done
CONFIG_CHECK="NETFILTER"
ERROR_CFG="ipset needs netfilter support in your kernel."
-src_unpack() {
- unpack ${A}
- sed -i \
- -e 's/KERNELDIR/(KERNELDIR)/g' \
- -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
- -e '/^all::/iV ?= 0' \
- -e '/^all::/iKBUILD_OUTPUT ?=' \
- -e '/$(MAKE)/{s/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/}' \
- "${S}"/kernel/Makefile
-
-}
-
pkg_setup() {
get_version
@@ -66,6 +58,16 @@ pkg_setup() {
export myconf
}
+src_prepare() {
+ sed -i \
+ -e 's/KERNELDIR/(KERNELDIR)/g' \
+ -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
+ -e '/^all::/iV ?= 0' \
+ -e '/^all::/iKBUILD_OUTPUT ?=' \
+ -e '/$(MAKE)/{s/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/}' \
+ "${S}"/kernel/Makefile
+}
+
src_compile() {
einfo "Building userspace"
emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} binaries || die "failed to build"