summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-25 06:38:13 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-25 06:38:13 +0000
commit19fc394455673e9da99cbe70b40817afcb7795f4 (patch)
tree835287cd75e65f4cd045bc803b1a4edaec24b9a7
parentBump (diff)
downloadgentoo-2-19fc394455673e9da99cbe70b40817afcb7795f4.tar.gz
gentoo-2-19fc394455673e9da99cbe70b40817afcb7795f4.tar.bz2
gentoo-2-19fc394455673e9da99cbe70b40817afcb7795f4.zip
dev-haskell/vector-algorithms: 0.5.4.2
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
-rw-r--r--dev-haskell/vector-algorithms/ChangeLog10
-rw-r--r--dev-haskell/vector-algorithms/files/vector-algorithms-0.5.4.1-ghc-7.4.patch21
-rw-r--r--dev-haskell/vector-algorithms/metadata.xml11
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.5.4.2.ebuild29
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/vector-algorithms/ChangeLog b/dev-haskell/vector-algorithms/ChangeLog
new file mode 100644
index 000000000000..e2756280a3fa
--- /dev/null
+++ b/dev-haskell/vector-algorithms/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/vector-algorithms
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector-algorithms/ChangeLog,v 1.1 2013/08/25 06:38:13 qnikst Exp $
+
+*vector-algorithms-0.5.4.2 (25 Aug 2013)
+
+ 25 Aug 2013; Alexander Vershilov <qnikst@gentoo.org>
+ +files/vector-algorithms-0.5.4.1-ghc-7.4.patch, +metadata.xml,
+ +vector-algorithms-0.5.4.2.ebuild:
+ dev-haskell/vector-algorithms: 0.5.4.2
diff --git a/dev-haskell/vector-algorithms/files/vector-algorithms-0.5.4.1-ghc-7.4.patch b/dev-haskell/vector-algorithms/files/vector-algorithms-0.5.4.1-ghc-7.4.patch
new file mode 100644
index 000000000000..edabcf2e8b54
--- /dev/null
+++ b/dev-haskell/vector-algorithms/files/vector-algorithms-0.5.4.1-ghc-7.4.patch
@@ -0,0 +1,21 @@
+--- vector-algorithms-0.5.4.1-orig/vector-algorithms.cabal 2012-08-16 06:39:54.000000000 +1000
++++ vector-algorithms-0.5.4.1/vector-algorithms.cabal 2012-08-17 17:05:37.875993915 +1000
+@@ -52,9 +52,15 @@
+ FlexibleContexts,
+ CPP
+
+- GHC-Options:
+- -Odph
+- -funbox-strict-fields
++ if impl(ghc >= 7.4.0)
++ GHC-Options:
++ -Odph
++ -funbox-strict-fields
++ -fsimpl-tick-factor=153
++ else
++ GHC-Options:
++ -Odph
++ -funbox-strict-fields
+
+ Include-Dirs:
+ include
diff --git a/dev-haskell/vector-algorithms/metadata.xml b/dev-haskell/vector-algorithms/metadata.xml
new file mode 100644
index 000000000000..8a8216dce180
--- /dev/null
+++ b/dev-haskell/vector-algorithms/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Efficient algorithms for vector arrays
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.5.4.2.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.5.4.2.ebuild
new file mode 100644
index 000000000000..07f04a2bc428
--- /dev/null
+++ b/dev-haskell/vector-algorithms/vector-algorithms-0.5.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector-algorithms/vector-algorithms-0.5.4.2.ebuild,v 1.1 2013/08/25 06:38:13 qnikst Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Efficient algorithms for vector arrays"
+HOMEPAGE="http://code.haskell.org/~dolio/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/primitive-0.3[profile?]
+ <dev-haskell/primitive-0.6[profile?]
+ >=dev-haskell/vector-0.6[profile?]
+ <dev-haskell/vector-0.11[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.4.1-ghc-7.4.patch")