summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-01-12 22:20:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-01-12 22:20:38 +0000
commit19f25bca5121339668d0ca5ccfdb9d0327972e7d (patch)
tree8e2d18d8586e303d927bb3a1f94511912ae9c0bc
parentAdd linguas support, fix desktop file per bug#443110, fix libexec location pe... (diff)
downloadgentoo-2-19f25bca5121339668d0ca5ccfdb9d0327972e7d.tar.gz
gentoo-2-19f25bca5121339668d0ca5ccfdb9d0327972e7d.tar.bz2
gentoo-2-19f25bca5121339668d0ca5ccfdb9d0327972e7d.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--app-emulation/spice/ChangeLog7
-rw-r--r--app-emulation/spice/spice-0.12.2.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index 157d28c1063a..75aa088f467c 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.40 2013/01/12 22:01:23 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.41 2013/01/12 22:20:38 cardoe Exp $
+
+*spice-0.12.2 (12 Jan 2013)
+
+ 12 Jan 2013; Doug Goldstein <cardoe@gentoo.org> +spice-0.12.2.ebuild:
+ Version bump
12 Jan 2013; Doug Goldstein <cardoe@gentoo.org> -spice-0.10.0.ebuild,
-spice-0.10.1.ebuild, -spice-0.11.0.ebuild, -spice-0.8.1.ebuild,
diff --git a/app-emulation/spice/spice-0.12.2.ebuild b/app-emulation/spice/spice-0.12.2.ebuild
new file mode 100644
index 000000000000..38a66a5c85d5
--- /dev/null
+++ b/app-emulation/spice/spice-0.12.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.2.ebuild,v 1.1 2013/01/12 22:20:38 cardoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+client +gui sasl smartcard static-libs" # static
+
+RDEPEND=">=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ virtual/jpeg
+ sys-libs/zlib
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( >=app-emulation/libcacard-0.1.2 )
+ client? (
+ gui? ( =dev-games/cegui-0.6*[opengl] )
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ )"
+
+# broken as we don't have static alsa-lib and building that one static requires more work
+# static? (
+# >=x11-libs/pixman-0.17.7[static-libs(+)]
+# media-libs/celt:0.5.1[static-libs(+)]
+# virtual/jpeg[static-libs(+)]
+# sys-libs/zlib[static-libs(+)]
+# media-libs/alsa-lib[static-libs(-)]
+# >=x11-libs/libXrandr-1.2[static-libs(+)]
+# x11-libs/libX11[static-libs(+)]
+# x11-libs/libXext[static-libs(+)]
+# x11-libs/libXinerama[static-libs(+)]
+# x11-libs/libXfixes[static-libs(+)]
+# x11-libs/libXrender[static-libs(+)]
+# )
+# )"
+DEPEND="virtual/pkgconfig
+ virtual/pyparsing
+ ${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+# maintainer notes:
+# * opengl support is currently broken
+# * TODO: add slirp for tunnel-support
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/0.11.0-gold.patch"
+}
+
+src_configure() {
+ python_convert_shebangs 2 spice-common/spice_codegen.py
+
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tunnel \
+ $(use_enable client) \
+ $(use_enable gui) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ --disable-static-linkage
+# $(use_enable static static-linkage) \
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}