summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-08-30 20:44:45 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-08-30 20:44:45 +0000
commit1871f66627e8644769a2f036369470093a646bde (patch)
tree58dd3f5bf8f18167d37532135891e76e832491d3
parentremasked perl 5.8.0 (diff)
downloadgentoo-2-1871f66627e8644769a2f036369470093a646bde.tar.gz
gentoo-2-1871f66627e8644769a2f036369470093a646bde.tar.bz2
gentoo-2-1871f66627e8644769a2f036369470093a646bde.zip
gcc3.2 fixes
-rw-r--r--net-im/gabber/ChangeLog13
-rw-r--r--net-im/gabber/files/TCPtransmitter.cc-gcc3-gentoo.patch12
-rw-r--r--net-im/gabber/files/digest-gabber-0.8.7-r31
-rw-r--r--net-im/gabber/gabber-0.8.7-r3.ebuild60
4 files changed, 84 insertions, 2 deletions
diff --git a/net-im/gabber/ChangeLog b/net-im/gabber/ChangeLog
index cb048259b795..d15572c88204 100644
--- a/net-im/gabber/ChangeLog
+++ b/net-im/gabber/ChangeLog
@@ -1,13 +1,22 @@
# ChangeLog for net-im/gabber
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/ChangeLog,v 1.5 2002/07/09 17:09:15 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/ChangeLog,v 1.6 2002/08/30 20:44:45 mkennedy Exp $
+
+*gabber-0.8.7-r3 (30 Aug 2002)
+
+ 30 Aug 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ gabber-0.8.7-r3.ebuild, files/digest-gabber-0.8.7-r3,
+ files/TCPtransmitter.cc-gcc3-gentoo.patch, ChangeLog :
+
+ Two GCC3.2 fixes: fixed a standard "package tries to override GCC3.2
+ system include dirs" problem, fixed minor C++ coding mistake.
*gabber-0.8.6-r2 (07 Jul 2002)
07 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> gabber-0.8.6-r2.ebuild :
Updated dependecies, added xmms support in the ebuild (use xmms ...).
Also fixes bug #4739
-gabber-0.8.6-r1 (8 Jun 2002)
+*gabber-0.8.6-r1 (8 Jun 2002)
8 Jun 2002; Spider <spider@gentoo.org> gabber-0.8.6-r1.ebuild
added limits to some libraries in DEPEND
diff --git a/net-im/gabber/files/TCPtransmitter.cc-gcc3-gentoo.patch b/net-im/gabber/files/TCPtransmitter.cc-gcc3-gentoo.patch
new file mode 100644
index 000000000000..bd1a3a1356ea
--- /dev/null
+++ b/net-im/gabber/files/TCPtransmitter.cc-gcc3-gentoo.patch
@@ -0,0 +1,12 @@
+diff -u gabber-0.8.7.orig/src/TCPTransmitter.cc gabber-0.8.7/src/TCPTransmitter.cc
+--- gabber-0.8.7.orig/src/TCPTransmitter.cc Sun Feb 17 16:29:51 2002
++++ gabber-0.8.7/src/TCPTransmitter.cc Fri Aug 30 14:30:13 2002
+@@ -1338,7 +1338,7 @@
+ }
+ }
+
+-void TCPTransmitter::setProxy(const string &ptype, const string &host, guint port, const string &user, const string &password, bool tryOther = true)
++void TCPTransmitter::setProxy(const string &ptype, const string &host, guint port, const string &user, const string &password, bool tryOther)
+ {
+ if (_state != Offline)
+ {
diff --git a/net-im/gabber/files/digest-gabber-0.8.7-r3 b/net-im/gabber/files/digest-gabber-0.8.7-r3
new file mode 100644
index 000000000000..2ffc6f94e97c
--- /dev/null
+++ b/net-im/gabber/files/digest-gabber-0.8.7-r3
@@ -0,0 +1 @@
+MD5 afd0c258b27dfb386e7ec668a9d371aa gabber-0.8.7.tar.gz 2141334
diff --git a/net-im/gabber/gabber-0.8.7-r3.ebuild b/net-im/gabber/gabber-0.8.7-r3.ebuild
new file mode 100644
index 000000000000..16439ab249cb
--- /dev/null
+++ b/net-im/gabber/gabber-0.8.7-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-0.8.7-r3.ebuild,v 1.1 2002/08/30 20:44:45 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNOME Jabber Client"
+SRC_URI="mirror://sourceforge/gabber/${P}.tar.gz"
+HOMEPAGE="http://gabber.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="*"
+
+DEPEND=">=gnome-base/gnome-libs-1.4.1.7
+ >=gnome-base/libglade-0.17-r1
+ <gnome-base/libglade-2.0.0
+ >=gnome-extra/gal-0.19
+ >=gnome-extra/gnomemm-1.2.2
+ >=x11-libs/gtkmm-1.2.5
+ <x11-libs/gtkmm-1.3.0
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ crypt? ( >=app-crypt/gnupg-1.0.5 )
+ xmms? ( >=media-sound/xmms-1.2.7-r11 )"
+
+RDEPEND="${DEPEND} nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ # patch for minor C++ coding error. sent upstream
+ # (mkennedy@gentoo.org).
+ cd ${S}
+ patch -p1 <${FILESDIR}/TCPtransmitter.cc-gcc3-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+
+ use ssl \
+ || myconf="${myconf} --disable-ssl"
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ use xmms \
+ || myconf="${myconf} --disable-xmms"
+
+ econf ${myconf} || die
+
+ # don't fsck with the gcc systems paths! (mkennedy@gentoo.org)
+ sed -e 's,-I/usr/include ,,g' Makefile >Makefile.new && \
+ cp Makefile.new Makefile
+ sed -e 's,-I/usr/include ,,g' src/Makefile >src/Makefile.new && \
+ cp src/Makefile.new src/Makefile
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}
+