summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-10-03 21:12:52 +0000
committerVlastimil Babka <caster@gentoo.org>2009-10-03 21:12:52 +0000
commit17bacc8e6bd11036daede8e81967a46627250fba (patch)
tree8023c8da22aa7ac4d4251daa1419470241635f94
parentRevbump to add missing podofo dep for bug #287492. Also, remove old ebuilds. (diff)
downloadgentoo-2-17bacc8e6bd11036daede8e81967a46627250fba.tar.gz
gentoo-2-17bacc8e6bd11036daede8e81967a46627250fba.tar.bz2
gentoo-2-17bacc8e6bd11036daede8e81967a46627250fba.zip
Version bump. Remove java5 useflag, and default to java5.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
-rw-r--r--dev-java/jdbc-postgresql/ChangeLog10
-rw-r--r--dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p504-build.xml.patch37
-rw-r--r--dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p505-build.xml.patch37
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-8.3_p605.ebuild75
4 files changed, 84 insertions, 75 deletions
diff --git a/dev-java/jdbc-postgresql/ChangeLog b/dev-java/jdbc-postgresql/ChangeLog
index 4b43ce464e55..992f3fc0179a 100644
--- a/dev-java/jdbc-postgresql/ChangeLog
+++ b/dev-java/jdbc-postgresql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/jdbc-postgresql
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.25 2009/05/06 21:55:28 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.26 2009/10/03 21:12:51 caster Exp $
+
+*jdbc-postgresql-8.3_p605 (03 Oct 2009)
+
+ 03 Oct 2009; Vlastimil Babka <caster@gentoo.org>
+ -files/jdbc-postgresql-8.2_p504-build.xml.patch,
+ -files/jdbc-postgresql-8.2_p505-build.xml.patch,
+ +jdbc-postgresql-8.3_p605.ebuild:
+ Version bump. Remove java5 useflag, and default to java5.
06 May 2009; Petteri Räty <betelgeuse@gentoo.org>
-jdbc-postgresql-8.2_p504.ebuild, -jdbc-postgresql-8.2_p505.ebuild,
diff --git a/dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p504-build.xml.patch b/dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p504-build.xml.patch
deleted file mode 100644
index e5e43df2e3d2..000000000000
--- a/dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p504-build.xml.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- build.xml.original 2006-12-09 00:20:02.000000000 +0100
-+++ build.xml 2006-12-09 17:08:35.000000000 +0100
-@@ -24,6 +24,8 @@
- <property name="builddir" value="build" />
- <property name="package" value="org/postgresql" />
- <property name="debug" value="on" />
-+ <property name="junit" value="true" />
-+ <property name="junit.task" value="true" />
-
- <!-- default build parameters are in build.properties, these may be
- overridden by local configuration settings in build.local.properties
-@@ -63,8 +65,6 @@
-
- <available property="datasourceclass" classname="javax.sql.DataSource"/>
- <available property="ssl" classname="javax.net.ssl.SSLContext"/>
-- <available property="junit" classname="junit.framework.Test"/>
-- <available property="junit.task" classname="org.apache.tools.ant.taskdefs.optional.junit.JUnitTask"/>
-
- <condition property="datasource">
- <isset property="datasourceclass" />
-@@ -386,7 +386,7 @@
- <target name="testjar" depends="jar">
- <fail message="JUnit could not be found in your classpath. You must download and install it from http://junit.org to build and run the test suite." unless="junit" />
- <mkdir dir="${builddir}/tests"/>
-- <javac srcdir="${srcdir}" destdir="${builddir}/tests" debug="${debug}">
-+ <javac classpath="${basedir}/lib/junit.jar" srcdir="${srcdir}" destdir="${builddir}/tests" debug="${debug}">
- <include name="${package}/test/**" />
-
- <exclude name="${package}/test/jdbc2/optional/**" unless="jdbc2optionaltests" />
-@@ -482,7 +482,6 @@
- <param name="base.dir" expression="${builddir}/doc/"/>
- <param name="use.id.as.filename" expression="1" />
- </xslt>
-- <delete file="${builddir}/doc/pgjdbc.html"/>
- </target>
-
- <!-- Blah. Can't reference an external XML catalog until Ant 1.6.
diff --git a/dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p505-build.xml.patch b/dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p505-build.xml.patch
deleted file mode 100644
index e5e43df2e3d2..000000000000
--- a/dev-java/jdbc-postgresql/files/jdbc-postgresql-8.2_p505-build.xml.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- build.xml.original 2006-12-09 00:20:02.000000000 +0100
-+++ build.xml 2006-12-09 17:08:35.000000000 +0100
-@@ -24,6 +24,8 @@
- <property name="builddir" value="build" />
- <property name="package" value="org/postgresql" />
- <property name="debug" value="on" />
-+ <property name="junit" value="true" />
-+ <property name="junit.task" value="true" />
-
- <!-- default build parameters are in build.properties, these may be
- overridden by local configuration settings in build.local.properties
-@@ -63,8 +65,6 @@
-
- <available property="datasourceclass" classname="javax.sql.DataSource"/>
- <available property="ssl" classname="javax.net.ssl.SSLContext"/>
-- <available property="junit" classname="junit.framework.Test"/>
-- <available property="junit.task" classname="org.apache.tools.ant.taskdefs.optional.junit.JUnitTask"/>
-
- <condition property="datasource">
- <isset property="datasourceclass" />
-@@ -386,7 +386,7 @@
- <target name="testjar" depends="jar">
- <fail message="JUnit could not be found in your classpath. You must download and install it from http://junit.org to build and run the test suite." unless="junit" />
- <mkdir dir="${builddir}/tests"/>
-- <javac srcdir="${srcdir}" destdir="${builddir}/tests" debug="${debug}">
-+ <javac classpath="${basedir}/lib/junit.jar" srcdir="${srcdir}" destdir="${builddir}/tests" debug="${debug}">
- <include name="${package}/test/**" />
-
- <exclude name="${package}/test/jdbc2/optional/**" unless="jdbc2optionaltests" />
-@@ -482,7 +482,6 @@
- <param name="base.dir" expression="${builddir}/doc/"/>
- <param name="use.id.as.filename" expression="1" />
- </xslt>
-- <delete file="${builddir}/doc/pgjdbc.html"/>
- </target>
-
- <!-- Blah. Can't reference an external XML catalog until Ant 1.6.
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-8.3_p605.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-8.3_p605.ebuild
new file mode 100644
index 000000000000..d6158880cef1
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-8.3_p605.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.3_p605.ebuild,v 1.1 2009/10/03 21:12:51 caster Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="postgresql-jdbc"
+MY_PV="${PV/_p/-}"
+MY_P="${MY_PN}-${MY_PV}.src"
+
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://jdbc.postgresql.org/"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="java6 test"
+
+DEPEND=">=dev-java/java-config-2.0.31
+ java6? ( =virtual/jdk-1.6* )
+ !java6? ( =virtual/jdk-1.5* )
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+ test? (
+ dev-java/ant-junit
+ virtual/postgresql-server
+ )"
+RDEPEND="java6? ( >=virtual/jre-1.6 )
+ !java6? ( >=virtual/jre-1.5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+EANT_DOC_TARGET="publicapi"
+
+src_compile() {
+ java-pkg-2_src_compile
+
+ # There is a task that creates this doc but I didn't find a way how to use system catalog
+ # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
+ if use doc; then
+ mkdir -p "${S}/build/doc"
+ xsltproc -o "${S}/build/doc/pgjdbc.html" http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
+ "${S}/doc/pgjdbc.xml"
+ fi
+}
+
+src_test() {
+ einfo "In order to run the tests successfully, you have to have:"
+ einfo "1) PostgreSQL server running"
+ einfo "2) database 'test' defined with user 'test' with password 'password'"
+ einfo " as owner of the database"
+ einfo "3) plpgsql support in the 'test' database"
+ einfo
+ einfo "You can find a general info on how to perform these steps at"
+ einfo "http://gentoo-wiki.com/HOWTO_Configure_Postgresql"
+
+ ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only junit)
+}
+
+src_install() {
+ java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
+
+ if use doc ; then
+ java-pkg_dojavadoc build/publicapi
+ dohtml build/doc/pgjdbc.html || die
+ fi
+
+ use source && java-pkg_dosrc org
+}