summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-09-08 16:03:11 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-09-08 16:03:11 +0000
commit17818984cbc6302357d90084eee14e454dab3bf0 (patch)
treea4f111b487acbb99b315a9513045b175e947f73e
parentmask the current development version of cairo for development of the various ... (diff)
downloadgentoo-2-17818984cbc6302357d90084eee14e454dab3bf0.tar.gz
gentoo-2-17818984cbc6302357d90084eee14e454dab3bf0.tar.bz2
gentoo-2-17818984cbc6302357d90084eee14e454dab3bf0.zip
Version bump. Currently masked why we develop all the necessary build requirements and steps for all the various backends.
(Portage version: 2.1.9.1/cvs/Linux x86_64)
-rw-r--r--x11-libs/cairo/ChangeLog8
-rw-r--r--x11-libs/cairo/cairo-1.10.0.ebuild112
-rw-r--r--x11-libs/cairo/metadata.xml4
3 files changed, 123 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index bb61ed77ecdc..2ae77e1a5c1f 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/cairo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.252 2010/08/29 18:23:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.253 2010/09/08 16:03:11 cardoe Exp $
+
+*cairo-1.10.0 (08 Sep 2010)
+
+ 08 Sep 2010; Doug Goldstein <cardoe@gentoo.org> +cairo-1.10.0.ebuild:
+ Version bump. Currently masked why we develop all the necessary build
+ requirements and steps for all the various backends.
29 Aug 2010; Raúl Porcel <armin76@gentoo.org> cairo-1.8.10.ebuild:
ia64/s390/sh/sparc stable wrt #329175
diff --git a/x11-libs/cairo/cairo-1.10.0.ebuild b/x11-libs/cairo/cairo-1.10.0.ebuild
new file mode 100644
index 000000000000..658f42a538b1
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.10.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.10.0.ebuild,v 1.1 2010/09/08 16:03:11 cardoe Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="aqua debug directfb doc drm gallium opengl openvg qt +svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND=">=media-libs/fontconfig-2.2.95
+ >=media-libs/freetype-2.1.9
+ sys-libs/zlib
+ >=media-libs/libpng-1.2.43-r2:0
+ >=x11-libs/pixman-0.18.4
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ gallium? ( media-libs/mesa[gallium] )
+ qt? ( >=x11-libs/qt-gui-4.4:4 )
+ svg? ( dev-libs/libxml2 )
+ X? ( >=x11-libs/libXrender-0.6
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXft
+ drm? ( >=sys-fs/udev-136
+ >=x11-base/xorg-server-1.6 )
+ )
+ xcb? ( >=x11-libs/libxcb-1.4
+ x11-libs/xcb-util )"
+# test? (
+# pdf test
+# x11-libs/pango
+# >=x11-libs/gtk+-2.0
+# >=app-text/poppler-bindings-0.9.2[gtk]
+# ps test
+# app-text/ghostscript-gpl
+# svg test
+# >=x11-libs/gtk+-2.0
+# >=gnome-base/librsvg-2.15.0
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ >=sys-devel/libtool-2
+ doc? ( >=dev-util/gtk-doc-1.6
+ ~app-text/docbook-xml-dtd-4.2 )
+ X? ( x11-proto/renderproto
+ drm? ( x11-proto/xproto
+ >=x11-proto/xextproto-7.1 )
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ # upgraded to an eautoreconf for the above interix patch.
+ eautoreconf
+}
+
+src_configure() {
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
+ # http://bugs.freedesktop.org/show_bug.cgi?id=15463
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D_POSIX_PTHREAD_SEMANTICS
+
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf \
+ $(use_enable X xlib) \
+ $(use_enable X xlib-xrender) \
+ $(use_enable xcb) \
+ $(use_enable svg) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable directfb) \
+ $(use_enable debug test-surfaces) \
+ $(use_enable opengl gl) \
+ $(use_enable openvg vg) \
+ $(use_enable drm) \
+ $(use_enable gallium) \
+ --enable-pdf \
+ --enable-png \
+ --enable-ft \
+ --enable-ps \
+ $(use_enable aqua quartz) \
+ $(use_enable aqua quartz-image) \
+ $(use_enable aqua quartz-font) \
+ || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ if use xcb; then
+ ewarn "You have enabled the Cairo XCB backend which is used only by"
+ ewarn "a select few apps. The Cairo XCB backend is presently"
+ ewarn "un-maintained and needs a lot of work to get it caught up"
+ ewarn "to the Xrender and Xlib backends, which are the backends used"
+ ewarn "by most applications. See:"
+ ewarn "http://lists.freedesktop.org/archives/xcb/2008-December/004139.html"
+ fi
+}
diff --git a/x11-libs/cairo/metadata.xml b/x11-libs/cairo/metadata.xml
index c6767c474816..98a626c8050e 100644
--- a/x11-libs/cairo/metadata.xml
+++ b/x11-libs/cairo/metadata.xml
@@ -20,5 +20,9 @@
Ubuntu</flag>
<flag name='opengl'>When used along with USE=glitz, enables glitz-glx usage.
Requires hardware OpenGL support</flag>
+ <flag name='drm'>Use Linux DRM for backend acceleration</flag>
+ <flag name='gallium'>Use Mesa's Gallium backend for acceleration</flag>
+ <flag name='openvg'>Use OpenVG for backend acceleration</flag>
+ <flag name='qt'>Use Qt for rendering</flag>
</use>
</pkgmetadata>