summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-12 19:44:30 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-12 19:44:30 +0000
commit169af50cfa1fff3f157e8c34fae17fbcb0c3e07b (patch)
treeb5afa33d82231acfe5a607b0a0158fa525dc434c
parentAdd fix from upstream for building on sparc #336939 by Raúl Porcel. (diff)
downloadgentoo-2-169af50cfa1fff3f157e8c34fae17fbcb0c3e07b.tar.gz
gentoo-2-169af50cfa1fff3f157e8c34fae17fbcb0c3e07b.tar.bz2
gentoo-2-169af50cfa1fff3f157e8c34fae17fbcb0c3e07b.zip
Initial commit, special thanks to Arfrever, djc and darkside for their help
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--www-apps/venus/ChangeLog11
-rw-r--r--www-apps/venus/files/postinstall-en.txt10
-rw-r--r--www-apps/venus/metadata.xml12
-rw-r--r--www-apps/venus/venus-20100911.ebuild79
4 files changed, 112 insertions, 0 deletions
diff --git a/www-apps/venus/ChangeLog b/www-apps/venus/ChangeLog
new file mode 100644
index 000000000000..dad66e14a7dc
--- /dev/null
+++ b/www-apps/venus/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-apps/venus
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/venus/ChangeLog,v 1.1 2010/09/12 19:44:30 tampakrap Exp $
+
+*venus-20100911 (12 Sep 2010)
+
+ 12 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +venus-20100911.ebuild, +files/postinstall-en.txt, +metadata.xml:
+ Initial commit, special thanks to Arfrever, djc and darkside for their
+ help
+
diff --git a/www-apps/venus/files/postinstall-en.txt b/www-apps/venus/files/postinstall-en.txt
new file mode 100644
index 000000000000..37427c4a8d5a
--- /dev/null
+++ b/www-apps/venus/files/postinstall-en.txt
@@ -0,0 +1,10 @@
+INSTALLATION
+
+Installation instructions can be found at:
+
+http://intertwingly.net/code/venus/docs/
+/usr/share/doc/\${PF}/html
+
+Example configuration files can be found at:
+
+${VHOST_ROOT}/conf
diff --git a/www-apps/venus/metadata.xml b/www-apps/venus/metadata.xml
new file mode 100644
index 000000000000..516f8feb67c6
--- /dev/null
+++ b/www-apps/venus/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>planet</herd>
+ <herd>web-apps</herd>
+ <use>
+ <flag name="django">Support for django template style to config files</flag>
+ <flag name="genshi">Support for genshi style to config files</flag>
+ <flag name="redland">Enable support for Redland RDF</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/www-apps/venus/venus-20100911.ebuild b/www-apps/venus/venus-20100911.ebuild
new file mode 100644
index 000000000000..9dba578d2a99
--- /dev/null
+++ b/www-apps/venus/venus-20100911.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/venus/venus-20100911.ebuild,v 1.1 2010/09/12 19:44:30 tampakrap Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit webapp python
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="A feed aggregator application"
+HOMEPAGE="http://intertwingly.net/code/venus/"
+SRC_URI="http://dev.gentoo.org/~tampakrap/${P}.tar.bz2"
+
+LICENSE="PSF-2.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="django genshi redland test"
+SLOT="0"
+
+DEPEND="
+ test? ( =dev-lang/python-2*[berkdb] )
+ "
+RDEPEND="django? ( dev-python/django )
+ genshi? ( dev-python/genshi )
+ redland? ( dev-python/rdflib[redland] )
+ dev-python/chardet
+ dev-python/httplib2
+ dev-python/utidylib
+"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc AUTHORS README TODO
+ dohtml -r docs/*
+
+ installation() {
+ insinto "$(python_get_sitedir)/${PN}"
+ doins -r *py {filters,planet}
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r themes
+
+ insinto "${MY_HOSTROOTDIR}/conf"
+ doins -r examples
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize venus
+ webapp_pkg_postinst
+ elog "Installation instructions can be found at /usr/share/doc/${PF}/html/
+ or http://intertwingly.net/code/venus/docs/index.html"
+}
+
+pkg_postrm() {
+ python_mod_cleanup venus
+}