summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-08 17:48:21 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-08 17:48:21 +0000
commit15e4292a6f4ac517b555f8155aa8b5b104930492 (patch)
tree941ae1537e1a730296a68e9fc348e9c22eedd01b
parentmu-conference-0.6.0-r2 (diff)
downloadgentoo-2-15e4292a6f4ac517b555f8155aa8b5b104930492.tar.gz
gentoo-2-15e4292a6f4ac517b555f8155aa8b5b104930492.tar.bz2
gentoo-2-15e4292a6f4ac517b555f8155aa8b5b104930492.zip
added 64bit fix. see bug #52634 for more information
-rw-r--r--x11-libs/libast/ChangeLog6
-rw-r--r--x11-libs/libast/files/libast-64bit.patch11
-rw-r--r--x11-libs/libast/libast-0.5-r2.ebuild10
3 files changed, 25 insertions, 2 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index caeaa95a893e..f23f20ac1514 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libast
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.10 2004/06/24 22:04:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.11 2004/07/08 17:48:21 lv Exp $
+
+ 08 Jul 2004; Travis Tilley <lv@gentoo.org> +files/libast-64bit.patch,
+ libast-0.5-r2.ebuild:
+ added 64bit fix. see bug #52634 for more information
*libast-0.5-r2 (22 Feb 2004)
diff --git a/x11-libs/libast/files/libast-64bit.patch b/x11-libs/libast/files/libast-64bit.patch
new file mode 100644
index 000000000000..7aa200279245
--- /dev/null
+++ b/x11-libs/libast/files/libast-64bit.patch
@@ -0,0 +1,11 @@
+diff -Nru libast-0.5.old/include/libast.h libast-0.5/include/libast.h
+--- libast-0.5.old/include/libast.h 2004-07-08 13:39:36.837764880 -0400
++++ libast-0.5/include/libast.h 2004-07-08 13:40:21.287007568 -0400
+@@ -337,6 +337,7 @@
+ /* fill l with c. */ \
+ l = (c) | (c)<<8; \
+ l |= l<<16; \
++ l |= l<<32; \
+ MEMSET_LONG(); \
+ \
+ /* fill in 1-byte chunks until boundary of long is reached. */ \
diff --git a/x11-libs/libast/libast-0.5-r2.ebuild b/x11-libs/libast/libast-0.5-r2.ebuild
index 20ef79071b44..88b4c92364cc 100644
--- a/x11-libs/libast/libast-0.5-r2.ebuild
+++ b/x11-libs/libast/libast-0.5-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.3 2004/06/24 22:04:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.4 2004/07/08 17:48:21 lv Exp $
+
+inherit 64-bit
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -16,6 +18,12 @@ DEPEND="virtual/x11
X? ( imlib? ( media-libs/imlib2 ) )
perl? ( dev-libs/libpcre )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ 64-bit && epatch ${FILESDIR}/libast-64bit.patch
+}
+
src_compile() {
local myconf
use X && use imlib \