summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2008-03-17 07:30:05 +0000
committerPeter Weller <welp@gentoo.org>2008-03-17 07:30:05 +0000
commit15281c28114fa3ce0697f1dd09cb4805a09bb10c (patch)
treef81a0b12d786868b41b933d8b5e71fc05747192b
parentBump (diff)
downloadgentoo-2-15281c28114fa3ce0697f1dd09cb4805a09bb10c.tar.gz
gentoo-2-15281c28114fa3ce0697f1dd09cb4805a09bb10c.tar.bz2
gentoo-2-15281c28114fa3ce0697f1dd09cb4805a09bb10c.zip
Bump
(Portage version: 2.1.4.4)
-rw-r--r--app-editors/tea/ChangeLog7
-rw-r--r--app-editors/tea/tea-17.6.0.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 98a5087974a5..6766472890b6 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.32 2008/03/01 19:03:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.33 2008/03/17 07:30:05 welp Exp $
+
+*tea-17.6.0 (17 Mar 2008)
+
+ 17 Mar 2008; Peter Weller <welp@gentoo.org> +tea-17.6.0.ebuild:
+ Bump
01 Mar 2008; Raúl Porcel <armin76@gentoo.org> tea-17.5.4.ebuild:
x86 stable
diff --git a/app-editors/tea/tea-17.6.0.ebuild b/app-editors/tea/tea-17.6.0.ebuild
new file mode 100644
index 000000000000..83634a840638
--- /dev/null
+++ b/app-editors/tea/tea-17.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-17.6.0.ebuild,v 1.1 2008/03/17 07:30:05 welp Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Small, lightweight GTK+ text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="enchant gnome hacking ipv6 spell"
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libX11
+ gnome? ( >=x11-libs/gtksourceview-2
+ gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ net-misc/curl
+ spell? ( app-text/aspell )
+ enchant? ( app-text/enchant )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-forced-cflags-and-compiler-warnings.patch
+ eautoconf
+}
+
+src_compile() {
+ local myconf
+
+ if use hacking; then
+ myconf="${myconf} --enable-hacking"
+ fi
+ if ! use gnome; then
+ myconf="${myconf} --enable-legacy"
+ fi
+ if use enchant; then
+ myconf="${myconf} --enable-enchant"
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ ${myconf} || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed!"
+
+ make_desktop_entry tea Tea /usr/share/tea/pixmaps/tea_icon_v2.png Development
+
+# insinto /usr/share/doc/tea/
+# doins AUTHORS COPYING NEWS README TODO ChangeLog doc/*
+
+# insinto /usr/share/pixmaps/
+# doins pixmaps/*
+}
+
+pkg_postinst() {
+ if use spell ; then
+ elog "To get full spellchecking functuality, ensure that you install"
+ elog "the relevant language pack(s)"
+ fi
+}