summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-07-30 18:37:03 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-07-30 18:37:03 +0000
commit1518e295764be257358be0195e5e40232de27477 (patch)
treed959638dcc13697bd41791e2c84a9a3cf67b3d83
parentQA: Remove default src_compile (diff)
downloadgentoo-2-1518e295764be257358be0195e5e40232de27477.tar.gz
gentoo-2-1518e295764be257358be0195e5e40232de27477.tar.bz2
gentoo-2-1518e295764be257358be0195e5e40232de27477.zip
fix bad header
(Portage version: 2.0.51.22-r2)
-rw-r--r--sys-libs/libsystem/Manifest4
-rw-r--r--sys-libs/libsystem/libsystem-7.1.ebuild34
-rw-r--r--sys-libs/libsystem/libsystem-darwin-71.1.3.ebuild80
3 files changed, 35 insertions, 83 deletions
diff --git a/sys-libs/libsystem/Manifest b/sys-libs/libsystem/Manifest
index 97277b5136dc..fdf6c3c94b1a 100644
--- a/sys-libs/libsystem/Manifest
+++ b/sys-libs/libsystem/Manifest
@@ -1,5 +1,3 @@
-MD5 deb9de9e3ece403cab6900877a90c9cb .libsystem-darwin-71.1.3.swp 12288
MD5 d77fdca3607d4907137808c04633e51a ChangeLog 470
-MD5 3606faa8946f6d7f5fffce3b684da83a libsystem-darwin-71.1.3.ebuild 1985
+MD5 ae5cc45b9ecb13d3d61f48000b774c92 libsystem-7.1.ebuild 1015
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-libsystem-7.1 0
-MD5 6f01a5b8b1cb050d413c02b1b4a34ae4 files/digest-libsystem-darwin-71.1.3 67
diff --git a/sys-libs/libsystem/libsystem-7.1.ebuild b/sys-libs/libsystem/libsystem-7.1.ebuild
new file mode 100644
index 000000000000..57a618f8a877
--- /dev/null
+++ b/sys-libs/libsystem/libsystem-7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsystem/libsystem-7.1.ebuild,v 1.11 2005/07/30 18:37:03 kito Exp $
+
+DESCRIPTION="Darwin Libsystem, a collection of core libs similar to glibc on linux"
+
+HOMEPAGE="http://www.opensource.apple.com/darwinsource/"
+SRC_URI=""
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="-* ppc-macos"
+IUSE=""
+PROVIDE="virtual/libc"
+
+# I haven't listed any deps here, we're currently not building Darwin from scratch yet.
+# For now, this is a dummy package provided upstream. The version provided by the
+# distributor is pinpointed in the users profile. I am not going to be injecting this
+# because its the root of the dependency tree. I'm not comfortable with portage
+# having an injected, non-existant package as the root of its tree.
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ mkdir -p ${S}
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ true
+}
diff --git a/sys-libs/libsystem/libsystem-darwin-71.1.3.ebuild b/sys-libs/libsystem/libsystem-darwin-71.1.3.ebuild
deleted file mode 100644
index b219c3b12305..000000000000
--- a/sys-libs/libsystem/libsystem-darwin-71.1.3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header:
-
-inherit eutils
-
-DESCRIPTION="Darwin/OS X core system library"
-HOMEPAGE="http://darwinsource.opendarwin.org/"
-SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/Libsystem-${PV}.tar.gz"
-
-LICENSE="APSL-2"
-
-SLOT="0"
-KEYWORDS="~ppc-macos"
-IUSE="build"
-
-# sys-libs/libm-darwin
-
-DEPEND="sys-apps/bootstrap_cmds
- =sys-devel/gcc-apple-1*
- sys-libs/csu-darwin
- sys-libs/keymgr-darwin
- sys-libs/libc-darwin
- sys-libs/libinfo-darwin
- sys-libs/libkvm-darwin
- sys-libs/libnotify-darwin
- sys-libs/libstreams
- sys-libs/libwrappers-darwin
- sys-libs/unc-darwin"
-
-S=${WORKDIR}/Libsystem-${PV}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- #epatch ${FILESDIR}/Libc-Makefile.patch
- sed -i -e 's|/usr/local|${D}/usr|g' ${S}/Makefile.xbs
- sed -i -e 's|/usr/local|${D}/usr|g' ${S}/GNUmakefile
-}
-
-src_compile() {
-
- local BUILDTARGETS
- # just ppc for now, TODO ppc64 i{3,6}86
- # we need debug later on down the food chain TODO relieve this dep and IUSE=debug
- # in macos, .a does NOT imply static, build-${ARCH}-dynamic gives you libc.a so
- # that doesn't get built here but later when its rolled into libSystem
- BUILDTARGETS="build-ppc-static build-ppc-profile build-ppc-debug"
-
- mkdir -p ${S}/build/obj ${S}/build/sym
- gnumake \
- RC_OS=macos RC_ARCHS=ppc TARGETS=ppc \
- SRCROOT="${S}" OBJROOT="${S}"/build/obj \
- DSTROOT="${D}" SYMROOT="${S}"/build/sym \
- ${BUILDTARGETS} || die "make ${BUILDTARGETS} failed."
-
-}
-
-src_install() {
- BUILDTARGETS="installhdrs"
-
- use ! build && BUILDTARGETS="${BUILDTARGETS} install-man"
-
- cd ${S}
- gnumake \
- RC_OS=macos RC_ARCHS=ppc TARGETS=ppc \
- SRCROOT="${S}" OBJROOT="${S}"/build/obj \
- DSTROOT="${D}" SYMROOT="${S}"/build/sym \
- ${BUILDTARGETS} || die "build ${BUILDTARGETS} failed."
-
- into /usr/lib/system
- dolib.a ${S}/build/obj/obj.ppc/*.a
-
- insinto /usr/include
- doins ${S}/nls/FreeBSD/*.h
-
- use build && rm -rf ${D}/usr/share
- rm -rf ${D}/var
-}
-