summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-07-12 11:01:26 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-07-12 11:01:26 +0000
commit14d229a0ee1ad13e2f5ec3d2eff72455bb4c6cb4 (patch)
treeeecbb00463b8b34b08ab5c84b256566af66b4273
parentMarked ~x86-solaris (diff)
downloadgentoo-2-14d229a0ee1ad13e2f5ec3d2eff72455bb4c6cb4.tar.gz
gentoo-2-14d229a0ee1ad13e2f5ec3d2eff72455bb4c6cb4.tar.bz2
gentoo-2-14d229a0ee1ad13e2f5ec3d2eff72455bb4c6cb4.zip
Version bump.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
-rw-r--r--net-libs/telepathy-qt/ChangeLog8
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.2.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index 9dffbc8ae8bb..3804d9204e38 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-qt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.10 2012/07/02 18:11:44 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.11 2012/07/12 11:01:26 kensington Exp $
+
+*telepathy-qt-0.9.2 (12 Jul 2012)
+
+ 12 Jul 2012; Michael Palimaka <kensington@gentoo.org>
+ +telepathy-qt-0.9.2.ebuild:
+ Version bump.
02 Jul 2012; Johannes Huber <johu@gentoo.org> telepathy-qt-0.8.0.ebuild:
marked x86 per bug 421121
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.2.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.2.ebuild
new file mode 100644
index 000000000000..4912f00f8de3
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.2.ebuild,v 1.1 2012/07/12 11:01:26 kensington Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+inherit python base cmake-utils
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug farsight farstream test"
+
+RDEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ farsight? (
+ net-libs/telepathy-farsight
+ )
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.17.5
+ )
+ !net-libs/telepathy-qt4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-python/dbus-python
+ x11-libs/qt-test:4
+ )
+"
+
+REQUIRED_USE="farsight? ( !farstream )"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable farsight)
+ $(cmake-utils_use_enable farstream)
+ $(cmake-utils_use_enable debug DEBUG_OUTPUT)
+ $(cmake-utils_use_enable test TESTS)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake-utils_src_configure
+}