summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-03-12 19:12:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-03-12 19:12:43 +0000
commit1469cda066535826d8a6b9248705eab5dceaea12 (patch)
tree502e71f000915c474cf2e18282a192ec876e4592
parentarm stable, bug #405781 (diff)
downloadgentoo-2-1469cda066535826d8a6b9248705eab5dceaea12.tar.gz
gentoo-2-1469cda066535826d8a6b9248705eab5dceaea12.tar.bz2
gentoo-2-1469cda066535826d8a6b9248705eab5dceaea12.zip
build with newer gcc (bug #406471) with patch from Markus Rathgeb
(Portage version: 2.1.10.44/cvs/Linux i686)
-rw-r--r--games-emulation/fceux/ChangeLog8
-rw-r--r--games-emulation/fceux/fceux-2.1.5.ebuild8
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-gcc46.patch12
3 files changed, 23 insertions, 5 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index 10b9a91d835d..e337de54910b 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/fceux
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.14 2011/08/01 19:15:07 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.15 2012/03/12 19:12:43 mr_bones_ Exp $
+
+ 12 Mar 2012; Michael Sterrett <mr_bones_@gentoo.org> fceux-2.1.5.ebuild,
+ +files/fceux-2.1.5-gcc46.patch:
+ build with newer gcc (bug #406471) with patch from Markus Rathgeb
01 Aug 2011; Markus Meier <maekke@gentoo.org> fceux-2.1.5.ebuild:
amd64/x86 stable, bug #375715
diff --git a/games-emulation/fceux/fceux-2.1.5.ebuild b/games-emulation/fceux/fceux-2.1.5.ebuild
index 4d7d05b0a465..738d3b190d39 100644
--- a/games-emulation/fceux/fceux-2.1.5.ebuild
+++ b/games-emulation/fceux/fceux-2.1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.2 2011/08/01 19:15:07 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.3 2012/03/12 19:12:43 mr_bones_ Exp $
EAPI=2
inherit eutils scons-utils games
@@ -26,7 +26,9 @@ RDEPEND="lua? ( dev-lang/lua )
S=${WORKDIR}/fceu${PV}
src_prepare() {
- epatch "${FILESDIR}"/${P}-underlink.patch
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
# mentioned in bug #335836
if ! use lua ; then
sed -i -e '/_S9XLUA_H/d' SConstruct || die
diff --git a/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch b/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
new file mode 100644
index 000000000000..90dacf4bb4a8
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
@@ -0,0 +1,12 @@
+diff -Naur a/fceu2.1.5/src/file.cpp b/fceu2.1.5/src/file.cpp
+--- a/fceu2.1.5/src/file.cpp 2010-09-19 00:05:09.000000000 +0000
++++ b/fceu2.1.5/src/file.cpp 2012-03-01 19:21:25.856204727 +0000
+@@ -310,7 +310,7 @@
+ if(magic==0x088b1f) {
+ // maybe gzip...
+
+- void* gzfile = gzopen(fileToOpen.c_str(),"rb");
++ gzFile gzfile = gzopen(fileToOpen.c_str(),"rb");
+ if(gzfile) {
+ delete fp;
+