summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-17 13:59:13 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-17 13:59:13 +0000
commit143a94eecd9815abc044362382956abbc3af7afd (patch)
treee7a7da5275c485b6db3ebf42ba3f6b9c633c61b7
parentadd aspell dep (bug #205177) and use autotools eclass (diff)
downloadgentoo-2-143a94eecd9815abc044362382956abbc3af7afd.tar.gz
gentoo-2-143a94eecd9815abc044362382956abbc3af7afd.tar.bz2
gentoo-2-143a94eecd9815abc044362382956abbc3af7afd.zip
Switch from GTK+-1.2 depend to OpenMotif wrt #205511. Fix compilers warnings. Install desktop entry with icon.
(Portage version: 2.1.4)
-rw-r--r--net-ftp/axyftp/ChangeLog12
-rw-r--r--net-ftp/axyftp/axyftp-0.5.1-r1.ebuild40
-rw-r--r--net-ftp/axyftp/axyftp-0.5.1.ebuild23
-rw-r--r--net-ftp/axyftp/files/axyftp-0.5.1-built-in-function-exit.patch18
-rw-r--r--net-ftp/axyftp/files/digest-axyftp-0.5.1-r1 (renamed from net-ftp/axyftp/files/digest-axyftp-0.5.1)0
5 files changed, 68 insertions, 25 deletions
diff --git a/net-ftp/axyftp/ChangeLog b/net-ftp/axyftp/ChangeLog
index 6512086d20ce..08f7dfd5d978 100644
--- a/net-ftp/axyftp/ChangeLog
+++ b/net-ftp/axyftp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-ftp/axyftp
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/ChangeLog,v 1.6 2007/05/15 14:03:32 bangert Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/ChangeLog,v 1.7 2008/01/17 13:59:12 drac Exp $
+
+*axyftp-0.5.1-r1 (17 Jan 2008)
+
+ 17 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/axyftp-0.5.1-built-in-function-exit.patch, -axyftp-0.5.1.ebuild,
+ +axyftp-0.5.1-r1.ebuild:
+ Switch from GTK+-1.2 depend to OpenMotif wrt #205511. Fix compilers
+ warnings. Install desktop entry with icon.
15 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/net-ftp/axyftp/axyftp-0.5.1-r1.ebuild b/net-ftp/axyftp/axyftp-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..8a4b4a64938d
--- /dev/null
+++ b/net-ftp/axyftp/axyftp-0.5.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/axyftp-0.5.1-r1.ebuild,v 1.1 2008/01/17 13:59:12 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="GUI FTP client for X Window System (former WXftp)"
+HOMEPAGE="http://www.wxftp.seul.org"
+SRC_URI="http://www.wxftp.seul.org/download/${P}.tar.gz"
+
+LICENSE="Artistic LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/openmotif
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-built-in-function-exit.patch
+}
+
+src_compile(){
+ econf --with-help=/usr/share/doc/${PF}/html \
+ --with-gui=motif
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc CHANGES README TODO
+ newicon icons/${PN}-ball64.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "AxY FTP" ${PN} "Network;FileTransfer;Motif"
+}
diff --git a/net-ftp/axyftp/axyftp-0.5.1.ebuild b/net-ftp/axyftp/axyftp-0.5.1.ebuild
deleted file mode 100644
index 4b0ce39764e9..000000000000
--- a/net-ftp/axyftp/axyftp-0.5.1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/axyftp-0.5.1.ebuild,v 1.4 2005/02/03 11:36:36 dholm Exp $
-
-DESCRIPTION="GUI FTP client for X Window System (former WXftp)"
-SRC_URI="http://www.wxftp.seul.org/download/${P}.tar.gz"
-HOMEPAGE="http://www.wxftp.seul.org"
-
-LICENSE="Artistic LGPL-2.1"
-KEYWORDS="~x86 ~amd64 ~ppc"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=x11-libs/gtk+-1.2"
-
-src_compile(){
- econf || die "configure failed"
- emake -j1 || die "compilation failed"
-}
-
-src_install() {
- make install DESTDIR=${D}
-}
diff --git a/net-ftp/axyftp/files/axyftp-0.5.1-built-in-function-exit.patch b/net-ftp/axyftp/files/axyftp-0.5.1-built-in-function-exit.patch
new file mode 100644
index 000000000000..8937114251e3
--- /dev/null
+++ b/net-ftp/axyftp/files/axyftp-0.5.1-built-in-function-exit.patch
@@ -0,0 +1,18 @@
+diff -ur axyftp-0.5.1.orig/src/buttonbar.c axyftp-0.5.1/src/buttonbar.c
+--- axyftp-0.5.1.orig/src/buttonbar.c 2000-01-17 21:50:04.000000000 +0200
++++ axyftp-0.5.1/src/buttonbar.c 2008-01-17 15:46:22.000000000 +0200
+@@ -1,4 +1,5 @@
+ /* Copyright (c) 1998 Alexander Yukhimets. All rights reserved. */
++#include<stdlib.h>
+ #include"axyftp.h"
+ #include"utils.h"
+ #include"multi.h"
+diff -ur axyftp-0.5.1.orig/src/utils.c axyftp-0.5.1/src/utils.c
+--- axyftp-0.5.1.orig/src/utils.c 2000-01-17 22:03:59.000000000 +0200
++++ axyftp-0.5.1/src/utils.c 2008-01-17 15:45:51.000000000 +0200
+@@ -1,4 +1,5 @@
+ /* Copyright (c) 1998 Alexander Yukhimets. All rights reserved. */
++#include<stdlib.h>
+ #include<string.h>
+ #include<stdio.h>
+
diff --git a/net-ftp/axyftp/files/digest-axyftp-0.5.1 b/net-ftp/axyftp/files/digest-axyftp-0.5.1-r1
index 3fb36bf10ca3..3fb36bf10ca3 100644
--- a/net-ftp/axyftp/files/digest-axyftp-0.5.1
+++ b/net-ftp/axyftp/files/digest-axyftp-0.5.1-r1