summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-22 17:08:34 +0000
committerNed Ludd <solar@gentoo.org>2004-06-22 17:08:34 +0000
commit137cad4f099abb9c3fa10d8cd9835f2a98712fb3 (patch)
treeba1414ac90e9a4315ab72b32c557064b4ea87d32
parentForce emake -j1 and fix xemacs IUSE flag, closing bug #54706 (Manifest recommit) (diff)
downloadgentoo-2-137cad4f099abb9c3fa10d8cd9835f2a98712fb3.tar.gz
gentoo-2-137cad4f099abb9c3fa10d8cd9835f2a98712fb3.tar.bz2
gentoo-2-137cad4f099abb9c3fa10d8cd9835f2a98712fb3.zip
Fixed unary operator problem because LDFLAGS_PIE does not exist in most of the cases. Fixed overwrite of LDFLAGS=
-rw-r--r--sys-devel/patch/ChangeLog6
-rw-r--r--sys-devel/patch/Manifest8
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild11
3 files changed, 13 insertions, 12 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index b00a834fd783..31e737ad5ab1 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/patch
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.21 2004/05/08 14:24:04 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.22 2004/06/22 17:08:34 solar Exp $
+
+ 22 Jun 2004; <solar@gentoo.org> patch-2.5.9.ebuild:
+ Fixed unary operator problem because LDFLAGS_PIE does not exist in most of the
+ cases. Fixed overwrite of LDFLAGS=
08 May 2004; Danny van Dyk <kugelfang@gentoo.org> patch-2.5.9.ebuild:
Filtering "-pie" from LDFLAGS and appending manually to the Makefile for amd64.
diff --git a/sys-devel/patch/Manifest b/sys-devel/patch/Manifest
index 37d292ee1493..4c061d1059b6 100644
--- a/sys-devel/patch/Manifest
+++ b/sys-devel/patch/Manifest
@@ -1,6 +1,6 @@
-MD5 d0d5279fa38abc6ca22a675f5b34a5e6 ChangeLog 2788
+MD5 c00e2accd1e6569574a668f032cf9807 patch-2.5.9.ebuild 1461
+MD5 c85af77037c7025f2492be5a86e5caf7 patch-2.5.4-r5.ebuild 913
+MD5 9ea0db90a864b3089b081629d69f2cb7 ChangeLog 2787
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 113d8b76c54663b406b5ecb5c06244e6 patch-2.5.4-r5.ebuild 914
-MD5 73dbd03f7a2042ab5dbd29c7ad0d500c patch-2.5.9.ebuild 1482
-MD5 d8308835b63cc0644a67523856ef2df8 files/digest-patch-2.5.4-r5 63
MD5 7113f2413944cb06cecdd0c57ab54078 files/digest-patch-2.5.9 63
+MD5 d8308835b63cc0644a67523856ef2df8 files/digest-patch-2.5.4-r5 63
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index 6c0d70f427d5..729c6c129406 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.16 2004/05/08 14:24:04 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.17 2004/06/22 17:08:34 solar Exp $
inherit flag-o-matic
@@ -30,15 +30,12 @@ src_compile() {
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
# workaround for hardened on amd64, 2nd part
- if [ ${LDFLAGS_PIE} = "1" ]; then
+ if [ "${LDFLAGS_PIE}" = "1" ]; then
einfo "Patching Makefile..."
sed -i -e 's/^LDFLAGS =/& -pie/' Makefile || die "Patching Makefile failed!"
fi
- if ! use static ; then
- emake || die "emake failed"
- else
- emake LDFLAGS=-static || die "emake failed"
- fi
+ use static && append-ldflags -static
+ emake LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {