summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2011-04-07 12:02:49 +0000
committerLuca Barbato <lu_zero@gentoo.org>2011-04-07 12:02:49 +0000
commit1357885bb68aec081a64ffa8337730736031fee6 (patch)
tree8b56e1fe8125f5853f80c3e567a17f94bb9f4309
parent[bump] dev-perl/Test-Base-0.600.0 (diff)
downloadgentoo-2-1357885bb68aec081a64ffa8337730736031fee6.tar.gz
gentoo-2-1357885bb68aec081a64ffa8337730736031fee6.tar.bz2
gentoo-2-1357885bb68aec081a64ffa8337730736031fee6.zip
First release
(Portage version: 2.1.9.45/cvs/Linux x86_64)
-rw-r--r--media-libs/vo-amrwbenc/ChangeLog16
-rw-r--r--media-libs/vo-amrwbenc/metadata.xml12
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-0.1.0.ebuild46
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild46
4 files changed, 120 insertions, 0 deletions
diff --git a/media-libs/vo-amrwbenc/ChangeLog b/media-libs/vo-amrwbenc/ChangeLog
new file mode 100644
index 000000000000..3b1550d05de1
--- /dev/null
+++ b/media-libs/vo-amrwbenc/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for media-libs/vo-amrwbenc
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/ChangeLog,v 1.1 2011/04/07 12:02:49 lu_zero Exp $
+
+*vo-amrwbenc-0.1.0 (07 Apr 2011)
+
+ 07 Apr 2011; Luca Barbato <lu_zero@gentoo.org> +metadata.xml,
+ +vo-amrwbenc-0.1.0.ebuild, +vo-amrwbenc-9999.ebuild:
+ First release
+
+*vo-amrwbenc-9999 (29 Mar 2011)
+
+ 29 Mar 2011; Luca Barbato <lu_zero@gentoo.org> +metadata.xml,
+ +vo-amrwbenc-9999.ebuild:
+ Initial ebuild
+
diff --git a/media-libs/vo-amrwbenc/metadata.xml b/media-libs/vo-amrwbenc/metadata.xml
new file mode 100644
index 000000000000..facf40543011
--- /dev/null
+++ b/media-libs/vo-amrwbenc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+<longdescription lang="en">
+VisualOn AMR-WB encoder library
+This library contains an encoder implementation of the Adaptive Multi
+Rate Wideband (AMR-WB) audio codec. The library is based on a codec
+implementation by VisualOn, part of the Stagefright framework from
+the Google Android project.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.0.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.0.ebuild
new file mode 100644
index 000000000000..5d93f449e19c
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.0.ebuild,v 1.1 2011/04/07 12:02:49 lu_zero Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || KEYWORDS="~amd64 ~arm ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
new file mode 100644
index 000000000000..d1c192a18a67
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild,v 1.1 2011/04/07 12:02:49 lu_zero Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || KEYWORDS="~amd64 ~arm ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}