summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-02-21 03:29:14 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-02-21 03:29:14 +0000
commit122f0fe7705b1a52668b29fb1d999a0df9862936 (patch)
treefd2f0c2a874411ecc2fec7e01d003d783adb859c
parentVersion bump. (diff)
downloadgentoo-2-122f0fe7705b1a52668b29fb1d999a0df9862936.tar.gz
gentoo-2-122f0fe7705b1a52668b29fb1d999a0df9862936.tar.bz2
gentoo-2-122f0fe7705b1a52668b29fb1d999a0df9862936.zip
Update for man pages, working tests, and missing header file.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
-rw-r--r--sci-geosciences/gpsd/ChangeLog8
-rw-r--r--sci-geosciences/gpsd/gpsd-2.32.ebuild4
-rw-r--r--sci-geosciences/gpsd/gpsd-2.95-r1.ebuild (renamed from sci-geosciences/gpsd/gpsd-2.95.ebuild)36
3 files changed, 33 insertions, 15 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 124ca0abb24f..68f19f262260 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.57 2011/01/25 20:14:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.58 2011/02/21 03:29:14 nerdboy Exp $
+
+*gpsd-2.95-r1 (21 Feb 2011)
+
+ 21 Feb 2011; Steve Arnold <nerdboy@gentoo.org> -gpsd-2.95.ebuild,
+ +gpsd-2.95-r1.ebuild:
+ Update for man pages, working tests, and missing header file.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> gpsd-2.38.ebuild,
gpsd-2.39-r1.ebuild:
diff --git a/sci-geosciences/gpsd/gpsd-2.32.ebuild b/sci-geosciences/gpsd/gpsd-2.32.ebuild
index feb166ce6d89..21959d045c62 100644
--- a/sci-geosciences/gpsd/gpsd-2.32.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.12 2010/11/21 12:42:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.13 2011/02/21 03:29:14 nerdboy Exp $
EAPI=1
diff --git a/sci-geosciences/gpsd/gpsd-2.95.ebuild b/sci-geosciences/gpsd/gpsd-2.95-r1.ebuild
index dcf218b46900..97c7d2640467 100644
--- a/sci-geosciences/gpsd/gpsd-2.95.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.95-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.95.ebuild,v 1.4 2010/10/18 09:03:11 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.95-r1.ebuild,v 1.1 2011/02/21 03:29:14 nerdboy Exp $
EAPI=3
@@ -14,7 +14,7 @@ SRC_URI="mirror://berlios/gpsd/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
GPSD_PROTOCOLS="ashtech aivdm clientdebug earthmate evermore fv18 garmin
garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
@@ -23,6 +23,7 @@ GPSD_PROTOCOLS="ashtech aivdm clientdebug earthmate evermore fv18 garmin
for protocol in ${GPSD_PROTOCOLS}; do
IUSE_GPSD_PROTOCOLS+=" gpsd_protocols_${protocol}"
done
+
IUSE="${IUSE_GPSD_PROTOCOLS} dbus ipv6 ntp qt4"
# those harddeps are de-facto automagicall
@@ -35,9 +36,10 @@ RDEPEND="
dev-libs/dbus-glib
)
ntp? ( net-misc/ntp )
- qt4? ( x11-libs/qt-gui )
-"
-DEPEND="${RDEPEND}"
+ qt4? ( x11-libs/qt-gui )"
+
+DEPEND="${RDEPEND}
+ app-text/xmlto"
PATCHES=(
"${FILESDIR}/${PV}-disable-strip.patch"
@@ -64,21 +66,25 @@ src_configure() {
myopts+=" $(use_enable gpsd_protocols_${protocol} ${protocol})"
done
+ if ! use qt4 ; then
+ myopts+=" --disable-libQgpsmm --disable-libgpsmm ${myopts}"
+ fi
+
# --disable-bluetooth: considered experimental -> disable
- # hack to make it not generate docs on the fly
- WITH_XSLTPROC=no WITH_XMLTO=no \
- econf \
+ # --enable-static is required for tests, see bug 355071
+ # Hack to make it not generate docs on the fly; xmlto is
+ # needed for man pages (xsltproc is only needed for web pages)
+ econf WITH_XMLTO=yes WITH_XSLTPROC=no \
+ --build=${CBUILD} \
--disable-dependency-tracking \
--disable-bluetooth \
- --disable-static \
- --enable-libgpsmm \
+ --enable-static \
--enable-gpsd-user=gpsd \
--enable-gpsd-group=uucp \
$(use_enable dbus) \
$(use_enable ipv6) \
$(use_enable ntp ntpshm) \
$(use_enable ntp pps) \
- $(use_enable qt4 libQgpsmm) \
${myopts}
}
@@ -86,6 +92,12 @@ src_install() {
# no it can't be done using emake cause it is non-compliant
make DESTDIR="${D}" install || die
+ # needs this header for libQgpsmm
+ if use qt4 ; then
+ insinto /usr/include
+ doins libQgpsmm/libQgpsmm_global.h
+ fi
+
# no need for .la files here
find "${D}" -type f -name '*.la' -exec rm -f '{}' +