summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-09-06 03:10:41 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-09-06 03:10:41 +0000
commit11e8231384e455532eb31fe5feba7faca217cce1 (patch)
tree0485f9ef0043d7a01acda14ecb1ffc0c80365707
parentnew version and a patch to make it adhere to sandbox with DESTDIR and python (diff)
downloadgentoo-2-11e8231384e455532eb31fe5feba7faca217cce1.tar.gz
gentoo-2-11e8231384e455532eb31fe5feba7faca217cce1.tar.bz2
gentoo-2-11e8231384e455532eb31fe5feba7faca217cce1.zip
new version and a patch to make it adhere to DESTDIR with python
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/Makefile-py.patch18
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.4.241
-rw-r--r--dev-libs/libxml2/libxml2-2.4.24.ebuild41
4 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index c510702f92bc..e316545756d2 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.11 2002/08/02 03:24:39 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.12 2002/09/06 03:10:41 spider Exp $
+
+*libxml2-2.4.24 (06 Sep 2002)
+ 06 Sep 2002; Spider <spider@gentoo.org> libxml2-2.4.24.ebuild :
+ new verison, patched up python/Makefile to make it adhere to DESTDIR
+
*libxml2-2.4.23 (07 Jul 2002)
01 Aug 2002; Mark Guertin <gerk@gentoo.org> libxml2-2.4.23.ebuild :
Added ppc to keywords
diff --git a/dev-libs/libxml2/files/Makefile-py.patch b/dev-libs/libxml2/files/Makefile-py.patch
new file mode 100644
index 000000000000..67c8b6b0fb8d
--- /dev/null
+++ b/dev-libs/libxml2/files/Makefile-py.patch
@@ -0,0 +1,18 @@
+--- python/Makefile.old Fri Sep 6 04:39:34 2002
++++ python/Makefile Fri Sep 6 04:40:57 2002
+@@ -538,11 +538,11 @@
+ cat $(srcdir)/libxml.py libxml2class.py > libxml2.py
+
+ install-data-local:
+- $(mkinstalldirs) $(libdir)/python${PYTHON_VERSION}/site-packages
+- /bin/install -c -m 0644 libxml2.py $(libdir)/python${PYTHON_VERSION}/site-packages
+- $(mkinstalldirs) $(DOCS_DIR)
++ $(mkinstalldirs) $(DESTDIR)/$(libdir)/python${PYTHON_VERSION}/site-packages
++ /bin/install -c -m 0644 libxml2.py $(DESTDIR)/$(libdir)/python${PYTHON_VERSION}/site-packages
++ $(mkinstalldirs) $(DESTDIR)/$(DOCS_DIR)
+ @(for doc in $(DOCS) ; \
+- do /bin/install -c -m 0644 $$doc $(DOCS_DIR) ; done)
++ do /bin/install -c -m 0644 $$doc $(DESTDIR)/$(DOCS_DIR) ; done)
+
+ $(GENERATED): gen_prog
+
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.4.24 b/dev-libs/libxml2/files/digest-libxml2-2.4.24
new file mode 100644
index 000000000000..9d2385b1c098
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.4.24
@@ -0,0 +1 @@
+MD5 b2dc5525fd6e49d36b90f1e07bac3f34 libxml2-2.4.24.tar.bz2 1562484
diff --git a/dev-libs/libxml2/libxml2-2.4.24.ebuild b/dev-libs/libxml2/libxml2-2.4.24.ebuild
new file mode 100644
index 000000000000..9d5d9363c6b8
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.4.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.24.ebuild,v 1.1 2002/09/06 03:10:41 spider Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+SRC_URI="mirror://gnome/2.0.1/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ >=sys-libs/zlib-1.1.4"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="x86"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ econf --with-zlib || die
+ patch -p0 < ${FILESDIR}/Makefile-py.patch || die "no, patch failed"
+ make || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}