summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2006-12-03 10:26:02 +0000
committerHans de Graaff <graaff@gentoo.org>2006-12-03 10:26:02 +0000
commit11379e78c480d735d677cff4de94637c0057a3f7 (patch)
tree2f94c963ca0429ca8e1e688c02f1ec6cd6de0227
parentAdded a revision that compiles with 2.6.19. Fixes bug #156838. Thanks to Dani... (diff)
downloadgentoo-2-11379e78c480d735d677cff4de94637c0057a3f7.tar.gz
gentoo-2-11379e78c480d735d677cff4de94637c0057a3f7.tar.bz2
gentoo-2-11379e78c480d735d677cff4de94637c0057a3f7.zip
Version bump. Remove some old versions.
(Portage version: 2.1.1-r2)
-rw-r--r--dev-ruby/rmagick/ChangeLog9
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.14.13
-rw-r--r--dev-ruby/rmagick/rmagick-1.14.1.ebuild35
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 4e0fa58f9cd7..38959763675c 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.28 2006/10/20 21:19:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.29 2006/12/03 10:26:01 graaff Exp $
+
+*rmagick-1.14.1 (03 Dec 2006)
+
+ 03 Dec 2006; Hans de Graaff <graaff@gentoo.org> -rmagick-1.9.2.ebuild,
+ -rmagick-1.9.3.ebuild, +rmagick-1.14.1.ebuild:
+ Add new version, fixing #155646. Remove old versions as much as possible
+ without affecting arches.
20 Oct 2006; Aron Griffis <agriffis@gentoo.org> rmagick-1.9.3-r1.ebuild:
Mark 1.9.3-r1 stable on ia64
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.14.1 b/dev-ruby/rmagick/files/digest-rmagick-1.14.1
new file mode 100644
index 000000000000..223578db542d
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.14.1
@@ -0,0 +1,3 @@
+MD5 7e92ac388252a7c5de817ce19af94d8d RMagick-1.14.1.tar.bz2 953136
+RMD160 7c739e969b39d33c02103c22aea2a721b56d0269 RMagick-1.14.1.tar.bz2 953136
+SHA256 a8bbfdd398a700fec780525e3720b0d61e48f3a645684100e407e7d15b74a443 RMagick-1.14.1.tar.bz2 953136
diff --git a/dev-ruby/rmagick/rmagick-1.14.1.ebuild b/dev-ruby/rmagick/rmagick-1.14.1.ebuild
new file mode 100644
index 000000000000..7b94b8b78de3
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.14.1.ebuild,v 1.1 2006/12/03 10:26:01 graaff Exp $
+
+inherit ruby
+
+#
+# The gem for this package doesn't seem to play well with portage. It runs a GNUish configure script, with argument
+# passed directly from the gem install command, but gem install doesn't use the same style of arguments. Thus, unless
+# you're smart enough to come up with a fix, please leave this as a source package install.
+#
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/14052/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix=${D} "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+}