summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-04-23 01:40:11 +0000
committerJoshua Brindle <method@gentoo.org>2003-04-23 01:40:11 +0000
commit1131dd742246669a3a404e2d490c4a2e98897060 (patch)
treebc4847ea1805912a7a624aac4f6fd44fe4b601b3
parentKV fix (diff)
downloadgentoo-2-1131dd742246669a3a404e2d490c4a2e98897060.tar.gz
gentoo-2-1131dd742246669a3a404e2d490c4a2e98897060.tar.bz2
gentoo-2-1131dd742246669a3a404e2d490c4a2e98897060.zip
added conf.d and init.d files
-rw-r--r--net-misc/zebra/ChangeLog6
-rw-r--r--net-misc/zebra/Manifest6
-rw-r--r--net-misc/zebra/files/zebra.confd16
-rw-r--r--net-misc/zebra/files/zebra.initd19
-rw-r--r--net-misc/zebra/zebra-0.93a.ebuild18
5 files changed, 56 insertions, 9 deletions
diff --git a/net-misc/zebra/ChangeLog b/net-misc/zebra/ChangeLog
index 817660933d8a..496083e935a7 100644
--- a/net-misc/zebra/ChangeLog
+++ b/net-misc/zebra/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-misc/zebra
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zebra/ChangeLog,v 1.1 2003/04/22 21:38:47 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zebra/ChangeLog,v 1.2 2003/04/23 01:40:08 method Exp $
*zebra-0.93a (22 Apr 2003)
+ 22 Apr 2003; Joshua Brindle <method@gentoo.org> zebra-0.93a.ebuild,
+ files/zebra.confd files/zebra.initd:
+ added init.d and conf.d files
+
22 Apr 2003; Joshua Brindle <method@gentoo.org> zebra-0.93a.ebuild:
Initial commit courtesy of solarx <solar@linbsd.net>
diff --git a/net-misc/zebra/Manifest b/net-misc/zebra/Manifest
index 8af47e95c26b..028f0c7074dc 100644
--- a/net-misc/zebra/Manifest
+++ b/net-misc/zebra/Manifest
@@ -1,3 +1,5 @@
-MD5 d59587822472f352dab686208193910a zebra-0.93a.ebuild 1072
-MD5 93cdd55ed10bf4fa008ee155de77c232 ChangeLog 364
+MD5 122a878efde20a1fc40817371a0146ad zebra-0.93a.ebuild 1317
+MD5 1b7eab649f0b4dbfc98a5dfa56a9a60b ChangeLog 506
MD5 1aea49f1bd903cd18e3a3ff2292c2639 files/digest-zebra-0.93a 64
+MD5 5cc027d5ee8a3a1564d0e21423461b49 files/zebra.confd 638
+MD5 3892c41d7ffc5ea4049987524758b908 files/zebra.initd 383
diff --git a/net-misc/zebra/files/zebra.confd b/net-misc/zebra/files/zebra.confd
new file mode 100644
index 000000000000..31ecfb9593ce
--- /dev/null
+++ b/net-misc/zebra/files/zebra.confd
@@ -0,0 +1,16 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+# Config file for /etc/init.d/zebra
+
+# -b, --batch Runs in batch mode
+# -d, --daemon Runs in daemon mode
+# -f, --config_file Set configuration file name
+# -i, --pid_file Set process identifier file name
+# -k, --keep_kernel Don't delete old routes which installed by zebra.
+# -l, --log_mode Set verbose log mode flag
+# -A, --vty_addr Set vty's bind address
+# -P, --vty_port Set vty's port number
+# -r, --retain When program terminates, retain added route by zebra.
+
+OPTS="-d"
diff --git a/net-misc/zebra/files/zebra.initd b/net-misc/zebra/files/zebra.initd
new file mode 100644
index 000000000000..3a314d9cb523
--- /dev/null
+++ b/net-misc/zebra/files/zebra.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting zebra"
+ start-stop-daemon --start --quiet --exec /usr/sbin/zebra -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping zebra"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/zebra
+ eend $?
+}
diff --git a/net-misc/zebra/zebra-0.93a.ebuild b/net-misc/zebra/zebra-0.93a.ebuild
index 0eecad04e396..ab710e3ef4e1 100644
--- a/net-misc/zebra/zebra-0.93a.ebuild
+++ b/net-misc/zebra/zebra-0.93a.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header:
S=${WORKDIR}/${P}
+IUSE="pam snmp ipv6"
DESCRIPTION="Multithreaded TCP/IP Routing Software that supports BGP-4, RIPv1, RIPv2 and OSPFv2"
SRC_URI="ftp://ftp.zebra.org/pub/zebra/${P}.tar.gz"
@@ -11,17 +11,19 @@ KEYWORDS="~x86"
LICENSE="GPL-2"
SLOT="0"
-DEPEND="virtual/glibc"
+DEPEND="virtual/glibc
+ pam? ( >=pam-0.75-r11 )"
src_compile() {
local myconf=""
- use snmp || myconf="$myconf --without-snmp"
+ use pam || myconf="$myconf --disable-pam"
+ use snmp || myconf="$myconf --disable-snmp"
use ipv6 || myconf="$myconf --disable-ipv6"
./configure \
--host=${CHOST} \
--prefix=/usr \
- --sysconfdir=/etc \
+ --sysconfdir=/etc/zebra \
--localstatedir=/var \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
@@ -31,14 +33,18 @@ src_compile() {
}
src_install() {
-
make \
prefix=${D}/usr \
- sysconfdir=${D}/etc \
+ sysconfdir=${D}/etc/zebra \
localstatedir=${D}/var \
infodir=${D}/usr/share/info \
mandir=${D}/usr/share/man \
install || die "Installation Failed"
+
+ cp */*.conf.sample ${D}/etc/zebra
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/zebra.initd zebra
+ insinto /etc/conf.d ; newins ${FILESDIR}/zebra.confd zebra
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README REPORTING-BUGS SERVICES TODO
}