summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-11-14 15:55:10 +0000
committerAron Griffis <agriffis@gentoo.org>2001-11-14 15:55:10 +0000
commit1076de614bbba45e2c47b48a384314b7c38c1090 (patch)
treef2f72a56056106f95055d3e2691bccb53c5d5461
parentadded ebuild from Luke Graham (diff)
downloadgentoo-2-1076de614bbba45e2c47b48a384314b7c38c1090.tar.gz
gentoo-2-1076de614bbba45e2c47b48a384314b7c38c1090.tar.bz2
gentoo-2-1076de614bbba45e2c47b48a384314b7c38c1090.zip
Updated MPEG Audio Decoder used by mpg321
-rw-r--r--media-sound/mad/files/digest-mad-0.14.2b1
-rw-r--r--media-sound/mad/mad-0.14.2b.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/mad/files/digest-mad-0.14.2b b/media-sound/mad/files/digest-mad-0.14.2b
new file mode 100644
index 000000000000..21aa903257c2
--- /dev/null
+++ b/media-sound/mad/files/digest-mad-0.14.2b
@@ -0,0 +1 @@
+MD5 eb3bfbe634ba9d5b4928aa11e0f6819d mad-0.14.2b.tar.gz 729088
diff --git a/media-sound/mad/mad-0.14.2b.ebuild b/media-sound/mad/mad-0.14.2b.ebuild
new file mode 100644
index 000000000000..116880ce3f70
--- /dev/null
+++ b/media-sound/mad/mad-0.14.2b.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/mad-0.14.2b.ebuild,v 1.1 2001/11/14 15:55:10 agriffis Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+HOMEPAGE="http://mad.sourceforge.net/"
+DESCRIPTION="A high-quality MP3 decoder"
+
+DEPEND="sys-devel/gcc virtual/glibc sys-devel/ld.so"
+RDEPEND="virtual/glibc sys-devel/ld.so"
+
+src_compile() {
+ confopts="--infodir=/usr/share/info --mandir=/usr/share/man \
+ --prefix=/usr --host=${CHOST} --enable-static \
+ --disable-debugging --enable-shared --enable-fpm=intel"
+ ./configure ${confopts} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}