summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-30 07:06:52 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-30 07:06:52 +0000
commit0f85e03de9137b98123a0af073125939a19443d4 (patch)
tree7de1b69bce7f803e5f6318463974a1489ce115c1
parentVersion bump. (diff)
downloadgentoo-2-0f85e03de9137b98123a0af073125939a19443d4.tar.gz
gentoo-2-0f85e03de9137b98123a0af073125939a19443d4.tar.bz2
gentoo-2-0f85e03de9137b98123a0af073125939a19443d4.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/polyglot/ChangeLog7
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.5.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/polyglot/ChangeLog b/dev-ruby/polyglot/ChangeLog
index 6bfcf6ebaa5b..bdd912b3055a 100644
--- a/dev-ruby/polyglot/ChangeLog
+++ b/dev-ruby/polyglot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/polyglot
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.29 2014/05/21 01:46:55 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.30 2014/05/30 07:06:52 graaff Exp $
+
+*polyglot-0.3.5 (30 May 2014)
+
+ 30 May 2014; Hans de Graaff <graaff@gentoo.org> +polyglot-0.3.5.ebuild:
+ Version bump.
21 May 2014; Manuel Rüger <mrueg@gentoo.org> -polyglot-0.3.3-r1.ebuild,
polyglot-0.3.4.ebuild:
diff --git a/dev-ruby/polyglot/polyglot-0.3.5.ebuild b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
new file mode 100644
index 000000000000..d843121768f7
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.3.5.ebuild,v 1.1 2014/05/30 07:06:51 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby rbx"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs"
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ # jruby has trouble parsing this metadata and there are no dependencies.
+ rm ../metadata || die
+}