summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2012-12-18 15:40:27 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2012-12-18 15:40:27 +0000
commit0e8c70329bfa979b057a78b0d0362896f55ce8b0 (patch)
tree6486925c7c2ad7e8a3a6f0a132bc8401bf841259
parentAlso respect prefix in latest patch. (diff)
downloadgentoo-2-0e8c70329bfa979b057a78b0d0362896f55ce8b0.tar.gz
gentoo-2-0e8c70329bfa979b057a78b0d0362896f55ce8b0.tar.bz2
gentoo-2-0e8c70329bfa979b057a78b0d0362896f55ce8b0.zip
Version bump. Drop old version.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
-rw-r--r--dev-python/larch/ChangeLog8
-rw-r--r--dev-python/larch/larch-1.20121216.ebuild (renamed from dev-python/larch/larch-1.20120527.ebuild)18
2 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/larch/ChangeLog b/dev-python/larch/ChangeLog
index fc33a9bf1200..b886a7f89216 100644
--- a/dev-python/larch/ChangeLog
+++ b/dev-python/larch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/larch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/larch/ChangeLog,v 1.3 2012/10/07 00:40:09 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/larch/ChangeLog,v 1.4 2012/12/18 15:40:27 mschiff Exp $
+
+*larch-1.20121216 (18 Dec 2012)
+
+ 18 Dec 2012; Marc Schiffbauer <mschiff@gentoo.org> -larch-1.20120527.ebuild,
+ +larch-1.20121216.ebuild:
+ Version bump. Drop old version.
*larch-1.20121006-r1 (07 Oct 2012)
diff --git a/dev-python/larch/larch-1.20120527.ebuild b/dev-python/larch/larch-1.20121216.ebuild
index abbd289b3668..99866e202cc8 100644
--- a/dev-python/larch/larch-1.20120527.ebuild
+++ b/dev-python/larch/larch-1.20121216.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/larch/larch-1.20120527.ebuild,v 1.1 2012/06/15 10:17:07 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/larch/larch-1.20121216.ebuild,v 1.1 2012/12/18 15:40:27 mschiff Exp $
EAPI=4
@@ -11,19 +11,27 @@ inherit distutils python
DESCRIPTION="Copy-on-write B-tree data structure"
HOMEPAGE="http://liw.fi/larch/"
SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
-RESTRICT="test"
+#RESTRICT="test"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/cliapp
+DEPEND="test? ( dev-python/CoverageTestRunner dev-util/cmdtest )"
+
+RDEPEND="dev-python/cliapp
dev-python/tracing
dev-python/ttystatus"
-RDEPEND="${DEPEND}"
pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
+
+src_test() {
+ # remove build directory so tests will not fail
+ # due to tests defined twice
+ rm -rf "${S}"/build
+ default
+}