summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-27 22:00:24 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-27 22:00:24 +0000
commit0e584135ecb0a9b58045c27c85d85a8d91b1db41 (patch)
tree20d270b4705543df8575b0220b3fbe17469c0e83
parentBugfix version bump, adds a trivial one-line change to fix compilation agains... (diff)
downloadgentoo-2-0e584135ecb0a9b58045c27c85d85a8d91b1db41.tar.gz
gentoo-2-0e584135ecb0a9b58045c27c85d85a8d91b1db41.tar.bz2
gentoo-2-0e584135ecb0a9b58045c27c85d85a8d91b1db41.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
-rw-r--r--kde-misc/akonadi-google/ChangeLog7
-rw-r--r--kde-misc/akonadi-google/akonadi-google-0.3.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-misc/akonadi-google/ChangeLog b/kde-misc/akonadi-google/ChangeLog
index c6b776b16b1a..da9fcb3c159d 100644
--- a/kde-misc/akonadi-google/ChangeLog
+++ b/kde-misc/akonadi-google/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/akonadi-google
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/akonadi-google/ChangeLog,v 1.9 2012/04/02 08:21:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/akonadi-google/ChangeLog,v 1.10 2012/04/27 22:00:24 johu Exp $
+
+*akonadi-google-0.3.1 (27 Apr 2012)
+
+ 27 Apr 2012; Johannes Huber <johu@gentoo.org> +akonadi-google-0.3.1.ebuild:
+ Version bump.
*akonadi-google-0.3 (02 Apr 2012)
diff --git a/kde-misc/akonadi-google/akonadi-google-0.3.1.ebuild b/kde-misc/akonadi-google/akonadi-google-0.3.1.ebuild
new file mode 100644
index 000000000000..f8494208e238
--- /dev/null
+++ b/kde-misc/akonadi-google/akonadi-google-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/akonadi-google/akonadi-google-0.3.1.ebuild,v 1.1 2012/04/27 22:00:24 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+EGIT_REPONAME="akonadi-google"
+inherit kde4-base
+
+DESCRIPTION="Google services integration in Akonadi"
+HOMEPAGE="https://projects.kde.org/projects/playground/pim/akonadi-google"
+SRC_URI="http://www.progdan.cz/wp-content/uploads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="oldpim"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs semantic-desktop)
+ dev-libs/libxslt
+ dev-libs/qjson
+ oldpim? ( dev-libs/boost )
+ !oldpim? ( $(add_kdebase_dep kdepimlibs semantic-desktop 4.6.0) )
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use oldpim KCAL)
+ )
+ kde4-base_src_configure
+}