summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-15 18:18:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-15 18:18:25 +0000
commit0d78fb0a10c6d3cd275a77c90624e10cf1b8e7d3 (patch)
tree15c87749bdb157ae5bfd19560367431612f08726
parentStable for AMD64/X86, wrt security bug #408367 (diff)
downloadgentoo-2-0d78fb0a10c6d3cd275a77c90624e10cf1b8e7d3.tar.gz
gentoo-2-0d78fb0a10c6d3cd275a77c90624e10cf1b8e7d3.tar.bz2
gentoo-2-0d78fb0a10c6d3cd275a77c90624e10cf1b8e7d3.zip
Install static libraries only if desired and remove libtool archive as we have pc file.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
-rw-r--r--media-libs/ftgl/ChangeLog8
-rw-r--r--media-libs/ftgl/ftgl-2.1.3_rc5.ebuild21
2 files changed, 19 insertions, 10 deletions
diff --git a/media-libs/ftgl/ChangeLog b/media-libs/ftgl/ChangeLog
index d112fc3bd167..2a779a2e40d8 100644
--- a/media-libs/ftgl/ChangeLog
+++ b/media-libs/ftgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/ftgl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ChangeLog,v 1.35 2011/05/20 09:24:18 tupone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ChangeLog,v 1.36 2012/03/15 18:18:25 scarabeus Exp $
+
+ 15 Mar 2012; Tomáš Chvátal <scarabeus@gentoo.org> ftgl-2.1.3_rc5.ebuild:
+ Install static libraries only if desired and remove libtool archive as we have
+ pc file.
20 May 2011; Tupone Alfredo <tupone@gentoo.org> ftgl-2.1.3_rc5.ebuild,
+files/ftgl-2.1.3_rc5-underlink.patch:
diff --git a/media-libs/ftgl/ftgl-2.1.3_rc5.ebuild b/media-libs/ftgl/ftgl-2.1.3_rc5.ebuild
index 8c1e6af5f126..18b126ba9ee7 100644
--- a/media-libs/ftgl/ftgl-2.1.3_rc5.ebuild
+++ b/media-libs/ftgl/ftgl-2.1.3_rc5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ftgl-2.1.3_rc5.ebuild,v 1.15 2011/05/20 09:24:18 tupone Exp $
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ftgl-2.1.3_rc5.ebuild,v 1.16 2012/03/15 18:18:25 scarabeus Exp $
+
+EAPI=4
inherit eutils flag-o-matic autotools
@@ -17,15 +18,18 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE=""
+IUSE="static-libs"
DEPEND=">=media-libs/freetype-2.0.9
virtual/opengl
virtual/glu
media-libs/freeglut"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P2}
+DOCS="AUTHORS BUGS ChangeLog INSTALL NEWS README TODO docs/projects_using_ftgl.txt"
+
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-underlink.patch
@@ -35,12 +39,13 @@ src_prepare() {
src_configure() {
strip-flags # ftgl is sensitive - bug #112820
- econf
+ econf \
+ $(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
rm -rf "${D}"/usr/share/doc/ftgl
- dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO \
- docs/projects_using_ftgl.txt
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
}