summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-22 17:32:58 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-22 17:32:58 +0000
commit0c4c0017a55a5d88429c4d91bd13a54a1048c73e (patch)
tree14cb54eba0f84de9dd891cc40c12547a704bf2cb
parentVersion bump, remove old (#398443 by b1254633). (diff)
downloadgentoo-2-0c4c0017a55a5d88429c4d91bd13a54a1048c73e.tar.gz
gentoo-2-0c4c0017a55a5d88429c4d91bd13a54a1048c73e.tar.bz2
gentoo-2-0c4c0017a55a5d88429c4d91bd13a54a1048c73e.zip
Fix underlinking, bug #410175 by Alec Meyers.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--dev-util/bam/ChangeLog7
-rw-r--r--dev-util/bam/bam-0.4.0.ebuild13
-rw-r--r--dev-util/bam/files/0.4.0/Makefile2
3 files changed, 11 insertions, 11 deletions
diff --git a/dev-util/bam/ChangeLog b/dev-util/bam/ChangeLog
index f6e5711fba78..16ca67114283 100644
--- a/dev-util/bam/ChangeLog
+++ b/dev-util/bam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/bam
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bam/ChangeLog,v 1.8 2012/06/16 07:44:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bam/ChangeLog,v 1.9 2012/07/22 17:32:58 pacho Exp $
+
+ 22 Jul 2012; Pacho Ramos <pacho@gentoo.org> bam-0.4.0.ebuild,
+ files/0.4.0/Makefile:
+ Fix underlinking, bug #410175 by Alec Meyers.
16 Jun 2012; Pacho Ramos <pacho@gentoo.org> -bam-0.2.0.ebuild, metadata.xml:
Drop maintainer as he is not able to maintain this anymore, drop old.
@@ -34,4 +38,3 @@
24 Mar 2010; Mounir Lamouri <volkmar@gentoo.org> +bam-0.2.0.ebuild,
+metadata.xml:
Initial commit. Package required for teeworlds, bug 206287
-
diff --git a/dev-util/bam/bam-0.4.0.ebuild b/dev-util/bam/bam-0.4.0.ebuild
index cb8162f68236..b22644bf3f16 100644
--- a/dev-util/bam/bam-0.4.0.ebuild
+++ b/dev-util/bam/bam-0.4.0.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bam/bam-0.4.0.ebuild,v 1.4 2012/05/21 12:23:12 phajdan.jr Exp $
-
-EAPI=3
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bam/bam-0.4.0.ebuild,v 1.5 2012/07/22 17:32:58 pacho Exp $
+EAPI=4
PYTHON_DEPEND="2"
inherit eutils python toolchain-funcs
@@ -35,17 +34,15 @@ src_prepare() {
}
src_compile() {
- emake ${PN} || die
-
+ emake ${PN}
if use doc; then
$(PYTHON) scripts/gendocs.py || die "doc generation failed"
fi
}
src_install() {
- dobin ${PN} || die
-
+ dobin ${PN}
if use doc; then
- dohtml docs/${PN}{.html,_logo.png} || die "dohtml failed"
+ dohtml docs/${PN}{.html,_logo.png}
fi
}
diff --git a/dev-util/bam/files/0.4.0/Makefile b/dev-util/bam/files/0.4.0/Makefile
index 27f35b40e87b..d64f43abcd11 100644
--- a/dev-util/bam/files/0.4.0/Makefile
+++ b/dev-util/bam/files/0.4.0/Makefile
@@ -1,4 +1,4 @@
-LIBS += -lm -lpthread -llua
+LIBS += -lm -lpthread -llua -ldl
TARGETS = txt2c internal_base bam
BAM_OBJ = $(patsubst %.c,%.o,$(wildcard src/*.c))
TXT2C_LUA = $(wildcard src/*.lua)