summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2011-02-01 21:44:39 +0000
committerJustin Bronder <jsbronder@gentoo.org>2011-02-01 21:44:39 +0000
commit0c339e1cf06e5285c4e85cc504e38dfd693f69b1 (patch)
tree7bbc01a20a6df3084895f7200e9863f550338146
parentStable for HPPA (bug #353352). (diff)
downloadgentoo-2-0c339e1cf06e5285c4e85cc504e38dfd693f69b1.tar.gz
gentoo-2-0c339e1cf06e5285c4e85cc504e38dfd693f69b1.tar.bz2
gentoo-2-0c339e1cf06e5285c4e85cc504e38dfd693f69b1.zip
Bump EAPI thanks to scarabeus.
(Portage version: 2.1.9.33/cvs/Linux x86_64)
-rw-r--r--sys-cluster/hpl/ChangeLog5
-rw-r--r--sys-cluster/hpl/hpl-2.0-r1.ebuild23
2 files changed, 15 insertions, 13 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index 5a69cd594ae9..4e252477a536 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/hpl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.17 2011/02/01 18:27:08 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.18 2011/02/01 21:44:39 jsbronder Exp $
+
+ 01 Feb 2011; Justin Bronder <jsbronder@gentoo.org> hpl-2.0-r1.ebuild:
+ Bump EAPI thanks to scarabeus.
*hpl-2.0-r1 (01 Feb 2011)
diff --git a/sys-cluster/hpl/hpl-2.0-r1.ebuild b/sys-cluster/hpl/hpl-2.0-r1.ebuild
index 74b4e88f8f2c..315555ab3cc3 100644
--- a/sys-cluster/hpl/hpl-2.0-r1.ebuild
+++ b/sys-cluster/hpl/hpl-2.0-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r1.ebuild,v 1.1 2011/02/01 18:27:08 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r1.ebuild,v 1.2 2011/02/01 21:44:39 jsbronder Exp $
+EAPI=4
inherit eutils
DESCRIPTION="A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
@@ -17,9 +18,7 @@ DEPEND="virtual/mpi
virtual/lapack"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86
sed -i \
-e "/^TOPdir/s,= .*,= ${S}," \
@@ -31,22 +30,22 @@ src_unpack() {
-e '/^LINKER\>/s,= .*,= mpicc,' \
-e '/^CC\>/s,= .*,= mpicc,' \
-e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS}|" \
- Make.gentoo_hpl_fblas_x86
+ Make.gentoo_hpl_fblas_x86 || die
}
src_compile() {
- # parallel make failure — bug #321539
- HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86 || die "Failed to build"
+ # parallel make failure — bug #321539
+ HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86
}
src_install() {
- dobin bin/gentoo_hpl_fblas_x86/xhpl || die
- dolib lib/gentoo_hpl_fblas_x86/libhpl.a || die
+ dobin bin/gentoo_hpl_fblas_x86/xhpl
+ dolib lib/gentoo_hpl_fblas_x86/libhpl.a
dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING \
- bin/gentoo_hpl_fblas_x86/HPL.dat || die
- doman man/man3/*.3 || die
+ bin/gentoo_hpl_fblas_x86/HPL.dat
+ doman man/man3/*.3
if use doc; then
- dohtml -r www/* || die
+ dohtml -r www/*
fi
}