summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-16 09:18:26 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-16 09:18:26 +0000
commit0c2651e368a9f0e932d694dafffca41006a47cdd (patch)
tree0086718ba4eb0dde58670f5f17793548826c46ee
parentstable x86, bug 213465 (diff)
downloadgentoo-2-0c2651e368a9f0e932d694dafffca41006a47cdd.tar.gz
gentoo-2-0c2651e368a9f0e932d694dafffca41006a47cdd.tar.bz2
gentoo-2-0c2651e368a9f0e932d694dafffca41006a47cdd.zip
Version bump and fix withsctp #181602.
(Portage version: 2.2_pre2)
-rw-r--r--net-misc/lksctp-tools/ChangeLog9
-rw-r--r--net-misc/lksctp-tools/files/lksctp-tools-1.0.8-as-needed.patch30
-rw-r--r--net-misc/lksctp-tools/files/lksctp-tools-1.0.8-prefix.patch13
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.8.ebuild31
4 files changed, 82 insertions, 1 deletions
diff --git a/net-misc/lksctp-tools/ChangeLog b/net-misc/lksctp-tools/ChangeLog
index a3ae0c528da9..ed05d309f3d2 100644
--- a/net-misc/lksctp-tools/ChangeLog
+++ b/net-misc/lksctp-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/lksctp-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/lksctp-tools/ChangeLog,v 1.10 2008/01/14 02:46:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/lksctp-tools/ChangeLog,v 1.11 2008/03/16 09:18:26 vapier Exp $
+
+*lksctp-tools-1.0.8 (16 Mar 2008)
+
+ 16 Mar 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/lksctp-tools-1.0.8-as-needed.patch,
+ +files/lksctp-tools-1.0.8-prefix.patch, +lksctp-tools-1.0.8.ebuild:
+ Version bump and fix withsctp #181602.
14 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
Metadata update.
diff --git a/net-misc/lksctp-tools/files/lksctp-tools-1.0.8-as-needed.patch b/net-misc/lksctp-tools/files/lksctp-tools-1.0.8-as-needed.patch
new file mode 100644
index 000000000000..3c862357e719
--- /dev/null
+++ b/net-misc/lksctp-tools/files/lksctp-tools-1.0.8-as-needed.patch
@@ -0,0 +1,30 @@
+fix static linking as well as --as-needed
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=1517981&group_id=26529&atid=387572
+
+--- lksctp-tools-1.0.6/src/apps/Makefile.in
++++ lksctp-tools-1.0.6/src/apps/Makefile.in
+@@ -8,8 +8,8 @@
+ INCLUDES = -I. -I$(top_srcdir)/src/include -I$(top_srcdir)/src/testlib
+ AM_CFLAGS = -g -Wall -Wstrict-prototypes -Wimplicit-function-declaration
+ AM_LDFLAGS =
+-LDADD = $(top_builddir)/src/lib/libsctp.la \
+- $(top_builddir)/src/testlib/libsctputil.la
++LDADD = $(top_builddir)/src/testlib/libsctputil.la \
++ $(top_builddir)/src/lib/libsctp.la
+
+ # programs to be installed with the distriubution
+ bin_PROGRAMS = sctp_darn sctp_test
+--- lksctp-tools-1.0.6/src/func_tests/Makefile.in
++++ lksctp-tools-1.0.6/src/func_tests/Makefile.in
+@@ -8,8 +8,8 @@
+ INCLUDES = -I. -I$(top_srcdir)/src/include -I$(top_srcdir)/src/testlib
+ AM_CFLAGS = -g -Wall -Wstrict-prototypes -Wimplicit-function-declaration
+ AM_LDFLAGS = -lpthread
+-LDADD = $(top_builddir)/src/lib/libsctp.la \
+- $(top_builddir)/src/testlib/libsctputil.la
++LDADD = $(top_builddir)/src/testlib/libsctputil.la \
++ $(top_builddir)/src/lib/libsctp.la
+
+ V6FLAGS = -DCONFIG_IPV6=1 -DTEST_V6=1 ${DEFS} ${INCLUDES} ${CFLAGS}
+
diff --git a/net-misc/lksctp-tools/files/lksctp-tools-1.0.8-prefix.patch b/net-misc/lksctp-tools/files/lksctp-tools-1.0.8-prefix.patch
new file mode 100644
index 000000000000..6e5808468d50
--- /dev/null
+++ b/net-misc/lksctp-tools/files/lksctp-tools-1.0.8-prefix.patch
@@ -0,0 +1,13 @@
+default @bindir@ expands to ${exec_prefix}/bin and default @exec_prefix@
+expands to ${prefix}
+
+--- src/withsctp/withsctp.in
++++ src/withsctp/withsctp.in
+@@ -1,5 +1,7 @@
+ #!/bin/sh
+ # -*- sh -*-
++prefix=@prefix@
++exec_prefix=@exec_prefix@
+ LIBDIR=@libdir@/@PACKAGE@
+ BINDIR=@bindir@
+ export LD_PRELOAD=${LIBDIR}/libwithsctp.so.1.0.6
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.8.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.8.ebuild
new file mode 100644
index 000000000000..6131fea64257
--- /dev/null
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/lksctp-tools/lksctp-tools-1.0.8.ebuild,v 1.1 2008/03/16 09:18:26 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
+HOMEPAGE="http://lksctp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lksctp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# I don't known if *BSD has the support needed at all
+# hence the lockdown to glibc and linux26-headers
+DEPEND=">=sys-kernel/linux-headers-2.6"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-prefix.patch #181602
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README ROADMAP doc/*txt
+}