summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-11 21:20:53 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-11 21:20:53 +0000
commit0bec9edfd292e420a8a7ac51c1729f934ee67ffe (patch)
tree950262cdad2459eed9fb82ee71f79b83b935f926
parentVersion bump; forgo tests when using JRuby for now. (diff)
downloadgentoo-2-0bec9edfd292e420a8a7ac51c1729f934ee67ffe.tar.gz
gentoo-2-0bec9edfd292e420a8a7ac51c1729f934ee67ffe.tar.bz2
gentoo-2-0bec9edfd292e420a8a7ac51c1729f934ee67ffe.zip
Version bump
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
-rw-r--r--x11-misc/i3status/ChangeLog7
-rw-r--r--x11-misc/i3status/i3status-2.5.1.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/x11-misc/i3status/ChangeLog b/x11-misc/i3status/ChangeLog
index 25348f34345c..d53464d2b3b2 100644
--- a/x11-misc/i3status/ChangeLog
+++ b/x11-misc/i3status/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/i3status
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/ChangeLog,v 1.7 2012/05/03 16:16:05 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/ChangeLog,v 1.8 2012/05/11 21:20:53 xarthisius Exp $
+
+*i3status-2.5.1 (11 May 2012)
+
+ 11 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +i3status-2.5.1.ebuild:
+ Version bump
*i3status-2.5 (03 May 2012)
diff --git a/x11-misc/i3status/i3status-2.5.1.ebuild b/x11-misc/i3status/i3status-2.5.1.ebuild
new file mode 100644
index 000000000000..c1b7e63f4e1e
--- /dev/null
+++ b/x11-misc/i3status/i3status-2.5.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/i3status-2.5.1.ebuild,v 1.1 2012/05/11 21:20:53 xarthisius Exp $
+
+EAPI=4
+
+inherit toolchain-funcs versionator
+
+DESCRIPTION="generates a status bar for dzen2, xmobar or similar"
+HOMEPAGE="http://i3wm.org/i3status/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+caps"
+
+RDEPEND="dev-libs/confuse
+ >=dev-libs/yajl-2.0.2
+ media-libs/alsa-lib
+ net-wireless/wireless-tools"
+DEPEND="${RDEPEND}
+ caps? ( sys-libs/libcap )"
+
+# borrowed from GSoC2010_Gentoo_Capabilities by constanze and flameyeys
+# @FUNCTION: fcaps
+# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
+# @RETURN: 0 if all okay; non-zero if failure and fallback
+# @DESCRIPTION:
+# fcaps sets the specified capabilities in the effective and permitted set of
+# the given file. In case of failure fcaps sets the given file-mode.
+# Requires versionator.eclass
+fcaps() {
+ local uid_gid=$1
+ local perms=$2
+ local capset=$3
+ local path=$4
+ local res
+
+ chmod $perms $path && \
+ chown $uid_gid $path
+ res=$?
+
+ use caps || return $res
+
+ #set the capability
+ setcap "$capset=ep" "$path" &> /dev/null
+ #check if the capabilitiy got set correctly
+ setcap -v "$capset=ep" "$path" &> /dev/null
+ res=$?
+
+ if [ $res -ne 0 ]; then
+ ewarn "Failed to set capabilities. Probable reason is missing kernel support."
+ ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
+ ewarn "where <FS> is the filesystem to store ${path}"
+ if ! version_is_at_least 2.6.33 "$(uname -r)"; then
+ ewarn "For kernel 2.6.32 or older, you will also need to enable"
+ ewarn "SECURITY_FILE_CAPABILITIES."
+ fi
+ ewarn
+ ewarn "Falling back to suid now..."
+ chmod u+s ${path}
+ fi
+ return $res
+}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -e "/@echo/d" -e "s:@\$(:\$(:g" -e "/setcap/d" \
+ -e '/CFLAGS+=-g/d' -i Makefile || die
+}
+
+pkg_postinst() {
+ fcaps 0:users 550 cap_net_admin "${ROOT}"/usr/bin/${PN}
+ elog "You need to install x11-misc/xmobar or x11-misc/dzen to use ${PN}."
+ elog "Please refer to manual: man ${PN}"
+}